Willkommen 

RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#101 von LDG , 27.02.2018 23:39

Hallo Eggon und Dirk,

Zitat

Zitat

Bleibt bei mir noch die Frage ob ich über die eine USB Schnittstelle mit dem PC + CV-Navi die RB administriere und mit meinem MAC - wg des gr. Bildschirms - Rocrail über die andere USB Schnittstelle parallel betreibe.

Das geht. Dann rate ich Dir sehr dazu, den PC über USB 1 (tams EsayControl) und den Mac über USB 2 (CP2102USB to UART Bridge Controller) an die RB anzuschließen. Siehe auch weiter vorne in diesem Thread bzgl. Mac: viewtopic.php?p=1593476#p1593476


Der Betrieb beider Schnitstellen gleichzeitig ist zwar machbar, aber man darf sich nicht wundern wenn es zu "seltsamen Effekten" kommt wenn zwei Steuerprogramme (z.B. CV-Navi und Rocrail) sich um die Zentrale und die darin konfigurierten Loks/Zubehördekoder/etc... "streiten".
Ich rate vom gleichzeitigen Betrieb beider Schnittstellen ab.

Entweder USB1 oder USB2 (bzw. USB oder RS232/seriell).

Gruß,
Lothar


Nächster Mist67 (Speyer) am 15.12.2021

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.218
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#102 von nakott , 28.02.2018 07:30

Hi Lothar,

aber genau das macht doch Tams selber mit der RB-Wlan oder dem wControl. Eine USB für den Wlan Adapter und eine USB für Steuerung vom PC aus. So ganz klar ist mir Deine Emphelung also nicht.

Man sollte vielleicht nicht gleichzeitig versuchen, die Konfig der RB zu ändern. Aber parallele Steuerung von Loks und Wagen geht sicher bestens.

Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 6.395
Registriert am: 04.07.2007


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#103 von LDG , 28.02.2018 08:37

Hallo Dirk,

Zitat
...aber genau das macht doch Tams selber mit der RB-Wlan oder dem wControl. Eine USB für den Wlan Adapter und eine USB für Steuerung vom PC aus. So ganz klar ist mir Deine Emphelung also nicht.

Man sollte vielleicht nicht gleichzeitig versuchen, die Konfig der RB zu ändern. Aber parallele Steuerung von Loks und Wagen geht sicher bestens.

Kersten "verkauft" auch keine Software zur Automatiksteuerung sondern nur erweiterte, unabhängige Handregler ( )
Nimm mal eine Lok die Deine Software (TC) auch gerade steuert auf einen Handregler und schalte das Licht ein und aus. Je nach Protokoll kommen bei F0 auch Fahrstufenkommandos mit. Weichen werden ohne Rücksicht auf verriegelte Fahrstraßen umgestellt...

Starte CV-Navi und programmiere einen Decoder auf dem Programmiergleis während die Anlage im Automatikbetrieb mit TC läuft. Es sind ja zwei unabhängige USB-Schnittstellen und bei Egon laufen die Programme noch dazu auf verschiedenen Rechnern. Also haben die doch nichts miteinander zu tun ...
... Du ahnst welche "Anfrage/Fehlermeldung" danach hier im Forum zu lesen ist.

Wenn man weiss was man tut (parallel zu Automatisierungssoftware maximal Handregler; selbst die können problematisch sein!) kann man beide Schnittstellen gleichzeitig nutzen; man sollte es aber nicht als "das funktioniert ohne Probleme und ich kann nur dazu raten" darstellen. Ich bin da eher etwas vorsichtiger.

Gruß,
Lothar


Nächster Mist67 (Speyer) am 15.12.2021

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.218
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#104 von Egon , 28.02.2018 09:33

Hallo Dirk, Lothar,
ich fahre ja seit Jahren mit der (alten) TAMS MC und Rocrail - soweit sogut. Ersatz für den Fall der Fälle soll die RB + Rocrail sein. Und obwohl beide Zentralen dieselbe Software haben sich die Unterschiede im Verhalten deutlich. Da stellt sich mir die Frage ob es nicht besser gewesen wäre den "Knopf" (Fahrtregler) doch wieder zu integrieren? Irgendeinen "Knopf" braucht es ja doch immer. Und ich möchte ja auch mal ganz schnell eine Lok testen ohne PC oder sonst etwas zu starten. Nun steckt jeder einen Handregler an die 2 Schnittstellen und muss damit leben. Eine RB mit dem TAMS Handregler handcontrol2 (?) sind in der Summe ja auch nicht wenig Geld.
Ich werde aber zuerst mal meine Erfahrungen mit der RB in aller Ruhe sammeln.
Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#105 von nakott , 28.02.2018 09:36

Zitat

Nimm mal eine Lok die Deine Software (TC) auch gerade steuert auf einen Handregler und schalte das Licht ein und aus. Je nach Protokoll kommen bei F0 auch Fahrstufenkommandos mit. Weichen werden ohne Rücksicht auf verriegelte Fahrstraßen umgestellt...


Hi Lothar,

das funktioniert richtig super. Sogar bekommt TC mit und zeugt es richtig an, dass ich am HC drehe oder Funktionen schalte. Es geht sogar so weit, dass bei einer Doppeltraktion, die nur TC bekannt ist, das Steuern der einen Lok über das HC bewirkt, dass TC für die andere Lok die passenden Fahrstufenbefehle sendet. Egal ob DCC, MM oder m3.

Von daher hätte ich keine Bedenken beim parallel Steuern von Loks und Weichen. Beim Thema Konfig bin ich aber ganz bei Dir.

Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 6.395
Registriert am: 04.07.2007


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#106 von LDG , 28.02.2018 13:32

Hallo Egon,

es gibt für die MasterControl eine Firmwarevariante "MC-Control" . Damit wird die MasterControl zu einer LokControl "degradiert" und kann dann (und nur dann!) am EasyNet der RedBox angeschlossen werden. Sie benötigt in diesem Zustand keine eigene Stromversorgung (kommt aus dem EasyNet der RedBox) und alle Ausgänge sind deaktiviert.
Wenn die MC dann wieder eine echte MC werden soll wird kann wieder die Firmwarevariante "MasterControl/RedBox" wie ein Update eingespielt werden.

Gruß,
Lothar


Nächster Mist67 (Speyer) am 15.12.2021

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.218
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#107 von Egon , 28.02.2018 18:57

Zitat

Hallo Egon,

es gibt für die MasterControl eine Firmwarevariante "MC-Control" . Damit wird die MasterControl zu einer LokControl "degradiert" und kann dann (und nur dann!) am EasyNet der RedBox angeschlossen werden. Sie benötigt in diesem Zustand keine eigene Stromversorgung (kommt aus dem EasyNet der RedBox) und alle Ausgänge sind deaktiviert.
Wenn die MC dann wieder eine echte MC werden soll wird kann wieder die Firmwarevariante "MasterControl/RedBox" wie ein Update eingespielt werden.

Gruß,
Lothar


Hallo Lothar,
danke für den Tipp - (ich war den Nachmittag unterwegs)
Ich werde aber beide Zentralen parallel betreiben, eine an der Anlage (Keller), die RB für Tests (Erdgeschoss). Ich will am bestehenden System nichts ändern. Trotzdem gut zu wissen, zumal das Update auch mal geübt werden will
Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#108 von Egon , 05.03.2018 09:18

Zitat von nakott im Beitrag Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

Hallo,

es gibt ein paar Neuigkeiten von Tams:

das Tams HandControl 2 wird nun laut Infos auf der Tams Webseite ausgeliefert.
.....
Grüße Dirk


Hallo Dirk, Interessierte,
der neue LENZ Handregler LH 101 gleicht vom Äusseren her dem TAMS Handcontrol wie ein Ei dem anderen. Sind die intern auch ähnlich oder gleich und wer stellt den nun letztendlich her? Könnte man einen LH 101 an einer RedBox wie ein Handcontrol nutzen?
Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#109 von ktams , 05.03.2018 11:26

moin,
das Gehäuse ist tatsächlich das gleiche. Ich beziehe das von Lenz. Die Innereien sind allerdings komplett anders.
Allerdings kann man den Lenz Handregler an den XpressNet Anschluss der RedBox anschließen. Damit kann man dann aber "nur" steuern und schalten. Einstellen geht nur mit der HC2
Gruß Kersten Tams


 
ktams
InterCity (IC)
Beiträge: 922
Registriert am: 02.05.2005
Homepage: Link
Spurweite H0
Stromart AC


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#110 von Egon , 05.03.2018 11:45

Hallo H. Tams,
Infos aus 1. Hand sind immer die Besten, danke.
Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#111 von nakott , 05.03.2018 21:00

Hallo Egon und Alle,

noch ein ganz wichtiger Hinweis:

Der Tams EasyNet-Stecker vom HC2 ist 8-polig
Der XpressNet-Stecker vom LH101 ist 6-polig

Man kann rein physisch problemlos den LH101-Stecker in die Tams EasyNet-Buchse der RB stecken, was die Buchse aber beschädigt. An der RB sind XpressNet-Buchse und EasyNet-Buchse nebeneinander an der Vorderseite angeordnet.

Daher ganz genau aufpassen, welchen Stecker man in welche Buchse steckt!!!!

Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 6.395
Registriert am: 04.07.2007


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#112 von MATS_MOBA , 13.07.2018 13:01

Hallo Dirk,

ich habe Deinen Beitrag für die Tams Redbox im Forum gefunden und finde diesen Super interessant.
Da ich in Digitalsteuerungstechnik ein Neuling bin, habe ich mich für Tams entschieden, unter dem Hintergrund das ist einfach, das bekomme ich auch hin.
Leider ist das nicht so, mein Laptop erkennt die RedBox und auch den Handregler, allerdings habe ich es nicht hin bekommen meine umgebauten Märklin Loks mit den Decoder LD-W-32.2 ans laufen zu brigen, es funktioniert nichts!!!

Gibt es eine eigene Anleitung für das Navi -CV von Tams?

Wenn ist das richtig verstehe,ist unter System mein Lok Decoder LD-W-32.2 aufgelistet und den kann ich mit den CV Daten beschreiben,
ich kann auch über Prog./Lokcontroll den Decoder programmieren?!

Bin für jede Hilfe dankbar!

Gruß aus DO
Martin


MATS_MOBA  
MATS_MOBA
Beiträge: 2
Registriert am: 10.07.2018


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#113 von nakott , 17.08.2018 08:58

Hallo Zusammen,

es gibt eine neue FW für Tams MC und RB: 2.1.1 (bisher 2.1.0)

Mit der FW 2.1.1 werden nun auch unter m3 Funktionen > F15 unterstützt. Bisher (bei FW <= 2.1.0) waren unter m3 nur die Funktionen F0-F15 ansprechbar.

Die neue FW kann bei Tams im Download Bereich heruntergeladen werden.

Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 6.395
Registriert am: 04.07.2007


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#114 von nakott , 23.09.2018 13:26

Hallo,

Es gibt ab jetzt eine Halterung für das Tams HandControl2. Infos hier: https://tams-online.de/epages/642f1858-c...jectID=49009453.
Die passt im Übrigen auch für den Lenz Regler LH101.

Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 6.395
Registriert am: 04.07.2007


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#115 von Egon , 03.10.2018 17:48

Zitat von nakott im Beitrag Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

Zitat von DiegoGarcia
Hast Du schon Gelegenheit gefunden, Deine Redbox an einen Macintosh zu hängen?

Hallo Diego,

... Die JRE finde ich auf dem Mac nun unter:

1
 
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home
 


Auf diesen Pfad habe ich JAVA_HOME besetzt. Denn leider brachte java_home Fehler und findet das installierte JRE nicht.

...

Grüße Dirk



Hallo Dirk,
falls du irgendwann einen Moment Zeit hast ...
Ich bin dabei CV Navi auf meinem iMac zu laufen zu bringen.
Im Moment treibt mich das blank

1
 
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home
 


zwischen Internet Plug-ins in den Wahnsinn.
Wenn ich CV-Navi.sh aufrufe passiert das folgende

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
 
BerndKnaaksiMac:CV-Navi berndknaak$ ./CV-Navi.sh 1
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home
INIT JAVA_OPTS
myNumLangParts= 3
JAVA_OPTS= -Duser.language=de -Duser.country=DE
calling $0=./CV-Navi.sh
SELF_PATH=/Users/berndknaak/Desktop/Bahn/CV-Navi
SELF_PATH=/Users/berndknaak/Desktop/Bahn/CV-Navi
PROG_DIR=/Users/berndknaak/Desktop/Bahn/CV-Navi
SYSTEMTYPE=x86_64
PROCESSOR=i386
uname: illegal option -- i
usage: uname [-amnprsv]
HARDWARE=
uname: illegal option -- o
usage: uname [-amnprsv]
OPERATINGSYSTEM=
Initialisiere JAVA_LIBRARY_PATH
Suche Bibliothek in: /usr/lib64/rxtx/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/rxtx-2/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/librxtxSerial.so
Suche Bibliothek in: /usr/lib/jni/librxtxSerial.so
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/lib/librxtxSerial.so
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/rxtx/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib64/rxtx-2/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib64/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib/jni/librxtxSerial.jnilib
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/lib/librxtxSerial.jnilib
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.jnilib
Bibliothek gefunden: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.jnilib
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -Djava.library.path=/Users/berndknaak/Desktop/Bahn/CV-Navi:. -Duser.language=de -Duser.country=DE -jar /Users/berndknaak/Desktop/Bahn/CV-Navi/KlarText.jar
./CV-Navi.sh: line 228: /Library/Internet: No such file or directory
BerndKnaaksiMac:CV-Navi berndknaak$
 
 


Hast du gelegentlich mal einen Tipp?
Danke
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#116 von LDG , 03.10.2018 22:29

Hallo Egon,

ich habe keinen Mac, deshalb nur mal unverbindliche Hinweise:

Wie (mit welchem Befehl) setzt Du die JAVA_HOME Umgebungsvariable ? Mit "export" ?

Eventuell die Umgebungsvariable mit "doppeltem Hochkomma" um den Pfad setzen:

1
 
export JAVA_HOME="/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home"
 


oder mit Backslash "" vor dem Leerzeichen (hier jedoch keine Hochkommas):

1
 
export JAVA_HOME=/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home
 



Bitte teile das Ergebnis mit. So wie oben mit der Ausgabe von

1
 
./CV-Navi.sh 1 
 



Gruß,
Lothar


Nächster Mist67 (Speyer) am 15.12.2021

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.218
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#117 von Egon , 04.10.2018 00:01

Hallo Lothar,
probiere ich morgen aus - vielen Dank
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#118 von Egon , 04.10.2018 10:41

Hallo Lothar,
leider kein Erfolg, hier das Ergebnis

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
 

BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$ export JAVA_HOME="/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home"
BerndKnaaksiMac:CV-Navi berndknaak$ ./CV-Navi.sh 1
INIT JAVA_OPTS
myNumLangParts= 3
JAVA_OPTS= -Duser.language=de -Duser.country=DE
calling $0=./CV-Navi.sh
SELF_PATH=/Users/berndknaak/Desktop/Bahn/CV-Navi
SELF_PATH=/Users/berndknaak/Desktop/Bahn/CV-Navi
PROG_DIR=/Users/berndknaak/Desktop/Bahn/CV-Navi
SYSTEMTYPE=x86_64
PROCESSOR=i386
uname: illegal option -- i
usage: uname [-amnprsv]
HARDWARE=
uname: illegal option -- o
usage: uname [-amnprsv]
OPERATINGSYSTEM=
Initialisiere JAVA_LIBRARY_PATH
Suche Bibliothek in: /usr/lib64/rxtx/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/rxtx-2/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/librxtxSerial.so
Suche Bibliothek in: /usr/lib/jni/librxtxSerial.so
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/lib/librxtxSerial.so
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/rxtx/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib64/rxtx-2/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib64/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib/jni/librxtxSerial.jnilib
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/lib/librxtxSerial.jnilib
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.jnilib
Bibliothek gefunden: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.jnilib
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -Djava.library.path=/Users/berndknaak/Desktop/Bahn/CV-Navi:. -Duser.language=de -Duser.country=DE -jar /Users/berndknaak/Desktop/Bahn/CV-Navi/KlarText.jar
./CV-Navi.sh: line 228: /Library/Internet: No such file or directory
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$ export JAVA_HOME=/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home
BerndKnaaksiMac:CV-Navi berndknaak$ ./CV-Navi.sh 1
INIT JAVA_OPTS
myNumLangParts= 3
JAVA_OPTS= -Duser.language=de -Duser.country=DE
calling $0=./CV-Navi.sh
SELF_PATH=/Users/berndknaak/Desktop/Bahn/CV-Navi
SELF_PATH=/Users/berndknaak/Desktop/Bahn/CV-Navi
PROG_DIR=/Users/berndknaak/Desktop/Bahn/CV-Navi
SYSTEMTYPE=x86_64
PROCESSOR=i386
uname: illegal option -- i
usage: uname [-amnprsv]
HARDWARE=
uname: illegal option -- o
usage: uname [-amnprsv]
OPERATINGSYSTEM=
Initialisiere JAVA_LIBRARY_PATH
Suche Bibliothek in: /usr/lib64/rxtx/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/rxtx-2/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/librxtxSerial.so
Suche Bibliothek in: /usr/lib/jni/librxtxSerial.so
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/lib/librxtxSerial.so
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.so
Suche Bibliothek in: /usr/lib64/rxtx/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib64/rxtx-2/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib64/librxtxSerial.jnilib
Suche Bibliothek in: /usr/lib/jni/librxtxSerial.jnilib
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/lib/librxtxSerial.jnilib
Suche Bibliothek in: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.jnilib
Bibliothek gefunden: /Users/berndknaak/Desktop/Bahn/CV-Navi/librxtxSerial.jnilib
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -Djava.library.path=/Users/berndknaak/Desktop/Bahn/CV-Navi:. -Duser.language=de -Duser.country=DE -jar /Users/berndknaak/Desktop/Bahn/CV-Navi/KlarText.jar
./CV-Navi.sh: line 228: /Library/Internet: No such file or directory
BerndKnaaksiMac:CV-Navi berndknaak$
 

 



Man sieht, dass beide Varianten zum gleichen Fehler führen. Das blank wird von der shell als Trenner ausgewertet und nicht als Teil des Dateinamens.
Ich habe mir CV-Navi vorher noch einmal von der TAMS Seite geholt.
Hast du noch eine Idee.
Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#119 von LDG , 04.10.2018 14:55

Hallo Egon,

Welche Java Version hast Du installiert ?

1
2
3
4
5
 
java -version
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version
/Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version
 
 


Mindestens eine der obigen Zeilen sollte eine Ausgabe beginnend mit "java version..." auswerfen.

Funktioniert bei Dir folgender Befehl direkt an der Kommandozeile?

1
 
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -Djava.library.path=/Users/berndknaak/Desktop/Bahn/CV-Navi:. -Duser.language=de -Duser.country=DE -jar /Users/berndknaak/Desktop/Bahn/CV-Navi/KlarText.jar
 

Das ist die dritte Zeile von oben Text ergänzt um ein "" direkt vor dem Leerzeichen (eventuell anpassen an die korrekte Ausgabe im ersten Abschnitt).

Wenn das nicht hilft schick mir Deine Telefonnummer per PN. Dann probieren wir mal ein paar andere Varianten durch.

Das Ergebnis kommt dann in das nächste CV-Navi-Startscript.

Gruß,
Lothar


Nächster Mist67 (Speyer) am 15.12.2021

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.218
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#120 von Egon , 04.10.2018 15:51

Hallo Lothar,

JAVA Version habe ich angehängt.
CV-Navi startet wenn von der Kommandozeile direkt eingegeben (s. code).
Nur habe ich noch keine Verbindung über USB. Der Treiber ist installiert und die Ausgabe kann du auch im code-block sehen. Wenn ich im CV-Navi (Optionen - Schnittstelle) /dev/tty.SLAB_USBtoUART angebe bekomme ich noch keine Verbindung zur RedBox. USB-Port "USB-2"
Aber nun bin ich doch ein Stück weiter. Bis hierher vielen Dank für deinen Einsatz.
Mit einem Windows PC klappt die Kommunikation zu meiner RedBox allerdings problemlos.
Hier die Ausgabe vom iMac

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
 
BerndKnaaksiMac:CV-Navi berndknaak$ 
BerndKnaaksiMac:CV-Navi berndknaak$ java -version
java version "10.0.2" 2018-07-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$ /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -Djava.library.path=/Users/berndknaak/Desktop/Bahn/CV-Navi:. -Duser.language=de -Duser.country=DE -jar /Users/berndknaak/Desktop/Bahn/CV-Navi/KlarText.jar
model[64] osName[Mac OS X] osArch[x86_64]
argc=0
decoderList verified successfully
Build: release 20171221a
CONNECT and not OPENED
java.lang.NullPointerException thrown while loading gnu.io.RXTXCommDriver
java.lang.NullPointerException thrown while loading gnu.io.RXTXCommDriver
NoSuchPortException EXCEPTION in CONNECT
jButtonEndActionPerformed mainWindowLocation=java.awt.Point[x=986,y=393]
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$ ls -l /dev/*SLAB*
crw-rw-rw- 1 root wheel 21, 5 4 Okt 15:20 /dev/cu.SLAB_USBtoUART
crw-rw-rw- 1 root wheel 21, 4 4 Okt 15:20 /dev/tty.SLAB_USBtoUART
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
 
 



netten Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#121 von LDG , 04.10.2018 17:22

Hallo Egon,

1
2
3
4
5
6
 
BerndKnaaksiMac:CV-Navi berndknaak$ java -version
java version "10.0.2" 2018-07-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)
BerndKnaaksiMac:CV-Navi berndknaak$
 
 


Du hast also schon Java 10 drauf und "java" wird auch im system-Suchpfad gefunden.
Damit musst Du die Umgebungsvariable "JAVA_HOME" gar nicht setzen.

CV-Navi 2.7 funktioniert mit Java 10 leider nicht mehr, da die bisher verwendeten Schnittstellenbibliotheken für USB/Seriell nicht mehr unterstützt werden
Nimm bitte eine CV-Navi-3.0-Vorabversion von hier: http://ldg.ddns.net/tams/test/
Dort sind die Schnittstellenbibliotheken bereits angepasst, aber es fehlen noch ein paar kleine Ergänzungen im Bereich Decoder, dann wird es die offizielle 3.0 werden

Auf Deinem Windows PC ist vermutlich Java (1.)8 oder (1.)9 installiert. Da geht CV-Navi 2.7 noch.

Gruß,
Lothar


Nächster Mist67 (Speyer) am 15.12.2021

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.218
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#122 von Egon , 04.10.2018 18:09

Hallo Lothar,
super - probiere ich nachher aus.
Mein Windows PC (den ich eigentlich nur für den ESU Lokprogrammer habe - Parallels und Windows Lizenz waren letztendlich teurer als dieser kl. Medion) hat Java 8 Update 161.

nette Grüße - auch als Rocrailer bernd68
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#123 von Egon , 05.10.2018 09:41

Hallo Lothar,
CV-Navi meldet sich mit "Version 3.0" und "beta 20180601c". Leider meldet es einen "Fehler!" "Probleme mit der Schnittstelle /dev/tty.SLAB_USBtoUART Verbinden/Öffnen fehlgeschlagen" Kann ich mit "OK" wegdrücken. Und CV-Navi beenden. Offenbar wird der Treiber/Schnittstelle nicht gefunden. Ich kann aber warten bis CV-Navi 3.0 frei gegeben wird. Ich habe keine Eile.
Hier noch die Konsolmeldungen zu meinem Versuch

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
 
BerndKnaaksiMac:CV-Navi berndknaak$ 
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$ ls -l /dev/tty*SLAB*
crw-rw-rw- 1 root wheel 21, 6 5 Okt 09:35 /dev/tty.SLAB_USBtoUART
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$ /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -Djava.library.path=/Users/berndknaak/Desktop/Bahn/CV-Navi:. -Duser.language=de -Duser.country=DE -jar /Users/berndknaak/Desktop/Bahn/CV-Navi/CV-Navi.jar
Mac OS X[x86_64] , java 10.0.2[64bit]
argc=0
decoderList verified successfully
Build: beta 20180601c
jButtonEndActionPerformed mainWindowLocation=java.awt.Point[x=1456,y=362]
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
BerndKnaaksiMac:CV-Navi berndknaak$
 
 



Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#124 von LDG , 05.10.2018 15:26

Hallo Egon,

an der Einbindung der Treiber wird bis zur finalen 3.0 nichts mehr geändert.

Es könnte jetzt an den fehlenden/unpassenden Berechtigungen für die Schnittstelle(n) liegen.

Wie bereits erwähnt habe ich kein Mac-OS zur Verfügung, deshalb die Befehle für Linux und bash. Das sollte unter aktuellem Mac-OS ähnlich gehen. Ohne Gewähr
Vielleicht kann hier jemand mit Mac-OS-Kenntnissen aushelfen.

Ist Dein Benutzer bereits in der Gruppe "wheel" ?

1
 
id
 


Wenn nicht, dann

1
 
sudo usermod -a -G wheel berndknaak
 

Abmelden und neu anmelden und mit "id" überprüfen ob der Benutzer jetzt auch in der Gruppe "wheel" ist.

Vielleicht geht es danach schon.

Aus anderer Quelle habe ich einen Eintrag im Skript bzgl. eventuell fehlender Berechtigung für das "lock"-Verzeichnis gemacht.
Bitte die Ausgabe von

1
 
 ls -la /var | grep lock
 



Eventuell auch die Ausgabe wenn Du CV-Navi.sh mit Parameter "-d" startest:

1
 
CV-Navi.sh -d
 

alternativ die Ausgabe mit der langen Startzeile, die Du bisher verwendet hast, ergänzt um " -d" .


Gruß,
Lothar


Nächster Mist67 (Speyer) am 15.12.2021

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.218
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams Zentrale RedBox, FW 2.2.1 und CV-Navi 3.0

#125 von Egon , 05.10.2018 16:34

Hallo Lothar,

probiere ich nachher aus. Danke

Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 711
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


   

ESU LoPi V3.0: Lebt er, oder lebt er nicht?

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
disconnected Foren-Chat Mitglieder Online 338
Xobor Einfach ein eigenes Forum erstellen
Datenschutz