RE: z21 findet Loks nicht !

#1 von gersat ( gelöscht ) , 29.11.2017 21:04

Hallo
Ich bin neu hier und hab mal gleich eine Frage :
Irgendwie kommt man ja nicht an "digital" vorbei,deshalb hab ich mir ein Roco Starterst z21 (weiß mit Multimaus und WLAN Set gekauft.
Was auch mit Originallok problemlos funktioniert-auch über iPad.
Dann kaufte ich noch gebraucht 3 Roco Loks mit Decoder ( 8 polig) welche aber nicht erkannt werden ! Dachte schon die Decoder sind kaputt.
Von einem Kollegen borgte ich ein älteres Startset Roco 51238 ebenfalls mit Multimaus und schwarzen 10764 ;das fand sofort die Adressen der alten
Loks und ich konnte alles steuern.
Die 2 Loks des alten Startsets funktionieren auch mit dem z21 aber die 3 alten Loks können keine Verbindung mit dem z21 herstellen.
Auch wenn ich die Adressen beim z21 eingebe.
Hab mir mal neue Decoder bestellt um ältere Loks umzurüsten ,hoffentlich funktionieren die dann mit dem z21.
Kennt jemand das Problem und hat eventuell eine Lösung - hab bis jetzt nichts gefunden.
Gerhard


gersat

RE: z21 findet Loks nicht !

#2 von Derrick23 , 29.11.2017 21:32

Decoder zurücksetzen, CV1 neu schreiben, fertig!


Derrick23  
Derrick23
CityNightLine (CNL)
Beiträge: 1.578
Registriert am: 13.08.2006
Gleise Roco Line
Spurweite H0
Steuerung TwinCenter
Stromart DC, Digital


RE: z21 findet Loks nicht !

#3 von stephan_bauer , 29.11.2017 22:52

Hallo Gerhard,

so wie Du es beschreibst, ist es nicht verständlich. Die z21 kann Loks nicht finden.
Beschreibe also genau, was Du machst, dass es mit der Multimaus und dem Verstärker funktioniert und was Du genau mit der z21 machst.

Grüße
Stephan


http://www.opendcc.de/


stephan_bauer  
stephan_bauer
InterCity (IC)
Beiträge: 661
Registriert am: 18.11.2007
Spurweite Z
Stromart Digital


RE: z21 findet Loks nicht !

#4 von gersat ( gelöscht ) , 30.11.2017 06:44

Hallo
Mit Multimaus und z21 bekomme ich keine Verbindung zu den Decodern der alten Loks.
Mit Multimaus und Verstärker 10764 sofort Verbindung zu alten Loks.

Da ich vorher keine Verbindung mit z21 herstellen konnte ,konnte ich auch nicht zurücksetzen !
Könnt ich aber jetzt mit der Verbindung über den Verstärker,werd ich machen !

Da alle sagten: Lok einfach draufstellen Adresse suchen ev CVs einstellen ,fürchtete ich schon einen Defekt des z21.

Gerhard


gersat

RE: z21 findet Loks nicht !

#5 von 1zu120 , 30.11.2017 07:23

Definiere doch mal was bei dir "Loks finden" bedeutet?
Lok aufs Gleis stellen und irgendwo (wo in einem Programm?) Adresse ablesen geht weder mit der 10764 noch mit der z21. Dazu braucht es Railcomfähige Rückmelder und eine entsprechende Railcom-Anzeige, wie eben in Steuerprogrammen oder externe Anzeigen.
CV's programmieren geht am besten am Rechner mit maintenance.exe von Roco (siehe z21.eu), hast doch LAN/WLAN.
Dann brauchst nur die CV 1 auslesen, Adresse testen - wenn diese nicht geht, dann ist eine "lange" Adresse aktiv. Sozusagen der Wert aus CV17 und Cv18. Mit der Multimaus an z21 auch wunderbar machbar - in den Programmiermodus gehen und nicht CV ändern, sondern mit den Pfeiltasten einmal nach rechts erscheint Lange Adresse und da OK drücken.


MfG Uwe
mein Blog Schmalspurmodule
Roco Z21, Roco-WLAN-Maus, z21App, Multimaus, Fredl, Servodecoder ESU, Schaltdecoder Decoderwerk


1zu120  
1zu120
InterRegioExpress (IRE)
Beiträge: 420
Registriert am: 19.03.2013
Ort: 1zu120
Spurweite TT


RE: z21 findet Loks nicht !

#6 von maybreeze , 30.11.2017 08:15

Servus,

alte Decoder - wieviele Fahrstufen?

neue Lok - wieviele Fahrstufen?


Liebe Grüße aus Wien
Klaus
------------------
© Sofern nicht anders angegeben stammen publizierte Fotos aus meiner Sammlung

🇦🇹 KLEINBAHN - ein (wesentliches) Stück österreichischer Modellbahngeschichte in 46 Fortsetzungen

24 Anlagen-Besuchstipps - war Maybreeze' Adventkalender 2023

🇦🇹 14. Wiener Stummi-Stammtisch (14.WIESTST) Do 5.9. ab 17 Uhr beim VMC in Leobersdorf


 
maybreeze
Metropolitan (MET)
Beiträge: 2.634
Registriert am: 13.02.2009
Ort: Wien
Spurweite H0, H0e
Stromart DC, Digital, Analog


RE: z21 findet Loks nicht !

#7 von 1001-digital , 30.11.2017 08:48

Hallo,
ich denke, das wird an den Decodern liegen. Die können vermutlich kein Railcom. Leg sie per Hand in der z21 an, dann sollte das auch funktionieren.

Viele Grüße
Carsten


 
1001-digital
InterCity (IC)
Beiträge: 806
Registriert am: 16.07.2015


RE: z21 findet Loks nicht !

#8 von gersat ( gelöscht ) , 30.11.2017 08:58

Hallo
Lok Adressen finden geht mit der Multimaus - Shift und Pfeiltaste im Lokmenü .
Was auch bei den neuen Loks funktioniert mit der z21!
Mit Multimaus und Verstärker 10764 finde ich auch die alten Loks.
Die alten Loks haben auch nur kurze Adressen - die ich auch ändern kann !
Davon hab ich eine auf 3 gestellt trotzdem nicht am z21 erkannt .
Welche Decoder verbaut sind kann ich nicht feststellen da gebraucht gekauft.
Hoffe am Wochenende Zeit zu finden mich mehr damit zu beschäftigen dann bringt die Tochter auch den Windows Laptop.
Am Mac möcht ich nichts installieren.
Gerhard


gersat

RE: z21 findet Loks nicht !

#9 von gersat ( gelöscht ) , 30.11.2017 09:06

Hallo
@1001digital

Wie soll mit der Hand auf z21 einstellen wenn ich keine Kommunikation mit dem Decoder bekomme ?
Bin im Büro kann jetzt nichts machen.

gerhard


gersat

RE: z21 findet Loks nicht !

#10 von 1zu120 , 30.11.2017 10:28

Welche Dekoder verbaut sind kann man immer feststellen.
In CV 8 steht der Hersteller, in CV250 bis CV253 dann der spezielle Typ und CV6 steht die Firmwareversion.
Der Wert in CV 8 bleibt auch mit dem schreiben von Wert 8 oder 0 immer erhalten. Diese Werte dienen nur dem Reset. CV 250 bis 253 und CV 6 sind nur lesbar.


MfG Uwe
mein Blog Schmalspurmodule
Roco Z21, Roco-WLAN-Maus, z21App, Multimaus, Fredl, Servodecoder ESU, Schaltdecoder Decoderwerk


1zu120  
1zu120
InterRegioExpress (IRE)
Beiträge: 420
Registriert am: 19.03.2013
Ort: 1zu120
Spurweite TT


RE: z21 findet Loks nicht !

#11 von egon II , 30.11.2017 10:39

....ich hab's gelöscht......


LG Egon II


 
egon II
InterRegioExpress (IRE)
Beiträge: 378
Registriert am: 15.01.2017
Spurweite H0
Stromart Digital


RE: z21 findet Loks nicht !

#12 von DerMödlinger , 30.11.2017 12:11

Servus an alle!

CV 6 ist die Mittengeschwindigkeit und nicht die SW-Version!
Und daher natürlich auch beschreibbar, sofern implementiert.

Die SW-Version steht meist in CV 7 und/oder anderen herstellerabhängigen CVs.

LG
AP


LG
DerMödlinger


DerMödlinger  
DerMödlinger
InterRegio (IR)
Beiträge: 154
Registriert am: 14.10.2017


RE: z21 findet Loks nicht !

#13 von gersat ( gelöscht ) , 30.11.2017 12:55

Hallo
Bevor das hier ausartet meine wichtigste Frage :
Muß ich annehmen ,dass die z21 nicht in Ordnung ist ?
Oder passiert das schon mal ,dass Loks die mit anderen Steuergeräten funktionieren mit der z21 nicht fahren ?
Ich bekomme die neuen Decoder erst in KW 50 dann kann ich hoffentlich mehr dazu sagen...

Gerhard


gersat

RE: z21 findet Loks nicht !

#14 von DerMödlinger , 30.11.2017 13:07

Servus Gerhard!

Wenn andere Loks problemlos fahren, ist ein Defekt der z21 unwahrscheinlich.
Nein, das passiert in der Regel nicht.
Prüfe bitte, ob die Anzahl der Fahrstufen richtig eingestellt ist.
Möglicherweise ist dies in den beiden Zentralen ja unterschiedlich.

Und auslesen sollte mit der z21 auf jeden Fall funktionieren.

LG
AP


LG
DerMödlinger


DerMödlinger  
DerMödlinger
InterRegio (IR)
Beiträge: 154
Registriert am: 14.10.2017


RE: z21 findet Loks nicht !

#15 von 1001-digital , 30.11.2017 16:24

Hallo Gerhard,
ich nehme an, du verwendest die App? Dort kannst du Loks manuell anlegen, musst aber eben die Adresse etc. kennen. Ebenso in der Multimaus: Adresse angeben und los. Oder verstehe ich dich falsch?

Wenn du die Adressen kennst und direkt versuchst damit eine Lok zu steuern, muss sich auch was tun. Probleme können die hier schon genannten Fahrstufen machen, die müssen in Decoder und Zentrale übereinstimmen. Außerdem gibt es einen Fallstrick bei den Adressen. Manche Zentralen definieren kurze Adressen bis 99, alles ab 100 ist eine lange. Andere definieren (normgerecht!) kurze Adressen bis 127, lange ab 128. Stellst du an einer Zentrale eine Adresse am Decoder z.B. auf 110, kann es sein, dass die Loks an anderen Zentralen nicht reagieren, weil 110 kurz auf technischer Ebene etwas anderes ist als 110 lang. Ich empfehle deshalb immer die Adressen 100 - 127 zu vermeiden. Witzigerweise ist es grade der "Normerfinder" Lenz, der die eigene Norm bricht. Sollte das dein Problem verursachen, kannst du die Adressen mit der z21 neu setzen oder besser auf andere Adressen ausweichen. Wie gesagt, bis 99 und ab 128 ist immer eindeutig, also problemfrei.

Viele Grüße
Carsten


 
1001-digital
InterCity (IC)
Beiträge: 806
Registriert am: 16.07.2015


RE: z21 findet Loks nicht !

#16 von gersat ( gelöscht ) , 01.12.2017 07:37

Hallo
Noch eine Frage :
Sind die Parameter der Loks in der Multimaus gespeichert oder in den Verstärkern bzw. z21 Box ?
Denn auch wenn ich die Multimaus vom 10764 (mit der die alten Loks fahren) an die z21 anstecke, fahren sie trotzdem nicht.
Kann es jetzt umgekehrt nicht sagen (muß ich Abends probieren).

Gerhard


gersat

RE: z21 findet Loks nicht !

#17 von 1zu120 , 01.12.2017 08:02

Hast Du eigentlich schon mal die Bedienungsanleitung und die FAQ auf der Seite z21.eu gelesen?
Auf jeden in den FAQ steht drin, dass der Verstärker 10764 NICHT als Booster an die z21/Z21 angeschlossen werden sollte/darf.
Aber Du kannst ruhig erst einmal weiter machen, deine Hardware zu zerstören oder ignorieren, was dir hier teilweise an Infos zukommt.
Grundsätzlich gilt:
Verstärker 10764 in Zusammenhang mit der Multimaus = die Multimaus ist die Zentrale und 10764 NUR Verstärker
z21 mit Multimaus = die z21 ist immer die Zentrale, Multimaus NUR ein Regler, in der Loks gespeichert werden können

Du hast am Anfang geschrieben, Du hättest ein WLAN-Package zur z21 dazu gekauft, ist das nun eingerichtet, kannst dich mit Rechner darauf verbinden? Hast Du dir die z21-maintenance.exe mal heruntergeladen und schon mal geschaut was damit alles geht?


MfG Uwe
mein Blog Schmalspurmodule
Roco Z21, Roco-WLAN-Maus, z21App, Multimaus, Fredl, Servodecoder ESU, Schaltdecoder Decoderwerk


1zu120  
1zu120
InterRegioExpress (IRE)
Beiträge: 420
Registriert am: 19.03.2013
Ort: 1zu120
Spurweite TT


RE: z21 findet Loks nicht !

#18 von drum58 , 01.12.2017 08:13

Hallo Uwe,

Zitat
Auf jeden in den FAQ steht drin, dass der Verstärker 10764 NICHT als Booster an die z21/Z21 angeschlossen werden sollte/darf.


Das hat Gerhard auch nicht geschrieben (und hoffentlich auch nicht gemacht).

Zitat
Verstärker 10764 in Zusammenhang mit der Multimaus = die Multimaus ist die Zentrale und 10764 NUR Verstärker
z21 mit Multimaus = die z21 ist immer die Zentrale, Multimaus NUR ein Regler, in der Loks gespeichert werden können.


Das ist entscheidend für Gerhards Aussage, dass beim Umstecken der Lokmaus die Loks an der z21 nicht vorhanden sind, obwohl er sie am Verstärker fahren kann.

Zitat
Du hast am Anfang geschrieben, Du hättest ein WLAN-Package zur z21 dazu gekauft, ist das nun eingerichtet, kannst dich mit Rechner darauf verbinden? Hast Du dir die z21-maintenance.exe mal heruntergeladen und schon mal geschaut was damit alles geht?


Das WLAN-Package ist zum Verbinden von PC und z21 nicht erforderlich, solange man nur mit dem Maintenance-Tool ausliest und programmiert und mit der Lokmaus fährt. Nur zum Fahren über PC und zur Verbindung mit Smartphone oder Pad braucht es das WLAN-Package. Entscheidend ist aber(egal ob mit oder ohne Package), dass PC und z21 im selben Netzwerk (also mit zusammenpassenden IPs) sind.

Gruß
Werner


drum58  
drum58
Metropolitan (MET)
Beiträge: 3.684
Registriert am: 17.01.2014
Homepage: Link
Ort: Moos-Bankholzen
Spurweite H0
Steuerung Lenz LZV 200 und LZV 100
Stromart DC, Digital


RE: z21 findet Loks nicht !

#19 von egon II , 01.12.2017 08:55

Zitat
...Das WLAN-Package ist zum Verbinden von PC und z21 nicht erforderlich, solange man nur mit dem Maintenance-Tool ausliest und programmiert und mit der Lokmaus fährt. Nur zum Fahren über PC und zur Verbindung mit Smartphone oder Pad braucht es das WLAN-Package. Entscheidend ist aber(egal ob mit oder ohne Package), dass PC und z21 im selben Netzwerk (also mit zusammenpassenden IPs) sind.



Wenn man denn beide mit Kabel miteinander verbindet..........
(wenn ich mich recht erinnere braucht man dann noch ein "gedrehtes" Kabel beim direkten zusammenstecken, aber das soll hier nicht verwirren

Mein PC ist mit dem Router, an dem die z21 steckt, über WLAN verbunden.
Wenn er schon das WLAN-Package hat, macht das durchaus Sinn.

Aber..... bei all den Bemerkungen des TE...

Weder mein Tablet, noch mein Smartphone noch das Maintenance Tool "findet" eine LOK.
Ich muss da schon die Adresse kennen/wissen.
Klar kann ich in der APP mir etwas mit Bild, Funktionstasten etc. zusammenstellen, aber die Adresse der Lok brauche ich immer noch.

Warum stellste die "neue" LOK nicht auf ein kleines Stück Gleis das direkt mit der z21 verbunden ist.
Sowohl mit dem Maintenance Tool, als auch mit der APP kannste die CVs auslesen.
So bekommste die Adresse heraus
CV 1 die Kurze und wie weiter oben schon beschrieben mit 17 und 18 und der Doku die lange.
Benutze die einfach


LG Egon II


 
egon II
InterRegioExpress (IRE)
Beiträge: 378
Registriert am: 15.01.2017
Spurweite H0
Stromart Digital


RE: z21 findet Loks nicht !

#20 von gersat ( gelöscht ) , 01.12.2017 09:07

Hallo
@ zilli
Mir wäre nie in den Sinn gekommen die beiden Systeme zu verbinden .
Und Ja ich hab die Bedienugsanleitung und FAQ gelesen.
@drum 58
Denke du hast mich verstanden.

@ egonII
Beiträge hatten sich überschnitten ..
Ich kenne ja die Lokadressen durch den Verstärker.
Aber wenn ich die Lok wieder aufs Gleis mit der z21 stelle und die Adresse eingebe ist keine Verbindung mödglich.

Könnte es sein ,dass es an der Stromverorgung liegt ?
Der Verstärker hat ja ein deutlich stärkeres Netzteil (AC) und nicht nur ein Steckernetzteil.

Allgemein zur Info
Ich bin elektrotechnisch kein Anfänger ,hab schon vor 40 Jahren Verstärker gebaut und diverse TTL Steuerungen für die analoge Modellbahn.
Aber mit programmierbaren Steuerungen hab ich mich noch nicht beschäftigt.
Seit vielen Jahren beschäftige ich mich hobbymäsig mit Sat Empfang und diversen Linux Receivern.
Durch meinen Enkel wird jetzt Modellbahn wieder aktuell und für Kinder sind halt die Möglichkeiten der digitalen Steuerung schon sehr wichtig!
Vor allem Anfahr und Bremsverzögerung und Richtungswechsel.Was sich analog nur mit größeren Aufwand machen lässt.(hab ich auch schon gebaut)

PS bekomme heute erst wieder meinen Windows Laptop .....

Gerhard


gersat

RE: z21 findet Loks nicht !

#21 von ralfio , 01.12.2017 09:40

[quote="egon II" post_id=1756532 time=1512114935 user_id=29917]
Weder mein Tablet, noch mein Smartphone noch das Maintenance Tool "findet" eine LOK.
Ich muss da schon die Adresse kennen/wissen.
Klar kann ich in der APP mir etwas mit Bild, Funktionstasten etc. zusammenstellen, aber die Adresse der Lok brauche ich immer noch
[/quote]

Das stimmt so nicht ganz. Mit der App kann man durchaus die Adresse auslesen. Da gibt es sogar eine extra Funktion dafür. Die hat aber auch ihre Tücken und funktioniert bei mir nur mit Dekodern ohne Stützkondensator zuverlässig.

@gersat
Schon mal die Multiprotokoll Funktion der z21 ausgeschaltet? Da brauchst du aber das Maintenance Tool. Vielleicht mögen deine alten Dekoder das gleichzeitig übertragene MM Protokoll nicht.

Gruß
Ralf


Gruß aus Down Under
Ralf


ralfio  
ralfio
InterCity (IC)
Beiträge: 573
Registriert am: 12.10.2010
Gleise Peco
Spurweite H0
Steuerung Z21pg, Z21, DR5000
Stromart Digital


RE: z21 findet Loks nicht !

#22 von 1001-digital , 01.12.2017 10:08

Hallo Gerhard

Zitat
Sind die Parameter der Loks in der Multimaus gespeichert oder in den Verstärkern bzw. z21 Box ?


Der Booster ist nur ein "dummer" Verstärker, alle Loks, die du in der Maus anlegst, werden in der Maus gespeichert. Das gilt auch, wenn du die Maus an die z21 oder eine andere Zentrale anstöpselst.

Bei der z21 und anderen Zentralen ist es so, dass dort zwar nicht nur ein dummer Booster drinsteckt, sondern auch das Gleissignal selbst darin erzeugt wird, Lokdaten sind aber nach wie vor nur in den Handreglern oder den Steuerprogrammen / Apps gespeichert.

Zitat
Denn auch wenn ich die Multimaus vom 10764 (mit der die alten Loks fahren) an die z21 anstecke, fahren sie trotzdem nicht.


Hast du denn mal die Hinweise bzgl. Fahrstufen und auch das mit der Adresse überprüft? Wie sind denn da die Ergebnisse? Ich finds bisschen schade, dass sich hier einige Leute die Finger wund tippen, aber von dir keine Rückmeldung kommt, ob du dich auch mal damit beschäftigt hast...

Viele Grüße
Carsten


 
1001-digital
InterCity (IC)
Beiträge: 806
Registriert am: 16.07.2015


RE: z21 findet Loks nicht !

#23 von gersat ( gelöscht ) , 01.12.2017 11:45

Hallo Carsten

Wie soll ich denn was überprüfen ,wenn ich egal mit welcher Maus über die z21 keine Verbindung zu der Lok/Decoder bekomme.
Entweder verstehe ich etwas total falsch ,aber wenn die Einstellungen in der Maus gespeichert sind müßten sie dann doch auch auf der z21 funktioniern.Es fahren ja die Loks mit beiden Mäusen an der 10764.
Hoffentlich finde ich am WE Zeit, da hab ich den Windows Laptop,mich mehr damit zu befassen.
Im Wirklichkeit gehts ja um nichts ; kann die 3 alten Loks ja mit der 10764 und Maus steuern.
Aber die Spielerei mit Steuerung über Tablet gefällt mir (und meinem Enkel) schon ganz gut.
Muß mich im Bekanntenkreis umhören ob jemand auch eine z21 hat zum ev.testen.
Mit neuen Decodern wirds ja dann hoffentlich problemlos gehen.

Gerhard


gersat

RE: z21 findet Loks nicht !

#24 von 1001-digital , 01.12.2017 12:26

Hallo Gerhard,
mit der Maus kannst du ja offenbar die Fahrzeuge steuern, weißt also, welche Adressen die haben -> Welche sind das? Auch die Fahrstufeneinstellung sollte so herauszufinden sein, wobei die ja beim Wechsel zwischen Maus-Booster und z21 mitgenommen werden sollte. Würde ich trotzdem nochmal prüfen und ggf. korrigieren.

Auch der Tipp mit dem MM-Protokoll könnte helfen. Schalte das testweise aus und probiers nochmal.

Viele Grüße
Carsten


 
1001-digital
InterCity (IC)
Beiträge: 806
Registriert am: 16.07.2015


RE: z21 findet Loks nicht !

#25 von maybreeze , 01.12.2017 12:46

Servus,

wenn das schon betagte digitale Loks sind (wie beschrieben/herauszulesen ist), bei denen der Decoder noch per Registerprogrammierung zu behandeln war (wie beispielsweise die ersten Roco/Lenz-Decoder 10741): Da hilft sinnvoll wohl nur ein Decodertausch zur einfachen Problembehebung und mehr Freude am Fahren.

Hier noch zum Lesen über die registerprogrammierten Decoder


Liebe Grüße aus Wien
Klaus
------------------
© Sofern nicht anders angegeben stammen publizierte Fotos aus meiner Sammlung

🇦🇹 KLEINBAHN - ein (wesentliches) Stück österreichischer Modellbahngeschichte in 46 Fortsetzungen

24 Anlagen-Besuchstipps - war Maybreeze' Adventkalender 2023

🇦🇹 14. Wiener Stummi-Stammtisch (14.WIESTST) Do 5.9. ab 17 Uhr beim VMC in Leobersdorf


 
maybreeze
Metropolitan (MET)
Beiträge: 2.634
Registriert am: 13.02.2009
Ort: Wien
Spurweite H0, H0e
Stromart DC, Digital, Analog


   


  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
Xobor Einfach ein eigenes Forum erstellen
Datenschutz