Willkommen 

RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#26 von Ingolf , 20.01.2018 16:46

Hallo Martin,

es ist vollbracht, alles läuft
Über WLAN und Tab, sowie Multimaus. Geht einwandfrei.
Ich habe noch einen Abschlußwiderstand 120 Ohm zwischen XNET_A und XNET_B gelötet.

Bitte schaue dir an:

https://www.opendcc.de/info/xpressnet/multimaus.html

besonders den letzten Abschnitt.

Nächsten Freitag wird das Teil im Club einem Stresstest unterzogen.

Die Buchse für den Booster-Anschluß ist schon mit auf der Platine, aber noch nicht angeschlossen, hier sehe ich noch nicht richtig durch.
Kennst du dich mit den Roco 10761 und 10764 aus ?

Ein paar kleine Arbeiten noch, Aussparungen in den Deckel sägen usw.

Am 11.2. veranstalten wir wieder mal eine Tauschbörse, da soll das Teil zum Einsatz kommen.

So, ich muß jetzt Fahrbetrieb aufnehmen !!

Dann kann ich mich auch mal wieder meinen anderen "Baustellen" widmen.

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#27 von Ingolf , 21.01.2018 15:37

Hallo Martin,
anbei ein paar Bilder,









Wie weit bist du ?

Auf einer meiner anderen "Baustellen" habe ich ein kleines Problem.
Vielleicht kannst du helfen.
Ich will bei einem Gurtwickler für eine Jalousie eine Fernbedienung einbauen.



Dies dürfte ein Festspannungsregler 5V (evtl auch 3,3V) sein.

Ich finde unter der Bezeichnung 8C626 leider kein Datenblatt.

Ich will eigentlich bloß einschätzen können, kann ich an den Regler noch ein Wemos D1 mini (ca 70 mA) hängen kann ?

Schönen Sonntag noch

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#28 von GPSSucher , 23.01.2018 13:48

Halo Ingo!

Das klingt sehr vielversprechend, was du da Berichtest!
Bei mir gibt's leider (noch) keine vorzeigbaren Fortschritte, letzte Woche fesselte mich die Arbeit bis in die Abende, und am Wochenende kamen mir 2 Feuerwehreinsätze dazwischen...
Beim Experimentieren am Breadboard hatte ich mir leider auch den TLE zerschossen, so das ich aktuell auf die nächste Lieferung aus China warten muss.
Hab mich momentan mit Fritzing darüber gemacht ein Layout zu erstellen, eventuell wage ich mich doch mal eine selbstgemachte Platine, wobei ich alle Stecker an einer Platinenseite haben möchte.

Was ich mich bei deinem Aufbau frage, die "Drumherumbeschaltung" für XPressnet, wo hast du die denn untergebracht? Auf der Unterseite des Protoshields?


Gruß,
Martin


GPSSucher  
GPSSucher
RegionalExpress (RE)
Beiträge: 99
Registriert am: 22.08.2012


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#29 von Ingolf , 23.01.2018 15:59

Hallo Martin,

TLE kaputt,

Auf der Platine mit den Buchsen habe ich nur den Abschlußwiderstand 120 Ohm und spaßeshalber noch einen Elko für die 12V.
Der IC MAX485 sitzt (zusammen mit der Diode) links oben auf der Huckepack-Platine auf dem MEGA. Mehr isses nicht.
Die Booster-Geschichte ist noch nicht bestückt.

Kannst du mir mit dieser Geschichte 8C626 was sagen ???

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#30 von GPSSucher , 23.01.2018 16:16

Hi Ingo,

Der 8C626 scheint mir ein Custom-IC zu den, konnte dazu auch nichts finden...sicher das es ein Spannungsregler ist?


Gruß,
Martin


GPSSucher  
GPSSucher
RegionalExpress (RE)
Beiträge: 99
Registriert am: 22.08.2012


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#31 von Ingolf , 23.01.2018 16:28

Hallo Martin,

nix Genaues weis man nicht.

Ich muß mal dran rum messen.

Danke und Grüße

Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#32 von GPSSucher , 23.01.2018 20:19

Hast du eine genaue Herstellerbezeichnung/Typenbezeichnung von dem Gerät?


Gruß,
Martin


GPSSucher  
GPSSucher
RegionalExpress (RE)
Beiträge: 99
Registriert am: 22.08.2012


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#33 von Ingolf , 24.01.2018 10:05

Moin,

Elektronischer Rollladen-Gurtwickler GW70.

Hersteller Superrollo Dresden.
Gekauft bei ELV.

Idee geklaut bei:

https://forum.fhem.de/index.php/topic,65563.0.html

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#34 von GPSSucher , 25.01.2018 09:57

Hallo Ingo,

Hmm, kann ich leider nix dazu sagen, ausser das ich davon ausgehe dass dein Gerät wahrscheinlich aus China kommt und nur umgelabelt ist - wenn du nun herausfindest, mit WELCHEM es baugleich ist, wäre man ggf. ein Stück weiter auf der Suche nach dem Schaltplan...

Zurück zur z21...

Wie ist denn die Boosterschnittstelle im Schaltbild zu sehen? Ich werd da nicht so ganz schlau daraus...ist J2 der Booster-Ausgang, und das im schraffierten Kasten der Boostereingang, z.b. am Roco 10761? Ich dachte immer das wäre der Xpressnet-Slave-Ausgang zum Anschluss weiterer Lok/Multimäuse?

http://pgahtow.de/wiki/images/Arduino_MEGA_Zentrale.png

Bin nur am Überlegen, da ich mir ja meinen TLE zerschossen habe und Nachschub noch auf sich warten lässt, einfach einen Roco 10761 zu verwenden - sprich, ich bastel mir die z21 mit LAN, WLAN und Xpressnet, und hänge den Rocobooster daran bis die TLE's da sind und ich meinen eigenen Verstärker nachbauen kann.


Gruß,
Martin


GPSSucher  
GPSSucher
RegionalExpress (RE)
Beiträge: 99
Registriert am: 22.08.2012


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#35 von Ingolf , 25.01.2018 10:47

Hallo Martin,

mit dem Gurtwickler ist nicht SO wichtig, laß mal sein, danke für deine Bemühungen.

Mit dem Z21-Schaltplan verstehe ich das so:

J2 ist der Anschluß für den 10761, der schraffierte Teil ist der Booster (ist ja eigentlich kein Booster), hier wird der MASTER-Anschluß
verwendet.
J6 wäre dann der Anschluß für Multimaus.
Deine Überlegungen sind gut, du mußt ja den internen Booster nicht verwenden.
Nur mal im Sketch schauen, ob der externe Booster aktiviert ist.
Ich kann dir auch einen TLE schicken, das Angebot steht noch. Schick mir per PN deine Adresse, und los geht´s.

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#36 von jochen3030 , 29.01.2018 13:10

Moin!

Habe den Thread eben erst entdeckt (man schaut ja nicht überall immer rein ), aber ich bin auch einer, der an der z21 von Herrn Gahtow "dran" ist, die selbst aufbauen und sogar erweitern will. Und ja, scheinbar ist Herr Gahtow schwer beschäftigt, leider ist es so, dass oft gar keine Antwort von Ihm kommt, oder so 20% dessen, was man eigentlich gefragt hat (bzw. auch Dinge, die man nicht gefragt hat und/oder anders...).

Jedenfalls hab ich mich mit dem Teil auch auseinander gesetzt, gerade der Schaltplan ist ja nicht ganz sauber dokumentiert, manches passte nicht und anderes musste man sich selbst zusammen denken. Ich finde daher den Thread hier sehr gut, denn es bringt ja nix, wenn 5 Leute Mühe und Arbeit haben, jeweils das Rad neu zu erfinden .

Was ich an Erkenntnissen habe/hatte möchte ich auch gern auflisten, alles bezieht sich auf die Variante für den Arduino MEGA (ATmega 2560):

  1. Der LN_IN, bzw. LN_Receive, hier muss entweder der entweder das eine, oder das andere auf Pin 48
  2. Es ist nicht ganz sauber dargestellt, aber am Anschluss J2 (XNet Booster) ist der Pin 5, dort muss wohl auch +12VDC dran.
  3. Am ESP01 (WIFI-Modul) ist am WIFI_RX ein Spannungsteiler eingebaut, soweit so gut. Besser wäre aber ein Logic-Level-Shifter, er zufällig genau für den ESP01 gedacht ist, damit wäre nicht nur "RX" abgedeckt, sondern auch "TX".
  4. TLE5205-2 Motortreiber. Etwas versteckt schreibt schon Herr Gahtow, dass man auch den TLE5206-2 verwenden kann. Der 5205 ist EOL und wird nicht mehr hergestellt, und die SMD-Version davon lässt sich nur schwerlich kühlen... . Der 5206 ist da besser zu bekommen .
  5. Der 74HC244N, da hab ich auch noch keine Ahnung zu einer Alternative. Denn der ist auch nur noch schwer (und überteuert) zu bekommen!
  6. Die Stromversorgung... . Die im Schaltplan ist mehr eine "grundsätzliche Abbildung". Wenn der Motortreiber schon 5A zieht, braucht man nicht mit 1A Spannungsversorgung herumspielen .


Ich selbst habe für mich folgende Lösung für die Spannungsversorgung:

  • Ein 200 Watt Netzteil für 12V (habe so eines von meinen 3D-Drucker übrig, das Teil hat mehr als genug "Dampf" für alles) und ist stabil, da nicht ausgereizt, klar, die Effizienz ist im Eimer, aber was soll's . Noch dazu wird bei mir der LocoNet-Teil recht stromhungrig! Wenn nun hier 2A, dort 3A und jenes noch mal 3A braucht, sind wir schon bei 8A... . Gerade wenn man überall was dran hängt!
  • Ein (ausrangiertes) Laptop-Netzteil für 20V für den Motortreiber und zwar NUR für den Motortreiber. Die Dinger bekommt man auch günstig für nen 10er in der Bucht... .
  • Der 7805 wurde durch einen XL4015 ersetzt, der deutlich belastbarer und leistungsstärker ist, einerseits hängt ja einiges am 5V-Strang, andererseits auch hier die Sicherheit, einfach nicht bis an die Belastungsgrenze zu gehen!



Noch warte ich selbst auch einige Teile, aber dann geht es auch bei mir an den Aufbau. In einem zweiten Schritt, soll dann ein CAN-Shield (CANdiy-Shield V2) für Märklin CAN dort integriert werden. Pinmäßig ist das geklärt, die Integration hatte Herr Gahtow mal angeboten, aber nachdem das schon ein paar Monate her ist und ich dazu von Ihm nichts mehr lese, wird es selbst umgesetzt werden. Hier geht's zum Thread!

Soweit dazu, ich hoffe, es hilft anderen auch! Bin gespannt, wie es hier weiter geht!

Gruß Jochen


 
jochen3030
InterRegioExpress (IRE)
Beiträge: 340
Registriert am: 12.11.2014


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#37 von orgel , 29.01.2018 15:54

Hallo Jochen,

mit 12V wirst Du vermutlich nicht weit kommen bei H0. Das Netzteil sollte meiner Meinung nach mind. 16 - 18V haben auch wenn Du Booster und Zentrale trennst. Ich habe ein Schaltnetzteil mit einstellbaren 12V, 15V, 16V, 18V, 19V, 20V, 24V bei 96W mit 4,5A. Ab einer bestimmten Anzahl von Modulen kommen noch mal Booster mit eigenem Netzteil dazwischen.

Um mehr dampf für das Loconet zu bekommen solltest Du die bekannten 15mA Pullup's verwenden um bei größeren Modulanlagen ausreichend Strom zu haben.


Bei mir sind auch noch nicht alle Teile angekommen, es fehlen immer noch die Platine und das Lan Shield
Gruß Uwe


orgel  
orgel
S-Bahn (S)
Beiträge: 17
Registriert am: 04.10.2012
Spurweite H0, N


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#38 von Ingolf , 29.01.2018 16:26

Hallo Jochen,

willkommen in unserer kleinen Runde.

Auch ich baue die ATmega 2560-Version, schon die 3. Variante. Eine mit einem sehr frühen Softwarestand, zu sehen auf Philipps Seite, mittlerweile
schon wieder auseinandergerissen. Die 2. Version mit Software 4.40, läuft im Club, funktioniert gut. Wir sitzen im Obergeschoß eines alten
Speichergebäudes, sehr geräumig. Aber das kleine ESP-Modul deckt es komplett ab.

Nun kam der Wunsch nach mehr Funktionalität auf, vor allem CV lesen/schreiben.
Ansonsten reicht das WLAN und der Multimaus-Anschluß (für Leute, die mit ihrem Handy nur telefonieren können ).
Unsere größte Anlage (und bisher einzige Digitalanlage) arbeitet noch mit Reedkontakten und mehreren herkömmlichen Schaltpulten, also werden
weitere Schnittstellen nicht gebraucht. Lediglich die Kabel an den Multimäusen waren lästig und immer zu kurz.

Ich selbst bin nicht der große Hard- und Software-Spezialist, aber um so ein Ding zusammenzubauen, reicht es.

Zu deinen angeführten Punkten:
1. bei der Loconet-Geschichte sehe ich auch nicht ganz durch, wird aber auch nicht realisiert.
2. Korrekt
3. Der Spannungsteiler reicht eigentlich, ich hatte nie Schwierigkeiten. Der MEGA erkennt das TX-Signal vom ESP auch bei dessen 3,3V-Pegel
korrekt.
4. Habe mir ein paar vom FC kommen lassen, war aber schon schwer, die Dinger zu finden.
5. Hier hatte ich keine Beschaffungsschwierigkeiten (Reichelt ???). Die liegen aber auch schon seit der ersten Version.
Ist aber momentan auch noch kein Thema. Wenn einige bauliche Maßnahmen an unserem Speicherdachboden abgeschlossen sind, wollen einer
meiner Kumpels und ich eine Voll-Digitalanlage aufbauen, dann werde ich S88 wohl nachrüsten.
6. Stromversorgung. Hier habe ich auch viel rumprobiert. Ich verwende jetzt auch ein Laptop-Netzteil, 18 V, 4,5A. Reicht für eine mittlere Anlage.
(Was hast du denn alles am Loconet zu hängen ?)
Für die 12V / 5V nehme ich DC/DC-Schaltregler, keine Sorgen mit Erwärmung, einen Raspi-Kühlkörper drauf, und löppt.
Für den ESP gibt es dann noch einen kleinen 3,3V-Regler.

Auf der anderen Seite habe ich für die Anlage (zu Hause) noch ein extra 5V-Steckernetzteil, meine Häusle-Beleuchtung läuft teilweise
ATTiny-gesteuert, Sound-Modul für die Kirchenglocken, ein Preisanzeiger für die Tankstelle, (ich hab die letzten 25 Jahre Tankstellen
repariert), Flackerlicht für ein Lagerfeuer......, alles selbst gebaut, ich habe ja die Zeit.

An dem CAN-Shield besteht kein Interesse, braucht bei uns niemand.

So, Jochen, soll erst mal reichen.

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#39 von jochen3030 , 29.01.2018 18:21

Hallo zusammen!

ich hab die Zitate hier drin gelassen, damit man noch weiß "was wieso wer". Also nicht wundern .

Zitat

Hallo Jochen,


Moin Uwe!

Zitat

mit 12V wirst Du vermutlich nicht weit kommen bei H0. Das Netzteil sollte meiner Meinung nach mind. 16 - 18V haben auch wenn Du Booster und Zentrale trennst. Ich habe ein Schaltnetzteil mit einstellbaren 12V, 15V, 16V, 18V, 19V, 20V, 24V bei 96W mit 4,5A. Ab einer bestimmten Anzahl von Modulen kommen noch mal Booster mit eigenem Netzteil dazwischen.


Sagen wir mal so, ganz so "neu" bin ich dann auch nicht . Die 12V sind für die Speisung vom LocoNet und vom XPressNet/RocoNet nötig und mit Boostern und Co. kenn ich mich ganz gut aus . Also danke für die Mühe, aber in dem Falle leider über's Ziel hinaus geschossen, macht nix .

Vielleicht hast Du meine Signatur gesehen, vielleicht nicht, jedenfalls bin ich der "Wahnsinnige", der sich die Mühe mit MiniMäx gemacht hat . Allein daher weiß ich schon einiges über Booster, Zentrale und Co., ich musste den ganzen Kram ja erst mal sortieren und verbinden .

Zitat

Um mehr dampf für das Loconet zu bekommen solltest Du die bekannten 15mA Pullup's verwenden um bei größeren Modulanlagen ausreichend Strom zu haben.


Nein, das ist so nicht ganz richtig. Es ist so, dass man damit das LocoNet-Signal gepullt wird, sprich, das innerste Ader-Pärchen eines normalen LocoNet Kabels. Jedenfalls soweit ich das gesehen hatte, irren ist menschlich . Mit der Stromversorgung von Geräten am LocoNet hat das nix zu tun. Und die bekommen (in diesem Falle) Ihre Stromversorgung über das äußerste Pärchen, die "Railsync"-Leitung, wie auch in der z21-Schaltung vorgesehen. Und das sind dort eben 12V. Ein LocoNet-Pullup ist im Schaltplan der Zentrale ja integriert, aber dennoch mein Dank für die Mühe .

Zitat

Bei mir sind auch noch nicht alle Teile angekommen, es fehlen immer noch die Platine und das Lan Shield
Gruß Uwe


Da wünsche ich Dir dann viel Geduld, ich warte auch noch auf einiges... .


Zitat

Hallo Jochen,

willkommen in unserer kleinen Runde.


Moin Ingo und Danke .

Zitat

Auch ich baue die ATmega 2560-Version, schon die 3. Variante. Eine mit einem sehr frühen Softwarestand, zu sehen auf Philipps Seite, mittlerweile
schon wieder auseinandergerissen. Die 2. Version mit Software 4.40, läuft im Club, funktioniert gut. Wir sitzen im Obergeschoß eines alten
Speichergebäudes, sehr geräumig. Aber das kleine ESP-Modul deckt es komplett ab.


Also ein wahrer Experte! Und gut zu wissen, dass der kleine ESP gut durch kommt.

Zitat

Nun kam der Wunsch nach mehr Funktionalität auf, vor allem CV lesen/schreiben.
Ansonsten reicht das WLAN und der Multimaus-Anschluß (für Leute, die mit ihrem Handy nur telefonieren können ).
Unsere größte Anlage (und bisher einzige Digitalanlage) arbeitet noch mit Reedkontakten und mehreren herkömmlichen Schaltpulten, also werden
weitere Schnittstellen nicht gebraucht. Lediglich die Kabel an den Multimäusen waren lästig und immer zu kurz.

Ich selbst bin nicht der große Hard- und Software-Spezialist, aber um so ein Ding zusammenzubauen, reicht es.


Joah, ist doch das wichtigste: Es funktioniert!

Zitat

Zu deinen angeführten Punkten:
1. bei der Loconet-Geschichte sehe ich auch nicht ganz durch, wird aber auch nicht realisiert.
2. Korrekt
3. Der Spannungsteiler reicht eigentlich, ich hatte nie Schwierigkeiten. Der MEGA erkennt das TX-Signal vom ESP auch bei dessen 3,3V-Pegel
korrekt.
4. Habe mir ein paar vom FC kommen lassen, war aber schon schwer, die Dinger zu finden.
5. Hier hatte ich keine Beschaffungsschwierigkeiten (Reichelt ???). Die liegen aber auch schon seit der ersten Version.
Ist aber momentan auch noch kein Thema. Wenn einige bauliche Maßnahmen an unserem Speicherdachboden abgeschlossen sind, wollen einer
meiner Kumpels und ich eine Voll-Digitalanlage aufbauen, dann werde ich S88 wohl nachrüsten.
6. Stromversorgung. Hier habe ich auch viel rumprobiert. Ich verwende jetzt auch ein Laptop-Netzteil, 18 V, 4,5A. Reicht für eine mittlere Anlage.
(Was hast du denn alles am Loconet zu hängen ?)
Für die 12V / 5V nehme ich DC/DC-Schaltregler, keine Sorgen mit Erwärmung, einen Raspi-Kühlkörper drauf, und löppt.
Für den ESP gibt es dann noch einen kleinen 3,3V-Regler.


Dann geh ich auch wieder "Step by Step durch:
1. LocoNet:
Eigentlich simpel, LocoNet wird (womit auch die Fragen zum LocoNet geklärt sind) in Zukunft für (größere) Modulanlagen verwendet, aber auch genauso bei mir zuhause. Ganz genau wird das für die FRED(I)'s (und ähnliche Geräte wie z.B. Uhlenbrock Daisy, Digitrax Geräte und diverse Eigenbauten) benötigt, eingesetzt und verwendet. Das Tolle am Loconet ist, dass man sich ausstecken und wo anders wieder einstecken kann, ohne dass man die Loks neu eingeben und/oder zuweisen muss . Aber dafür braucht man eben auch wieder genug "Saft", denn 10 FRED(I)'s á 300 mA sind auch allein schon wieder 3A. Die Roco Multimäuse sind auch durstig!
Details zum Modulbau dann in dem Link der Signatur, oben hab ich ja auch schon ein paar Worte dazu verloren .
3. Logic-Level-Shifter
Ok, wenn die Praxis zeigt, dass es auch so funktioniert, ist es gut!
4. Der Motortreiber
Ja, ich wollte mir auch welche aus China kommen lassen, da gibt es die noch. Aber nachdem der 5206 ja auch geht... . Theopraktisch werde ich den vermutlich sowieso nicht benötigen, wenn (in meinem Falle) die Signale durch die Eigenbau-CS2 an's Gleis gehen. Mal schaun .
5. 74HC244N
Bei Reichelt.de hab ich gesucht, ist mein Hauptlieferant. Irgendwie war ich (bei jedem der duzenden Male, bei denen ich nachgesehen habe) der Meinung, dass es sich dabei um den "74HC244" (ohne "N") gehandelt hätte. Hab eben nochmals nachgesehen und meinen Irrtum bemerkt, danke Dir!
6. Stromversorgung 12V/5V:
Ja, genau das ist der xl4015, ein DC-DC Spannungssregler, nur halt ein etwas stärkerer, der auch nicht teuer ist . Der ESP hat seinen 3,3V, klar!

Zitat

Auf der anderen Seite habe ich für die Anlage (zu Hause) noch ein extra 5V-Steckernetzteil, meine Häusle-Beleuchtung läuft teilweise
ATTiny-gesteuert, Sound-Modul für die Kirchenglocken, ein Preisanzeiger für die Tankstelle, (ich hab die letzten 25 Jahre Tankstellen
repariert), Flackerlicht für ein Lagerfeuer......, alles selbst gebaut, ich habe ja die Zeit.


Ja, ich bin gerade selbst dabei, diverse DCC-Selbstbau-Decoder für Signale und Servo's aufzubauen, Bauart "MicroBahner", gleichzeitig wird für DCC-Selbstbau-Decoder für Fahrzeuge, Bauart "Fichtelbahner" das Material bestellt . Eigenbau ist einfach günstiger und macht genauso Spaß!

Zitat

An dem CAN-Shield besteht kein Interesse, braucht bei uns niemand.


Joah, schade und zum Glück . Das Teil wird einfach Mühe, zur Not werd ich einfach Rocrail verwenden und dort beide Zentralen verknüpfen... .

Zitat

So, Jochen, soll erst mal reichen.

Grüße Ingo


Letztendlich habe ich vor, 2 Zentralen aufzubauen. Eine mit "Komplettausstattung" als Versuchsobjekt und eine weitere, mit den Bereichen, die ich wirklich brauche. Sprich: z21-Core, LocoNet, XPressNet, WLAN. Ohne Motortreiber, ohne LAN, ohne S88N. Das ist dann die 2. Ausführung .

Danke Euch und einen schönen Abend,

Gruß Jochen


 
jochen3030
InterRegioExpress (IRE)
Beiträge: 340
Registriert am: 12.11.2014


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#40 von GPSSucher , 30.01.2018 17:58

Hallo,

Nachdem ich mich doch schon ein paar Tage nicht mehr gemeldet habe, auch mal wieder ein Lebenszeichen von mir!

Offenbar sind wir doch einige Experimentierfreudige

Bei mir ist's momentan zeitlich sehr knapp, von daher warte ich jetzt erstmal die nächste Chinalieferung ab, da dürfte ein komplettes Überraschungspaket mit TLE's, MAX485, Buchsen, Spannungsreglern usw. kommen - bin gespannt...


Gruß,
Martin


GPSSucher  
GPSSucher
RegionalExpress (RE)
Beiträge: 99
Registriert am: 22.08.2012


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#41 von Ingolf , 30.01.2018 19:57

Hallo Jungs,

eine Geschichte muß ich noch loswerden.
Ich habe ja am Freitag meine Zentrale mit in den Club genommen, zum Probefahren.
Hat auch hervorragend geklappt, über eine Multimaus (der eine von den Jungs hat noch ein Oldtimer-Handy), 2 Handys und meinem guten
alten ASUS TF101-Tablet. Die Handys eingerichtet und los gings. Hat alles funktioniert und Spaß gemacht.

Bis jemand einen Kurzschluß gebaut hat.

Die Zentrale lief nicht mehr, offenbar hat die Kurzschlußerkennung nicht angesprochen. Man war ich down !
WLAN funktionierte noch, aber sonst ging nix.
Ein/Aus, hat alles nix gebracht.

Am WE in dem Ding rumgemessen, der TLE funktionierte lt. Philipps Logiktabelle noch.
Am Error-Ausgang des TLE war H-Pegel, so wie es sein soll.

Das Ding erst mal wutentbrannt in die Ecke.
Heute baue ich alles wieder auf - und es funktioniert wieder, bis auf CV lesen.

Hat jemand eine Idee ???

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#42 von franz_H0m , 31.01.2018 06:49

Hallo Ingo,

erstmal - Danke für diese Diskussion hier, die Gahtow-Zentrale steht auf meinem Plan und seinen Xpressnet-LAN Client habe ich für unseren Club schon vor längerem gebaut.

Du sagst, dass die Kurzschlusserkennung nicht funktionierte und jetzt CV-lesen nicht geht. Ich habe gerade keine Zeit zum Nachgucken, aber das sollte doch beides über den Sense-Anschluss des TLE gehen. Vielleicht sowas ganz blödes wie ein schlechter Kontakt zwischen Sense und A-in beim Mega?


Grüße, Franz

Mitglied bei den Lundarallarna.
Avatar: MAN-Zugmaschine der Ottensener Industriebahn (Foto: Dr. Ullrich Huckfeld).


 
franz_H0m
InterRegioExpress (IRE)
Beiträge: 495
Registriert am: 02.11.2008
Ort: Lund, Sweden
Gleise Tillig/Eigenbau
Spurweite H0m
Steuerung z21PG DCC
Stromart Digital


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#43 von franz_H0m , 31.01.2018 06:55

Zitat

Eigenbau-CS2



Kannst Du dazu was sagen?


Grüße, Franz

Mitglied bei den Lundarallarna.
Avatar: MAN-Zugmaschine der Ottensener Industriebahn (Foto: Dr. Ullrich Huckfeld).


 
franz_H0m
InterRegioExpress (IRE)
Beiträge: 495
Registriert am: 02.11.2008
Ort: Lund, Sweden
Gleise Tillig/Eigenbau
Spurweite H0m
Steuerung z21PG DCC
Stromart Digital


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#44 von orgel , 31.01.2018 08:50

Im Grunde sind es Zwei Ansätze auf Basis von Gerhard Bertelsmann's Hardware:

Gerhard Bertelsmann Hard und Software:
viewtopic.php?f=7&t=133541

Michael Bernstein Software.
viewtopic.php?f=7&t=131311

Gruß Uwe


orgel  
orgel
S-Bahn (S)
Beiträge: 17
Registriert am: 04.10.2012
Spurweite H0, N


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#45 von jochen3030 , 31.01.2018 09:40

Moin!

Zitat

Zitat

Eigenbau-CS2



Kannst Du dazu was sagen?




Da war Uwe einfach mal wieder deutlich schneller als ich .

Zitat

Im Grunde sind es Zwei Ansätze auf Basis von Gerhard Bertelsmann's Hardware:

Gerhard Bertelsmann Hard und Software:
viewtopic.php?f=7&t=133541

Michael Bernstein Software.
viewtopic.php?f=7&t=131311

Gruß Uwe


Ergänzend gäbe es auch noch die Version von "CAN-Digital-Bahn" (CDB):
http://www.can-digital-bahn.com/modul.ph...odul=54#Mod_Top

Um es genauer zu machen:

Die Lösung von Michael Bernstein und die von "CDB" benötigen immer eine MS2 als "Master" (Verwaltung/Zentrale), die von Gerhard Bertelsmann benötigt eine CS2.exe auf "irgendeinem" Rechner als "Master".

Ich verwende zzt. die Lösung von Gerhard Bertelsmann, bzw. eine der Lösungen, denn er hat da mehrere Versionen. Zum einen einen reinen Adapter, eine modifizierte Gleisbox die direkt an einen PC (WIN/MAC/UNIX) angestöpselt wird (da reicht auch ein seeeehr alter Thin-Client).
Dann gibt es Versionen für den BeagleBoneBlack, bzw. BananaPi und für den Raspberry Pi. Ich verwende hierbei die "Ursprungsversion", als Gleisbox-Adapter wie auf Gerd's Website vorgestellt: http://lnxpps.de/maerklin/gleisbox/ oder auch im Forum: viewtopic.php?f=7&t=127446

Denke das genügt für die Info, mehr in den verlinkten Threads, über die Suchfunktion oder gern auch per PN an mich selbst .
Wir kommen hier sonst komplett ins "Off-Topic", es soll ja hier um die "Eigenbau-z21" gehen und nicht um die CS2 Eigenbauten .

Gruß Jochen


 
jochen3030
InterRegioExpress (IRE)
Beiträge: 340
Registriert am: 12.11.2014


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#46 von Ingolf , 31.01.2018 11:14

Hallo Jochen,

wollen wir mal nicht so genau nehmen, es ist ja auch immer gut, über den Tellerrand zu schauen.
Und bei der Fülle an Beiträgen übersieht man auch das eine oder andere.

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#47 von franz_H0m , 31.01.2018 12:01

Danke für die OT-Erläuterungen hinter dem Tellerrand!


Grüße, Franz

Mitglied bei den Lundarallarna.
Avatar: MAN-Zugmaschine der Ottensener Industriebahn (Foto: Dr. Ullrich Huckfeld).


 
franz_H0m
InterRegioExpress (IRE)
Beiträge: 495
Registriert am: 02.11.2008
Ort: Lund, Sweden
Gleise Tillig/Eigenbau
Spurweite H0m
Steuerung z21PG DCC
Stromart Digital


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#48 von bertr2d2 , 31.01.2018 16:51

Hallo,

Zitat

Die Lösung ... von Gerhard Bertelsmann benötigt eine CS2.exe auf "irgendeinem" Rechner als "Master".


eine CS2.exe ist nicht zwingend notwendig. Es laufen Rocrail, M*rklinApp, RemoteCS2, WDP etc. pp. mit dieser Lösung auch ohne CS2.exe im Netz.

Gruß

Gerd


Smallest Rocrail Server Ever II ist jetzt Smallest Railroad Server Ever II
SRSEII -> SRSEII (Raider heisst jetzt Twix, sonst ändert sich nix )


bertr2d2  
bertr2d2
EuroCity (EC)
Beiträge: 1.248
Registriert am: 09.10.2012
Spurweite H0
Stromart Digital


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#49 von Holger28 , 31.01.2018 19:39

Hallo zusammen,

ich hoffe hier ein paar Mitstreiter zu finden, die mich bei der Zentrale von Philip Gahtow unterstützen können. Ich hatte vor einer Weile schon intensiven Kontakt mit ihm, da die TLE5205-S die ich gekauft hatte nicht die von ihm beschriebene Logik hatten sondern dem Datenblatt gehorchten. Nach mehreren Anläufen habe ich jetzt einen TLE5206 im EInsstz, der mit der Ver. 4.79 direkt läuft.

Meine Zentrale habe ich mit ESP, MEGA, ohne LN, XNET und S88 aufgebaut dafür aber den Railcom-Dekoder integriert. Schaltplan anbei. Beim Schaltplan ist mir allerdings IN1 und IN2 am Detektor nicht klar, da die Info von RAIL1 und RAIL2 kommen sollte. Hat den schon einer in Angriff genommen?

Das Auslesen der CV funktioniert bei mir leider gar nicht. Die Lok zuckt nur rum und wenn Werte ausgegeben werden, dann Zufallszahlen. Ich verwende übrigens neben der Zentrale nur die Z21-App.

Das #define Z21DATADEBUG habe ich einkommentiert, nutzt aber nichts.

Bei der Kurzschlusserkennung habe ich beide Punkte aktiviert, da auch beide (V_RAIL und CURRENT_SENSE) installiert sind.

Aufgefallen ist mir in dem Zitat von Philipp, dass er angibt, V_RAIL geht über den 100k an RAIL. Laut Schaltplan habe ich aber 100k an Bahnspannung und 4,7k an GND.

Könnte ihr auch bitte mal in meine Definitionen schauen, ob ich da was falsch verstanden habe?

Viele Grüße,
Holger

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
 
                                   CHANGE DOWN HERE THE CONFIGURATION
----------------------------------------------------------------------------------------------------------
Command Station Config:
=> uncomment ("//") the following lines, if you not USE the protokoll!
*/
/**************************************************************/
#define Debug Serial //Interface for Debugging
#define DebugBaud 115200 //Debug speed
#define DEBUG //To see DATA on Serial
//#define REPORT //To see Sensor Messages (LocoNet & S88)
//#define LnDEB //To see HEX DATA of LocoNet Protokoll
//#define XnDEB //To see XpressNet
#define Z21DEBUG //to see Z21 LAN control data
#define Z21DATADEBUG //to see DATA of Z21 LAN Protokoll
#define RCDEB //To see RailCom Data
 
/**************************************************************
Singel S88 Bus Interface (max 62 * 8 Module)*/
//#define S88N
 
/**************************************************************
WiFi ESP 8266 Z21 LAN Komunikation via Serial*/
#define WIFI
//#define Z21VIRTUAL //WiFi over SoftSerial for UNO only! - LAN and LocoNet will be inaktiv!
 
/**************************************************************
LAN W5100 Ethernet Z21 LAN Kommunikation*/
//#define LAN //Standard IP ist 192.168.0.111. Bitte diese IP nur über die Webseite (http://192.168.0.111) ändern!
//#define DHCP //Activate to Receive a IP Adress from the DHCP Server, if no DHCP found fix IP Adress vom EEPROM will be load.
#define HTTPCONF //Website to configure IP Adress and Number of S88 Bus Module
 
/**************************************************************
DCC RailCom Global Detector */
#define DCCGLOBALDETECTOR //activate the DCC Railcom Global Detector for MEGA on Serial Port 3 (RX only)
 
/*RailCom For Arduino UNO (!!!in testing!!!):*/
//#define RAILCOMI2C //I2C Reading for RailCom over external MCU (legacy: support only for UNO and Sanduino!)
 
/**************************************************************
DCC Decoder (only for MEGA, To decode a DCC-Signal, add this data to command station DCC output)*/
//#define DECODER //outdated!!!
 
/**************************************************************
XpressNet Master Interface*/
//#define XPRESSNET
//#include <XpressNetMaster.h>
 
/**************************************************************
LocoNet Master Interface (Timer1, Timer5 on MEGA)*/
//#define LOCONET
//#include <LocoNet.h>
//#define TXAllLokInfoOnLN false //sende alle Lok-Ereignisse ins LocoNet (MASTER-MODE only)
//#define LnSLOTSRV //Z21 DCC Arduino provide a Slot Server for Loco (MASTER-MODE)
 
/**************************************************************
Booster external: (zB. ROCO, CD[E])*/
//#define BOOSTER_EXT
//#define BOOSTER_EXT_ON HIGH
//#define BOOSTER_EXT_OFF LOW
 
/**************************************************************
Booster internal: (zB. TLE5205)*/
#define BOOSTER_INT
//#define BOOSTER_INT_ON LOW //only for old Mode without RAILCOM support over NDCC!
//#define BOOSTER_INT_OFF HIGH //only for old Mode without RAILCOM support over NDCC!
/*(GoIntPin) activate inverted booster signal*/
#define BOOSTER_INT_NDCC //for new RAILCOM Booster3R
/*(VAmpIntPin) activate the current sensor for prog track:*/
#define BOOSTER_INT_MAINCURRENT //MEGA, SANGUINO and for UNO only without external Booster,
/*(VAmpIntPin) activate SHORT CIRCUIT SENCE over MAINCURRENT*/
#define BOOSTER_INT_CURRENT_SHORT_DETECT //alternativ Short Circuit Detection over current sence resistor
 
/**************************************************************
DCC Master to create a DCC Signal:*/
#include <DCCPacketScheduler.h> //DCC Interface Library
//---------
#define SwitchFormat ROCO //ROCO (+0) or IB (+4) => Define Accessory Address start value!
 
#define FS128 //default Fahrstufen (Speed Steps) => possible values: FS14, FS28, FS128
/***************************************************************/
 
 


Holger28  
Holger28
Regionalbahn (RB)
Beiträge: 39
Registriert am: 31.01.2018
Ort: Bayern
Gleise Märklin M
Spurweite H0
Steuerung DCC z21PG, App, Rocrail
Stromart Digital


RE: Suche Erfahrungsaustausch zur Z21 nach Philipp Gahtow

#50 von Ingolf , 01.02.2018 08:18

Hallo Holger,

So manches mal sehe ich auch nicht mehr richtig durch. Ich schieße den Sketch unverändert auf den MEGA, lediglich #define Z21DATADEBUG
habe ich letztens aktiviert, dann kannst du über USB und den seriellen Monitor mitlesen, was passiert.

Ansonsten bin ich leider NICHT der Spezialist für Hard-und Software, fast alles in den letzten Jahren selbst mühsam angelesen.
Vielleicht einer der anderen Jungs ?

Du wolltest einen Schaltplan anhängen, reich mal bitte nach.

CV lesen und schreiben hat bei mir schon mal funktioniert, bis zu dem Kurzschluß im Club. Danach ging erst mal gar nix mehr.
Die Kurzschlußerkennung hatte nicht angesprochen (SHORT-LED blieb aus). Zentrale war nicht wieder zum laufen zu kriegen.
Kurioserweise läuft die Zentrale jetzt wieder, bis auf CV. Jetzt funktioniert auch die Kurzschlußerkennung.
Beim CV lesen ruckelt die Lok mehrmals und es wird immer der Wert 255 ausgegeben. Die 255 erhalte ich auch, wenn gar keine Lok auf
dem Gleis steht.

Meine Frage an alle:
Kann folgendes sein: im Kurzschlußfall dürfte ja kurzzeitig ein hoher Strom von +Gleisspannung über die H-Brücke im TLE und den 0,33 Ohm-
Widerstand nach GND fließen. Das heist, am den 0,33 Ohm liegt für den Moment eine recht hohe Spannung an. Und die zerschießt mir den
A9-Anschluß am MEGA.
Oder bin ich da auf dem Holzweg ????

V_RAIL kommt ja von dem Spannungsteiler 100k / 4,7k, sollte also ein statischer Wert sein. Mein Netzteil hat 16V, an dem Anschluß V_RAIL
messe ich (ohne das der MEGA mit dran hängt) 0,72V. Paßt also. Wenn der MEGA mit dran ist, habe ich einen schwankenden Wert, der höher
ist als die 0,72V. Die App zeigt konstant 65V Gleisspannung an.
Im seriellen Monitor taucht alle paar Sekunden folgende Zeile auf:

mA:0(509), V:16625, T:3

Ich denke dies sind Stromaufnahme am Gleis, Gleisspannung und der Temperatursensor.

Wie du siehst, habe ich selbst auch etliche Fragen, die ich auf diesem Wege zu klären versuche, mit Philipp ist es mir etwas zu mühsam
geworden.

Ich werde mir die Tage noch mal einen ganz neuen MEGA nehmen, und sehen was läuft. (Gaaanz vorsichtig, ohne einen Kurzen zu bauen)

Grüße Ingo


Ingolf  
Ingolf
InterRegioExpress (IRE)
Beiträge: 279
Registriert am: 30.08.2015


   

Arduino (Newbie) u Weichenantrieb "analog" : wie ?

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
disconnected Foren-Chat Mitglieder Online 95
Xobor Einfach ein eigenes Forum erstellen
Datenschutz