RE: FCC, Traincontroller, Lok fährt manchmal nicht :-(

#1 von herbi39 , 26.10.2018 15:37

Hallo zusammen,

ich habe folgendes Problem und hoffe, daß ihr mir da helfen könnt.

Meine FCC von D&H (mit Booster von D&H) nutze ich ausschließlich zum fahren (DCC).
Als Steuerungsprogramm verwende ich Traincontroller Gold 9

Wenn ich nun die FCC einschalte und eine Lok-Adresse wähle, kann ich ganz normal damit über den Handregler (Mobile Station 1) fahren.

Dann starte ich Traincontroller und kann auch darüber die Lok steuern.

Wenn ich aber die Lok nicht mit dem Handregler fahre, sondern TC direkt nach der FCC starte, kommt es immer wieder vor, daß die Lok nicht losfährt.
Obwohl im TC angezeigt wird, daß sie eigentlich schon unterwegs ist.
Es erscheinen auch keine Fehlermeldungen in TC!

Wähle ich die betroffene Lok auf der Mobile Station, erscheint die Meldung "Besetzt" im Display und es tut sich nichts.

Währenddessen kann mit anderen Loks aber problemlos von Hand oder über TC gefahren werden!

Das Problem betrifft nicht nur eine bestimmte Lok, sondern kann bei allen vorkommen!

Nun habe ich die Hoffnung, daß das Problem schon mal jemand hatte und lösen konnte, oder eine Idee hat, was ich noch probieren könnte.

Viele Grüße
Herbert


 
herbi39
InterRegio (IR)
Beiträge: 193
Registriert am: 06.11.2009
Homepage: Link
Spurweite N
Stromart DC, Digital


RE: FCC, Traincontroller, Lok fährt manchmal nicht :-(

#2 von Sx2Fan , 26.10.2018 21:51

Hallo Herbert,
das stellt sich für mich so dar als würde TC die Lok mit einer anderen Fahrstufenzahl also z.B. mit 14FS an der Stelle von 28FS/126FS ansprechen als eingestellt. Was auch zu Ungereimtheiten führt ist, wenn dieselbe Adresse über TC z.B. mit 28FS und parallel z.B. über die MS1 mit 126FS angesprochen wird. Das scheint an Hand deiner Schilderungen in deinem Fall aber nicht die Ursache zu sein. Trotz dem bitte Prüfe doch mal, ob TC den Decoder korrekt anspricht. Also kurze oder lange Adresse und mit welcher Fahrstufenzahl 14FS oder 28FS/126FS die TC-Software das tut. Nutze dazu doch mal den Bus-Monitor der MS1, um das zu prüfen (Klick auf Loksymbol bei der MS1 und dann am über Drehregler bis zum Menü "BUSLISTE" navigieren und diesen Menüpunkt durch Klick auf den Drehregler aktivieren. Dort dann durch die Liste der verfügbaren Buskanäle scrollen und nachsehen, was dort aufgelistet wird.)

Beste Grüße
Werner


Sx2Fan  
Sx2Fan
Regionalbahn (RB)
Beiträge: 46
Registriert am: 06.04.2007
Spurweite H0
Stromart Digital


RE: FCC, Traincontroller, Lok fährt manchmal nicht :-(

#3 von herbi39 , 27.10.2018 10:49

Hallo Werner,

da ich die MS1 resettet habe, ist die Busliste nun leer.

Das für mich unerklärliche ist, daß ich z.B. eine Lok mit TC auf ein Abstellgleis fahre, eine Runde mit einer anderen Lok drehe und dann die erste Lok wieder aus dem Abstellgleis fahren möchte.
Das kann mehrmals klappen, aber auf einmal kann ich eine der beiden Loks nicht mehr ansprechen. Auch das Licht lässt sich nicht schalten.
Die Lok hat aber auf jeden Fall Kontakt, denn der Belegtmelder zeigt dies ja an.
Wenn ich die Lok genau so stehen lasse und TC herunterfahre, ändert sich nichts.
Nach einem Neustart der FCC kann ich sie aber wieder ganz normal über die MS1 fahren.
Starte ich dann TC, gehts meistens auch noch, kann aber sein, daß nun eine andere Lok das genannte Problem hat.

Viele Grüße
Herbert


 
herbi39
InterRegio (IR)
Beiträge: 193
Registriert am: 06.11.2009
Homepage: Link
Spurweite N
Stromart DC, Digital


RE: FCC, Traincontroller, Lok fährt manchmal nicht :-(

#4 von Bayer ( gelöscht ) , 27.10.2018 11:28

Hallo Herbert,

hier mal einige Fragen zur Aktualität deines Systems:
FCC Firmware ist Version 1.12? MS1 hat 1.01? Die Schnittstelleneinstellungen am Rechner sind lt. Anleitung eingestellt und nochmals überprüft worden? Die FCC ist direkt mit einem USB2-Anschluß am Rechner eingesteckt, d.h. es wird kein USB-Seriell Adapter verwendet? Das USB-Kabel entspricht den Normen und wurde ggfs. schon mal getauscht?

Gruß
Wolfgang


Bayer

RE: FCC, Traincontroller, Lok fährt manchmal nicht :-(

#5 von herbi39 , 27.10.2018 15:00

@Wolfgang,

Firmware ist auf dem aktuellen Stand!
Alles andere ist auch so wie du geschrieben hast.

@Werner
ich habe alles probiert, leider ohne Erfolg.

Da ich aber mit der FCC von Anfang an nicht ganz glücklich bin, habe ich mir jetzt eine Digikeijs DR5000 bestellt

Die FCC werde ich nur noch für die Updates und Programmierung meiner D&H Decoder verwenden.

Die beiden D&H Booster sind nun zwar überflüssig, aber ich werde sie schon irgendwo an dem Mann bringen

Vielen Dank euch beiden
und ein schönes Wochenende
Herbert


 
herbi39
InterRegio (IR)
Beiträge: 193
Registriert am: 06.11.2009
Homepage: Link
Spurweite N
Stromart DC, Digital


RE: FCC, Traincontroller, Lok fährt manchmal nicht :-(

#6 von Sx2Fan , 27.10.2018 16:19

Hallo Herbert,

die Busliste wird nicht, wie du offensichtlich annimmst in der MS1 administriert, sondern direkt in der FCC. Insofern muss man die FCC reseten bzw. neu starten damit die Busliste leer wird. Um das noch mal zu verdeutlichen auch wenn TC eine DCC (oder SX2, MM) Lok anspricht und nicht die MS1 führt dies zu einem Eintrag in der sogenannten Busliste. Man könnte es auch so formulieren: Wird dafür in der FCC ein Bedienkanal belegt.

Der Menüpunkt Busliste wurde in der MS1 unter anderem dafür implementiert, dass man darüber die Kontrolle über eine ursprünglich an einem anderen Gerät - das könnte auch ein PC mit entsprechender Software gewesen sein, der dies direkt über das Interface der FCC getan hat - aufgerufen DCC-Lok einfach in der MS1 übernehmen kann.

Ein netter Nebeneffekt ist, dass man genau diese Busliste auch zur Analyse heranziehen kann, um zu ermitteln welche DCC-Adressen aktuell aktiv sind und von der FCC über das Gleis in welcher Art und Weise (kurze/lange Adresse, 14FS, 28FS, 126FS) angesprochen werden. Ganz exakt ist das nicht, denn die Busliste einer MS1 die an der 8-poligen Buchse der FCC angeschlossen ist kann nur 16 der 32 verfügbaren Bedienkanäle der FCC analysieren, da sie nur Zugriff auf den SX-Bus0 hat. (Zur Info: Ein Gerät, welches gleichzeitig Zugriff auf beide SX-Busse also SX-Bus0 und SX-Bus1 hat, kann alle 32 in der FCC verfügbaren Bedienkanäle überwachen. Nach einer marginalen Modifikation an der FCC ist so etwas z.B. mit der BTMS von Jochen Havekost möglich.)

Um es noch einmal deutlich zu sagen es spielt dabei absolut keine Rolle von welchem Gerät eine DCC-Datenausgabe ursprünglich initiiert wurde. Es führt zu einem Eintrag in der Busliste, da diese ein globale Liste ist, die in der FCC liegt. Diese Busliste gibt bei jedem Bedienkanal auch die Info aus, ob die dort hinterlegte DCC-Lok mit kurzen oder langen DCC-Adressen angesprochen wird und mit welcher Fahrstufenzahl dies erfolgt (14FS oder 28/126FS).

Aktiviere doch mal auf der MS1 gar keine DCC-Lok, sondern rufe mal einige (sagen wir 10 Stk.) dieser Loks direkt über die manuelle Bedienung von TC auf. Über die virtuellen Fahrregler von TC aktivierst du dann mindestens das Licht oder gibst eine Fahrstufe vor. Dabei spielt es absolut keine Rolle, ob die Lok tatsächlich auf dem Gleis steht.

Danach rufst du mal den Busmonitor an der MS1 auf und schaust nach, welche Einträge dort auftauchen und checkst diese auf Plausibilität hinsichtlich kurzer oder langer DCC-Adresse und speziell Anzahl der Fahrstufen. Stimmen diese Daten tatsächlich mit der Programmierung deiner entsprechenden Lokdecoder überein oder passt hier was nicht?

Ein Blick in den Busmonitor sollte auch helfen, wenn erneut eines - BTW deine Ausführungen in dem Ursprungspost korrelieren für mich mit dem, was du in #3 schilderst nicht - der von dir geschilderten Probleme auftritt. Hoffe du kommst dadurch der Ursache für die von dir geschilderten Phänomene doch noch auf die Spur und hast zumindest eine brauchbare Alternative zu der von dir georderten Digikeijs DR5000, bei der - was wir nicht hoffen wollen - eventuell neue Herausforderungen auftreten.

Ein paar weitere Informationen wären im Kontext mit deinen Problemen aber doch noch interessant: Nutzt du bei den Decodern kurze oder lange Adressen? Verwendest du 14FS oder 28/126FS? Welche Gleisprotkolle neben DCC hast du in der FCC aktiv (SX1, SX2, MM)? Hast du RailCom in der FCC aktiv oder ist das aus? Wie und mit welcher Spannung versorgst du die FCC? Da du offensichtlich D&H Decoder verwendest hast du diese schon mal auf Protokoll SX1 oder SX2 umgestellt? Tretten die Probleme dann auch auf?

Beste Grüße
Werner


Sx2Fan  
Sx2Fan
Regionalbahn (RB)
Beiträge: 46
Registriert am: 06.04.2007
Spurweite H0
Stromart Digital


RE: FCC, Traincontroller, Lok fährt manchmal nicht :-(

#7 von gabli , 03.11.2018 18:15

Hallo,

Zitat

FCC Firmware ist Version 1.12?


Aktuell ist aber Version 1.13

[attachment=0]03-11-_2018_18-06-37.pdf[/attachment]

Zitat
Die FCC ist direkt mit einem USB2-Anschluß am Rechner eingesteckt, d.h. es wird kein USB-Seriell Adapter verwendet? Das USB-Kabel entspricht den Normen und wurde ggfs. schon mal getauscht?


Ein USB-Seriell Adapter kann mit der FCC nicht verwendet werden, denn der USB-Seriell Adapter befindet sich in der FCC selber (keine "echte" USB-Schnittstelle im Gegensatz zum D&H Programmer, der hat eine "echte" USB Schnittstelle! Wichtig ist aber, dass ein aktueller Treiber von D&H bzw. FTDI verwendet wird. Meine FCC funktioniert jedenfalls einwandfrei, wobei ich mit iTrain steuere.

Freundliche Grüsse

Gian


Windows 11 Pro 64bit 23H2 22631.3447
PC Shuttle Mini DH470, Intel i9/32GB-RAM
iTrain Pro 5.1.12.325b
JAVA 22 (Bellsoft)
LoDi: Fahren (nur DCC), Schalten, Melden (seit 2021)
Ausnahme: H0: Melden mit SX1-BUS und teilw. Schalten (Stärz ZS2 Mainboard Anschluss RS232)
3 LoDi-Con WLAN Handregler mit LoDi-Rektor direkt verbunden
Mein Youtube Kanal
Wer billig kauft, kauft doppelt!

Dateianlage:
Sie haben nicht die nötigen Rechte, um die angehängten Dateien zu sehen

 
gabli
InterRegioExpress (IRE)
Beiträge: 345
Registriert am: 14.08.2015
Ort: ZH
Spurweite H0, H0m
Stromart Digital


   


  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
Xobor Einfach ein eigenes Forum erstellen
Datenschutz