Willkommen 

RE: Qdecoder und PIKO Weichenantrieb Problem

#1 von helmi77 , 21.03.2021 12:32

Hallo! Da ich etwas am Verzweifeln bin mit dem Qdecoder und mein Wissen im Bereich der Digitaltechnik enden wollend ist erlaube ich mir hier um Rat zu fragen. Ich versuche probeweise den Doppelspulen Weichenantrieb von PIKO (#55271) mit dem ZA1-16 von qDecoder zu steuern. Zu diesem Zweck verwende ich einen Arduino mit Motorshield und DCC++ als Zentrale. Das Motorshield und der qDecoder bekommen 12V DC über ein separates Netzteil. Meine Herangehensweise war dabei folgende:

  • qDecoder an Programmiergleis angeschlossen
  • Ausgang 3 (CV 555) Adresse 126 zugeordnet
  • Modus von Ausgang 3 (CV 556) auf Impulsbetrieb gesetzt (Wert 20)
  • qDecoder wieder an Hauptgleis angeschlossen
  • Weichenantrieb (die beiden schwarzen Kabel) an Ausgang 3 und 4 angeschlossen, rotes Kabel an blaues "+" vom qDecoder
  • In der JMRI Software die Weiche eingetragen mit Adresse 126 und betätigt

Der Effekt ist, dass die Weiche einmal erfolgreich umspringt und der Decoder im Anschluss komplett einfriert. Es ist weder ein weiterer Schaltvorgang noch ein Reset per Knopfdruck möglich (Kontroll-LED leuchtet nicht mehr). Die Zentrale funktioniert trotz allem unverändert weiter, nur der qDecoder mag nicht so recht. Erst nach Trennen des qDecoder vom Stromkreis und erneutem Anschluss lässt er sich wieder zurücksetzen. Hat jemand eine Idee für mich woran das liegen könnte?

Danke im Voraus!


helmi77  
helmi77
Beiträge: 4
Registriert am: 21.03.2020
Gleise Pico
Spurweite H0
Stromart Digital


RE: Qdecoder und PIKO Weichenantrieb Problem

#2 von schotterbruno , 07.04.2021 22:26

Hallo Helmi

Grundsätzlich scheint der Piko Weichenantrieb ein problemloser Antrieb zu sein und sollte mit dem Qdecoder ansteuerbar sein.

Gemäss Deiner Beschreibung hast Du alles richtig gemacht. Also muss das Problem beim Zusammenspiel mit dem Arduino mit Motorshield zu sein.
Eine kurze Sicht in die Beschreibung des Arduinos scheint mir, dass dies ein Antrieb für Motoren ist. Hat also nichts mit einem Magnetantrieb zu tun.
Ein Motorantrieb braucht immer eine Umpolung. Also lass mal den Arduino aus und vor.

Im Prinzip solltest Du den Decoder nur mit Deiner DCC Zentrale schalten können, bei der die Adresse 126 für die Weiche hinterlegt ist.

Falls Du nicht weiter kommen solltest, kannst du mich über Qdecoder erreichen. Dann können wir das besprechen.
Die Lösung des Problems werden wir dann hier für alle publizieren.

Liebe Grüsse
Bruno Ineichen


Mä K-Gleis, Lenz DCC (Fahren und Schalten getrennt), Blücher GBM16XN mit Loconet für die Rückmeldung, TC 8 Gold. Qdecoder für Weichen und Signale. Meine private Anlage Eichenstadt


schotterbruno  
schotterbruno
InterRegio (IR)
Beiträge: 178
Registriert am: 09.07.2012
Spurweite H0
Steuerung DCC
Stromart Digital


RE: Qdecoder und PIKO Weichenantrieb Problem

#3 von Modelltraumland , 08.04.2021 11:01

Hallo Bruno,

der Arduino mit Motorshield und dcc++ ist seine Zentrale. Der Arduino dient hier nicht als Decoder.


VLG Bernd

Tillig Elite H0, 2-Leiter, Rocrail mit Tams MC DCC (Loks), IB-com MM (Weichen Signale), GCA101 Loconet (Rückmeldung), DC-Car, Light@Night Lichtsteuerung, Ampelsteuerung Arduino http://www.modelltraumland-wuppertal.de/


Modelltraumland  
Modelltraumland
InterCity (IC)
Beiträge: 839
Registriert am: 27.01.2017
Homepage: Link
Gleise Tillig Elite
Spurweite H0
Stromart Digital


RE: Qdecoder und PIKO Weichenantrieb Problem

#4 von helmi77 , 08.04.2021 18:07

Hallo nochmal und vielen Dank für die Antworten! Modelltraumland hat richtigerweise ergänzt, dass der Arduino und das Motorshield bei mir als Zentrale fungieren und im wesentlichen den Bahnstrom und das DCC-Signal liefern.


helmi77  
helmi77
Beiträge: 4
Registriert am: 21.03.2020
Gleise Pico
Spurweite H0
Stromart Digital


RE: Qdecoder und PIKO Weichenantrieb Problem

#5 von Modelltraumland , 08.04.2021 18:56

Hallo helmi77 (Helmut?),

wie hast Du die externe Stromversorgung des Motorshields und des Decoders realisiert?`Beides mit eigenem Netzteil oder gemeinsam am selben Netzteil?


VLG Bernd

Tillig Elite H0, 2-Leiter, Rocrail mit Tams MC DCC (Loks), IB-com MM (Weichen Signale), GCA101 Loconet (Rückmeldung), DC-Car, Light@Night Lichtsteuerung, Ampelsteuerung Arduino http://www.modelltraumland-wuppertal.de/


Modelltraumland  
Modelltraumland
InterCity (IC)
Beiträge: 839
Registriert am: 27.01.2017
Homepage: Link
Gleise Tillig Elite
Spurweite H0
Stromart Digital


RE: Qdecoder und PIKO Weichenantrieb Problem

#6 von helmi77 , 08.04.2021 18:58

Die hängen gemeinsam am selben Netzteil.
LG helmi


helmi77  
helmi77
Beiträge: 4
Registriert am: 21.03.2020
Gleise Pico
Spurweite H0
Stromart Digital


RE: Qdecoder und PIKO Weichenantrieb Problem

#7 von Modelltraumland , 08.04.2021 19:06

Hi,,

versuchs mal mit jeweils einem eigenen Netzteil/Trafo. Der Decoder kann ja wohl auch mit Wechselspannung versorgt werden. Vielleicht bringt das ja was.


VLG Bernd

Tillig Elite H0, 2-Leiter, Rocrail mit Tams MC DCC (Loks), IB-com MM (Weichen Signale), GCA101 Loconet (Rückmeldung), DC-Car, Light@Night Lichtsteuerung, Ampelsteuerung Arduino http://www.modelltraumland-wuppertal.de/


Modelltraumland  
Modelltraumland
InterCity (IC)
Beiträge: 839
Registriert am: 27.01.2017
Homepage: Link
Gleise Tillig Elite
Spurweite H0
Stromart Digital


RE: Qdecoder und PIKO Weichenantrieb Problem

#8 von helmi77 , 08.04.2021 19:11

Werde ich probieren, danke!


helmi77  
helmi77
Beiträge: 4
Registriert am: 21.03.2020
Gleise Pico
Spurweite H0
Stromart Digital


   

lineare Kennline mit Zimo MX645R ?
Decoder aus Märklin 60760 Einstellmöglichkeiten?

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
disconnected Foren-Chat Mitglieder Online 81
Xobor Einfach ein eigenes Forum erstellen
Datenschutz