Willkommen 

Lokpilot V4.0 Transistor abgeraucht

#1 von Jack01 , 13.09.2021 11:59

Moin liebes Forum,
ich bin seit längerer Zeit stiller Mitleser in diesem Forum. Heute habe ich mich mal angemeldet, da ich eine Frage zu dem Lokdecoder "LokPilot 4.0" habe.
Ich selbst habe keine Modellbahn, helfe aber meinem Nachbarn bei elektronischen Problemen. Ich bin gelernter Elektroniker im Ruhestand (aber SMD-löten geht noch).
Nun zu meinem Problem:
Beim Umbau einer Lok auf den o. g. Dekoder ist aus irgendeinem Grund ein Transistor abgeraucht. Es ist einer der Transistoren, die den Motor steuern. Trotz längerer Suche im Netz ist es mir bis jetzt nicht gelungen, den Transistor zu identifizieren oder einen Schaltplan zu finden. Die Bezeichnung lautet "039L". Davon sind insgesamt 2 Exemplare auf dem PCB verbaut. Das Einzige das ich gefunden habe ist der Typ "39L". Das ist aber ein Voltage Regulator von Anpec.
Ich habe den aufgebrannten Transistor mal durch einen N-Kanal Mosfet ersetzt. Damit läuft der Motor zwar wieder, aber nur in eine Richtung und er lässt sich auch nicht regeln. Bei Gelegenheit werde ich nochmal einen P-Kanal Mosfet versuchen (habe zurzeit keinen).
Hat hier jemand einen Tip für mich, um welchen Typ es sich hier handelt?
Gruß

Hans-Jürgen


Jack01  
Jack01
Beiträge: 5
Registriert am: 13.09.2021


RE: Lokpilot V4.0 Transistor abgeraucht

#2 von jogi , 13.09.2021 19:46

Hallo , jogi hier


Die Motor Regelung erfolgt über eine H Brücke.
2 N in einem Gehäuse und 2 P in einem Gehäuse.
IFR7103 = N, IFR7342 = P
Die Ausgänge sind immer an 2 Pins zusammgefast.
https://www.infineon.com/dgdl/Infineon-I...15355f665771b69

https://www.infineon.com/dgdl/Infineon-I...15355f0f0141ac6



Die Teile ( 8 Pins ) lassen sich austauschen, wenn man die Leiterbahn nicht beschädigt.

Beinchen abknipsen und dann die restlichen vorsichtig ablöten.

Zu Umbau auf digital:
Bei älteren Loks ist oft ein Motoranschluss mit dem Rahmen verbunden. ( Rahmen hat Verbindung zum Gleis )
Wenn das beim Umbau nicht beachtet wird ( Verbindung muß aufgetrennt werden ), geht die Motorendstufe in Rauch auf. Ist vielleicht auch hier die Ursache.


Viel Erfolg


Bastelnde Grüße Jogi ;
Elektronische Bauteile kennen 3 Zustände:Ein-Aus-Kaputt".
K-Gleise,DCC mit IB .CS2 nur Test Mfx freie Zone.MoBa MÄ seit 1954.
Jogis Bahn
mein letzter Umbau


Langsamfahrer und Jack01 haben sich bedankt!
jogi  
jogi
Metropolitan (MET)
Beiträge: 3.669
Registriert am: 13.06.2005
Ort: NRW
Gleise K - Gleise
Spurweite H0
Stromart Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#3 von Jack01 , 14.09.2021 15:35

Moin Jogi,

danke für die Tips.
Bei mir ist aber ein "039L" abgeraucht. Davon gibt es 2 Stück auf der Platine. Laut Ohm-Messung gehen die "D" Pins direkt auf die Motoranschlüsse. Ich bin davon ausgegangen, dass die H-Brücker aus den 4 im Bild markierten Transistoren besteht. Das sind jeweils 2 x 039L und 2x 040C. Die von Dir genannten integrierten Chips haben jeweils 8 Pins. Die kann ich aber auf der Platine nicht finden. Auf der Rückseite der Platine sehe ich nur zwei 6-Beinige Chips.
Auf dem Bild fehlt jetzt der defekte Transistor. Die beiden Linken Transistoren gehen mit dem "D" Anschluß an den Orangen Motoranschluß und die beiden Rechten (wobei ja jetzt einer fehlt) gehen an den Grauen Motoranschluß.

Inzwischen habe ich einen neuen Dekoder bekommen. Ich werde aber trotzdem versuchen, den defekten Dekoder wieder zum Laufen zu bringen.

Gruß

Hans-Jürgen
Bild entfernt (keine Rechte)


Jack01  
Jack01
Beiträge: 5
Registriert am: 13.09.2021


RE: Lokpilot V4.0 Transistor abgeraucht

#4 von jogi , 14.09.2021 16:44

Hallo Hans-Jürgen

Bist Du sicher, das es ein ESU Decoder ist ?
Ich glaube nein.

Was steht in CV 8 ?


Bastelnde Grüße Jogi ;
Elektronische Bauteile kennen 3 Zustände:Ein-Aus-Kaputt".
K-Gleise,DCC mit IB .CS2 nur Test Mfx freie Zone.MoBa MÄ seit 1954.
Jogis Bahn
mein letzter Umbau


jogi  
jogi
Metropolitan (MET)
Beiträge: 3.669
Registriert am: 13.06.2005
Ort: NRW
Gleise K - Gleise
Spurweite H0
Stromart Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#5 von LukasLokführer , 14.09.2021 18:41

Zitat von jogi im Beitrag #4
Was steht in CV 8 ?

Hallo Jogi,

nach dem, was auf der Leiterplatte steht - fast mittig - würde es mich wundern, wenn in der CV8 etwas anderes als 151 stünde.

Gruß,
Lukas


Beschwa hat sich bedankt!
 
LukasLokführer
InterCity (IC)
Beiträge: 555
Registriert am: 09.02.2010
Ort: Lummerland
Spurweite H0
Stromart DC, Digital, Analog


RE: Lokpilot V4.0 Transistor abgeraucht

#6 von moppe , 14.09.2021 19:14

Zitat von Jack01 im Beitrag #3




Ist das ein LoPi V4?
Ich denken es ein LoPi Standard ist (was hab kein zu tun mit ein V4)

Klaus


"Meine" Modellbahn:http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk
PIKO C4 "Horror Gallery": http://moppe.dk/PIKOC4.html


 
moppe
ICE-Sprinter
Beiträge: 6.051
Registriert am: 07.08.2011
Homepage: Link
Ort: Norddeusche halbinsel
Gleise Roco, PECO, Märklin/Trix, PIKO,
Spurweite H0, H0e, N, Z
Steuerung Z21, Lenz, MpC Gahler+Ringsmeier, Games on Track/Faller
Stromart AC, DC, Digital, Analog


RE: Lokpilot V4.0 Transistor abgeraucht

#7 von lokopa66 , 15.09.2021 13:57

Hallo Hans-Jürgen,


>>>> Ich werde aber trotzdem versuchen, den defekten Dekoder wieder zum Laufen zu bringen.

Das gefällt mir :-)

Wenn der Motor nur in eine Richtung läuft, wird die andere Halbbrücke evtl. auch einen weghaben.

Es stellt sich auch die Frage, welche Seite der Brücke gerade läuft, die mit dem ersetzten Transistor oder die andere Seite.

Vielleicht gehören auch noch 2 Treiber vor der Brücke dazu, die könnten evtl. In dem 6poler unterhalb stecken? Fehler könnte dahin durchgeschlagen haben.

Gehören die 040C rechts daneben zu den Aux-Ausgängen? Wenn sie noch schalten, würde ich zwei auslöten und erstens durch Beschaltung herausfinden, ob n- oder p-channel (oder bipolar?) und zweitens dann mal die beiden in der Motorbrücke damit ersetzen. Gleichzeitig den verbliebenen 039L auf den jeweiligen Komplementärtyp zu 040C testen.

Ich habe soetwas im Hinterkopf, dass es eine Steuerspannung geben muss, die jeweils die eine oder andere Halbbrücke richtungsabhängig durchsteuert. Vielleicht fehlt die in der nicht funktionierenden Richtung...

VG
Rainer


lokopa66  
lokopa66
InterCity (IC)
Beiträge: 500
Registriert am: 08.01.2006
Gleise MGleis, CGleis
Spurweite H0
Steuerung 6021, IB-1, Infrarot aus S-Set
Stromart Digital

zuletzt bearbeitet 16.09.2021 | Top

RE: Lokpilot V4.0 Transistor abgeraucht

#8 von Jack01 , 15.09.2021 14:30

So,
mußte mich als newbie in diesem Metier erstmal einlesen, wie und was man mit diesen CV's macht
In CV 8 steht 150. Es ist aber ein V3 und nicht wie ursprünglich angenommen ein V4.
Ich habe mir jetzt erstmal ein Testboard zugelegt. Alle anderen Funktionen (Fahrlicht sowie Aux1 und Aux2) sind gegeben.
Da ich die Lok mit einem neuen Dekoder zum Laufen gebracht habe, ist der (gefühlte) Druck erstmal weg.
Ich werde jetzt versuchen herauszufinden, welche Signale an den Motoren anliegen sollten (Freq. und Ampl., da gibt es recht gute Infos im Netz) und mich dann mal durch die Platine beißen. Ich glaube auch nicht, dass der Microcontroller die H-Brücke direkt ansteuert.
Das scheint übrigens ein ARM zu sein (es steht MINI58T ARM drauf).

Gruß

Hans-Jürgen
p.s.
heute ist doch glatt mein guter alter Röhren Oszi gestorben.....
Bild entfernt (keine Rechte)


Jack01  
Jack01
Beiträge: 5
Registriert am: 13.09.2021

zuletzt bearbeitet 16.09.2021 | Top

RE: Lokpilot V4.0 Transistor abgeraucht

#9 von lokopa66 , 15.09.2021 15:17

Hi nochmal,

Vielleicht habe ich da etwas ausgegraben. Würde allerdings bedeuten, der 039L wäre ein P-CH.

Eine gewisse Plausibilität dafür besteht für mich darin, dass die 04-Typen dann N-Channel wären und dann könnten die 4 04er rechts von den Motortreibern die Licht und Aux-Treiber darstellen. Das wäre eine Art Standardbeschaltung, dann könnten sie mit z.B. +5Volt direkt vom Arm angesteuert werden, ich kenne den Arm und seine Ausgänge jedoch noch nicht. (Ein Pic wird mit 5V betrieben und liefert dann auch 5V.

Licht funktioniert ja noch, oder? Dann miss doch bitte mal jeweils an Gate gegen Source, ob sich dort etwa + 5 Volt einstellen bei aktiviertem Licht / Aux und wieder 0Volt bei Deaktivierter Funktion. Anstatt Source könntest Du auch Gleichrichter-Minus nehmen.

Eine weitere Plausibilität ergibt sich daraus, dass wenn der 03er Typ ein P-CH ist, genau die eine halbe Motorbrücke nicht funktioniert, in der jetzt 2 N-CH von Dir eingelötet sind.

Such mal bei Google nach den Datenblättern von MT3401 und MT3400.



Allerdings scheinen mir die +/- 30Volt ein bischen knapp?

Könntest Du von der anderen Seite des Lopi auch eine Nahaufnahme einstellen bitte?


VG
Rainer


Jack01 hat sich bedankt!
lokopa66  
lokopa66
InterCity (IC)
Beiträge: 500
Registriert am: 08.01.2006
Gleise MGleis, CGleis
Spurweite H0
Steuerung 6021, IB-1, Infrarot aus S-Set
Stromart Digital

zuletzt bearbeitet 16.09.2021 | Top

RE: Lokpilot V4.0 Transistor abgeraucht

#10 von jogi , 15.09.2021 17:13

Hallo , jogi hier

Ich habe bisher KEINEN ESU Decoder gehabt, wo eine Motorendstufe mit einzelnen Transistoren realisiert wurde.
Habe noch einen ESU OEM Decoder ca. 15 J alt, auch der hat die 8pol. FETs Motorendstufe. Die V2,3,4 ja eh

Kennung 150 ist nicht bekannt. 155 ist Fleischmann

Hersteller Kennung
http://www.kruemelsoft.privat.t-online.de/cv8.htm


Bastelnde Grüße Jogi ;
Elektronische Bauteile kennen 3 Zustände:Ein-Aus-Kaputt".
K-Gleise,DCC mit IB .CS2 nur Test Mfx freie Zone.MoBa MÄ seit 1954.
Jogis Bahn
mein letzter Umbau


jogi  
jogi
Metropolitan (MET)
Beiträge: 3.669
Registriert am: 13.06.2005
Ort: NRW
Gleise K - Gleise
Spurweite H0
Stromart Digital

zuletzt bearbeitet 15.09.2021 | Top

RE: Lokpilot V4.0 Transistor abgeraucht

#11 von WolfgangReder , 15.09.2021 17:39

Hallo

Zitat von jogi im Beitrag #10


Kennung 150 ist nicht bekannt. 155 ist Fleischmann



Vermutlich OT aber der Vollständigkeit halber:
150 = Wm. K. Walthers, Inc.

Quelle: NMRA S-9.2.2

lg
Wolfi


jogi hat sich bedankt!
WolfgangReder  
WolfgangReder
InterRegio (IR)
Beiträge: 134
Registriert am: 31.03.2020
Gleise Roco
Spurweite H0
Steuerung Zimo MX10
Stromart Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#12 von Domapi , 15.09.2021 17:45

Solch alten Dekoderschrott würde ich nicht versuchen zu reparieren.
Den würde ich gleich durch einen neuen gˋscheiten Dekoder ersetzen.


Viele Grüße
Martin

Mein noch namenloser Trennungsbahnhof: viewtopic.php?f=64&t=152275


 
Domapi
EuroCity (EC)
Beiträge: 1.160
Registriert am: 22.09.2015
Ort: Nämberch
Gleise Ohne Pickel
Spurweite H0
Steuerung Mit Hirn und Verstand
Stromart DC, Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#13 von lokopa66 , 15.09.2021 18:07

Hallo Martin,


manchen (wie mir) macht es aber Spaß, sich mit der Schaltung auseinander zu setzen und es hat einen Lerneffekt :-)

VG
Rainer


MYKer hat sich bedankt!
lokopa66  
lokopa66
InterCity (IC)
Beiträge: 500
Registriert am: 08.01.2006
Gleise MGleis, CGleis
Spurweite H0
Steuerung 6021, IB-1, Infrarot aus S-Set
Stromart Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#14 von lokopa66 , 15.09.2021 18:09

Den Decoder finde ich auch recht untypisch bestückt. Bin auf die Ablichtung der anderen Seite gespannt.


lokopa66  
lokopa66
InterCity (IC)
Beiträge: 500
Registriert am: 08.01.2006
Gleise MGleis, CGleis
Spurweite H0
Steuerung 6021, IB-1, Infrarot aus S-Set
Stromart Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#15 von Jack01 , 15.09.2021 18:23

Klar, rein finanziell lohnt sich die Reparatur und der Aufwand nicht. Darum geht es mir aber nicht. Auch im Ruhestand muß man was zu tun haben, erst recht wenn es den ganzen Tag regnet

Heute gibt es keine Sonne. Deshalb ist das Bild nicht so gut geworden.

Gruß

Hans-Jürgen
Bild entfernt (keine Rechte)


Jack01  
Jack01
Beiträge: 5
Registriert am: 13.09.2021


RE: Lokpilot V4.0 Transistor abgeraucht

#16 von Domapi , 15.09.2021 18:40

Zitat von lokopa66 im Beitrag #13
Hallo Martin,


manchen (wie mir) macht es aber Spaß, sich mit der Schaltung auseinander zu setzen und es hat einen Lerneffekt :-)

VG
Rainer


Das unterstütze ich ich natürlich vollumfänglich ‼️‼️🤓


Viele Grüße
Martin

Mein noch namenloser Trennungsbahnhof: viewtopic.php?f=64&t=152275


 
Domapi
EuroCity (EC)
Beiträge: 1.160
Registriert am: 22.09.2015
Ort: Nämberch
Gleise Ohne Pickel
Spurweite H0
Steuerung Mit Hirn und Verstand
Stromart DC, Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#17 von lokopa66 , 15.09.2021 19:40

Hi,


Das ist ein Esu 53611 Lopi Standard.

VG
Rainer


moppe und Michael Knop haben sich bedankt!
lokopa66  
lokopa66
InterCity (IC)
Beiträge: 500
Registriert am: 08.01.2006
Gleise MGleis, CGleis
Spurweite H0
Steuerung 6021, IB-1, Infrarot aus S-Set
Stromart Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#18 von moppe , 15.09.2021 19:56

Zitat von Jack01 im Beitrag #8

In CV 8 steht 155. Es ist aber ein V3 und nicht wie ursprünglich angenommen ein V4.



In CV 8 steht 151 (ESU) und der Decoder ist kein LokPilot V3 oder V4, es ist ein LokPilot Standard, wer hab kein zu tun mit V3 und V4 Decoder!

Klaus


"Meine" Modellbahn:http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk
PIKO C4 "Horror Gallery": http://moppe.dk/PIKOC4.html


Michael Knop hat sich bedankt!
 
moppe
ICE-Sprinter
Beiträge: 6.051
Registriert am: 07.08.2011
Homepage: Link
Ort: Norddeusche halbinsel
Gleise Roco, PECO, Märklin/Trix, PIKO,
Spurweite H0, H0e, N, Z
Steuerung Z21, Lenz, MpC Gahler+Ringsmeier, Games on Track/Faller
Stromart AC, DC, Digital, Analog


RE: Lokpilot V4.0 Transistor abgeraucht

#19 von lokopa66 , 16.09.2021 07:29

Hallo,

die Intellibox auf Hans-Jürgens Foto sagt CV8=150 ?





VG
Rainer


lokopa66  
lokopa66
InterCity (IC)
Beiträge: 500
Registriert am: 08.01.2006
Gleise MGleis, CGleis
Spurweite H0
Steuerung 6021, IB-1, Infrarot aus S-Set
Stromart Digital


RE: Lokpilot V4.0 Transistor abgeraucht

#20 von lokopa66 , 16.09.2021 10:03

Hallo,


ich habe die beiden Fotos gegenübergestellt und mir die Umgebung der 4 Transistoren rechts angesehen. Die Leiterbahnverfolgung zeigt, dass sie tatsächlich für Aux 1/2 und L v/h zuständig sind (sofern die Verfolgung richtig ist). Auf dem kleinen Ausschnitt ist mir etwas aufgefallen (roter Pfeil), ist das ein Drähtchen (Kurzschlussgefahr) oder nur Staub?





Wenn es N-Ch sind, könntest Du das wie unten mit der Spannungsmessung Gate/Source feststellen, die Grafik habe ich einem anderen meiner Beiträge entliehen.
(Mir ist allerdings moch unklar, ob der ARM 0/5V abgibt. Die Grafik bezog sich auf PIC bzw. allgemein auf Logikpegel, die u.a. mit den Mosfets verstärkt werden können.)



Mir ist gerade erst aufgefallen, dass Du Elektroniker bist. Also sorry, falls ich hier zu viel gemacht habe.


VG
Rainer


Jack01 hat sich bedankt!
lokopa66  
lokopa66
InterCity (IC)
Beiträge: 500
Registriert am: 08.01.2006
Gleise MGleis, CGleis
Spurweite H0
Steuerung 6021, IB-1, Infrarot aus S-Set
Stromart Digital

zuletzt bearbeitet 16.09.2021 | Top

RE:(gelöst) Lokpilot V4.0 Transistor abgeraucht

#21 von Jack01 , 16.09.2021 17:09

Ich bin überwältigt von der Resonanz!
Damit habe ich nicht gerechnet. Eigentlich wollte ich nur wissen, ob jemand die Transistoren kennt.
Wie gesagt, ich habe mit Modellbahnen bisher keine Berührung gehabt und muss mich jetzt erstmal in die Technik einarbeiten.
Ich bin überwiegend in der Arduino Welt und der Bootselektronik (NMEA und CAN-Bus) unterwegs.

Der Dekoder läuft wieder
Es war noch der 2. Transistor im selben Zweig defekt. Es ist richtig, der 039L ist ein P-Channel und der 040C ist ein N-Channel.
Leider habe ich keine richtigen äquivalent Typen. Für den N-Channel habe ich einen IRLML 6346 und für den P-Channel habe ich einen IRLML 5203 eingesetzt. Damit läuft zumindest mein Testmotor. Dann war noch das Lötpad vom Gleichrichter zum Transistor weggebrannt. Da es sich hier um ein Multilayer Board handelt (ich glaube mindestens 3 Lagen) habe ich einen Draht von Transistor ((S-Anschluß) zum Gleichrichter (4 einzelne Dioden) angelötet.
Bei dem CV-Wert bin ich mir nicht sicher, ob ich da alles richtig gemacht habe. Ich glaube der Wert von 150 ist der, den ich vorher mal versuchsweise eingegeben habe (da habe ich die Anleitung der Intellibox nicht so richtig verstanden).

Ich bedanke mich bei allen, die mir hier so toll geholfen haben (vielleicht mache ich doch nochmal was mit der DCC-Steuerung. Die Seite "Open DCC" gefällt mir ganz gut)!Bild entfernt (keine Rechte)Bild entfernt (keine Rechte)

Vielen Dank

Hans-Jürgen
p.s.
bei meinem alten Philips Röhren Oszi von 1972 ist doch tatsächlich die Heizung der CRT durchgebrannt........


lokopa66 hat sich bedankt!
Jack01  
Jack01
Beiträge: 5
Registriert am: 13.09.2021


   

Gibt es diesen Steckverbinder noch (230 Volt) ?
Delta Modul 66031

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
disconnected Foren-Chat Mitglieder Online 172
Xobor Einfach ein eigenes Forum erstellen
Datenschutz