Willkommen 

CS2 Probleme mit DCC Dekodern

#1 von alexbaeu , 13.01.2022 17:06

Hallo zusammen,

ich habe aktuell 2 Probleme mit meiner CS2 (Version 4.2.13 - müsste aktuell sein) und DCC Dekodern.
Bei Märklin verwende ich wenn möglich mfx und bei anderen Herstellern wenn möglich DCC.

1) Ich habe versucht die Adresse einer neuen Roco Br86 mit Zimo Dekoder MX645P22 umzustellen, die zunächst auf der Defaultadresse 3 einwandfrei mit allen 29 Funktionen funktioniert hat. Bei Versuch derUmstellung der Adresse begannen die Probleme und ich bin am verzweifeln. Mittlerweile reagiert diese überhaupt nicht mehr auf dem Programmiergleis. Weder Reset noch Auslesen der Adressse funktioniert noch. Ich habe gestern dannversucht eine neue Roco E160 zu programmieren. Diese reagiert schon gar auf der Default Adresse 3. Daher hatte ich dann die Vermutung, dass es an meiner CS2 liegen könnte und einiges ausprobiert (reboot, konfigurierte Default Loks etc.), leider ohne Erfolg.

2) Ich würde gerne Adresse oberhalb von 80 für DCC Dekoder verwenden. Bei einigen meiner Loks verschiedender Hersteller funktioniert dies leider nicht und mir bleibt nur eine Adresse unter 80 zu wählen.

Kennt jemand diese Probleme und was man dagegen tun kann?
Vielen Dank vorab.

Alexander


alexbaeu  
alexbaeu
Beiträge: 6
Registriert am: 13.01.2022


RE: CS2 Probleme mit DCC Dekodern

#2 von vikr , 13.01.2022 17:36

Hallo Alexander,

Zitat von alexbaeu im Beitrag #1
habe aktuell 2 Probleme mit meiner CS2 (Version 4.2.13 - müsste aktuell sein) und DCC Dekodern.


Ich würde gerne Adresse oberhalb von 80 für DCC Dekoder verwenden. Bei einigen meiner Loks verschiedender Hersteller funktioniert dies leider nicht und mir bleibt nur eine Adresse unter 80 zu wählen.

Kennt jemand diese Probleme und was man dagegen tun kann?

das Nutzen der Adressen von 81 bis 99 (ggf. 127) funktioniert exakt bei DCC genauso wie das Programmieren der Adresse bis 80. Der Wert kurzer Adressen steht in CV1.
Lange Adressen, größer 127, werden in den CVs 17 und 18 notiert. Gleichzeitig muss der Decoder aber wissen, ob er nun auf Befehle mit der langen oder kurzen Adresse hören soll. Das muss deshalb in CV29 "gesetzt" sein.
Man muss also CV1, CV17, CV18 und CV29 immer "in einem Rutsch" im Decoder richtig einstellen und dann noch kontrollieren, ob die Zentrale jetzt auch für Lokbefehle die richtige (lange oder kurze) Adresse nimmt. DCC Programmieren deshalb bei der CS3 ails Einsteiger am besten nur auf dem (isolierten) Programmiergleis. Fahren auf dem Hauptgleis, sonst kann man sehr leicht etwas verstellen und sich die Kommunikation mit dem Decoder "absägen" . Dann hilft zwar ein Decoder-Reset weiter, aber alle individuellen Einstellungen sind futsch.

MfG

vik


alexbaeu hat sich bedankt!
vikr  
vikr
Metropolitan (MET)
Beiträge: 3.462
Registriert am: 23.10.2011
Spurweite H0, N

zuletzt bearbeitet 13.01.2022 | Top

RE: CS2 Probleme mit DCC Dekodern

#3 von DipsyTeletubby , 13.01.2022 22:57

Hi Alex,
die CS2 verhält sich beim Verändern eder CS1 sehr zickig, ich rate Dir davon ab, eine Lokadresse bei Verwendung einer Mä CS2 über die CV1, CV17 und CV18 abändern zu wollen.
Danach ist die Lok von der CS2 normalerweise nicht mehr ansprechbar.

Ändere die Lokadresse besser über das Menü davor, "Konfiguration Lok", über den Menüpunkt Lokadresse und schreibe die Daten dann über die Schaltfläche LOK Pfeil nach unten.
Wenn Du hier eine größere DCC-Adresse einstellt und in den Decoder schreibst, werden von der CS2 die CV1, CV17 und CV18 automatisch korrekt mitprogrammiert.
Die Lok muss dabei auf dem Programiergleis stehen.

Hier ein Video von Andy63 zum Anlegen einer DCC-Lok in der CS2:
In der CS2 eine neue DCC-Lok anlegen


CS2 60215 mit 4.2.13 (14) - GFP 3.81


alexbaeu hat sich bedankt!
 
DipsyTeletubby
EuroCity (EC)
Beiträge: 1.139
Registriert am: 09.07.2007
Gleise M-Gleis
Spurweite H0
Steuerung CS2
Stromart Digital


RE: CS2 Probleme mit DCC Dekodern

#4 von vikr , 13.01.2022 23:19

Hallo Alex,

Zitat von DipsyTeletubby im Beitrag #3
Ändere die Lokadresse besser über das Menü davor, "Konfiguration Lok", über den Menüpunkt Lokadresse und schreibe die Daten dann über die Schaltfläche LOK Pfeil nach unten.
Wenn Du hier eine größere DCC-Adresse einstellt und in den Decoder schreibst, werden von der CS2 die CV1, CV17 und CV18 automatisch korrekt mitprogrammiert.
Die Lok muss dabei auf dem Programiergleis stehen.
ich nehme an, genauso hast Du es - gemäß CS2-Bedienungsanleitung - bisher versucht. Was hat genau hat nicht geklappt?
Berichte bitte mal, welche Werte in CV1, CV17, CV18 stehen und kontrolliere bitte auf dem Programmiergleis auch, was in CV29 steht.

MfG

vik


alexbaeu hat sich bedankt!
vikr  
vikr
Metropolitan (MET)
Beiträge: 3.462
Registriert am: 23.10.2011
Spurweite H0, N

zuletzt bearbeitet 13.01.2022 | Top

RE: CS2 Probleme mit DCC Dekodern

#5 von berndm , 13.01.2022 23:56

Das Problem kommt mir sehr bekannt vor.
RE: Probleme Märklin CS2 und ältere bis ganz neuen DCC Decoder
Nur wir es mit einem Update auch nicht besser.

Ab und zu tauchen hier im Forum Berichte auf, die das gleiche Problem schildern. Andere scheinen keine derartige Probleme zu haben.


alexbaeu hat sich bedankt!
 
berndm
ICE-Sprinter
Beiträge: 6.501
Registriert am: 08.09.2010
Spurweite H0


RE: CS2 Probleme mit DCC Dekodern

#6 von alexbaeu , 14.01.2022 08:42

Hallo zusammen,

vielen Dank für Eure schnellen Antworten. @berndm: Leider habe ich beruflich und privat viel zu tun und kann mich nicht ständig um mein Hobby kümmern und damit auch zeitnah um eure Antworten. Ich komme auch vor heute Abend sicher nicht dazu etwas auszuprobieren. Trotzdem bin ich überwältigt wie schenll reagiert habt.

Ich habe einige Modelle mit DCC Dekoder und das hat bisher auch immer ganz gut funktoniert. Manche gehen nur mit der Adresse unter 80. Damit habe ich mich abgefunden. Ich nehme dann halt eine niedrige Adresse. Die Adresse ändere ich iummer über die Adresseingabe und dann den Pfeil in Lok übertragen. Direkt die CV register zu beschrieben habe ich ich zwar auch schon mal versucht, war aber nciht erfolgreich, würde es aber wie beschrieben nochmals probieren.

Bei dem aktuellen Fall ist es so, dass weder RST noch das Auslesen bzw. Programmieren der Adresse mehr funktionieren will. Bei RST zucken ja die Loks etwas, das passiert aberin diesem Fall auch nicht mehr. Zum Vergleich habe ich eine DCC Lok aufs Gleis gesetzt und konnte die Adresse problemlos auslesen. Danke für den Link mit dem Video. Ich werde es mir anschauen und mit meinem Vorgehen vergleichen.

Ich gehe normalerweise wie folgt vor:
- Lok anlegen mit DCC Adresse 3
- Auslesen der Konfiguration
- Anpassen der Funktionstasten und Test
- Ändern der Adresse im Adressfeld und speichern in die Lok.

Bei der besagten Lok haben die ersten 3 Punkte auch funktioniert. Nachdem ich sie auf die geeignete Adresse gesetzt habe war sie nciht mehr ansprechbar.
Wie kann ich die Lok sicher auf dem Programmiergleis zurücksetzen, auch wenn ich keine Adresse mehr habe? das sollte doch über die Taste RST gehen, oder?

Vielen Dank vporab und Eure Geduld.

Grüße

Alexander


alexbaeu  
alexbaeu
Beiträge: 6
Registriert am: 13.01.2022


RE: CS2 Probleme mit DCC Dekodern

#7 von berndm , 14.01.2022 20:02

Zitat von alexbaeu im Beitrag #6
...
Ich gehe normalerweise wie folgt vor:
- Lok anlegen mit DCC Adresse 3
- Auslesen der Konfiguration
- Anpassen der Funktionstasten und Test
- Ändern der Adresse im Adressfeld und speichern in die Lok.

Bei der besagten Lok haben die ersten 3 Punkte auch funktioniert. Nachdem ich sie auf die geeignete Adresse gesetzt habe war sie nciht mehr ansprechbar.
Wie kann ich die Lok sicher auf dem Programmiergleis zurücksetzen, auch wenn ich keine Adresse mehr habe? das sollte doch über die Taste RST gehen, oder?
...


Grundsätzlich würde ich genauso vorgehen. In einigen (wenigen) Fällen klappt das dann auch. Wenn es dann wie häufiger nach dem zweiten oder dritten Versuch nichts wird, dann kommt die alte Intellibox zum Einsatz und damit hat das Ändern der langen DCC-Adresse immer gut funktioniert. Das alte Ding kommt mit DCC immer noch sehr gut zurecht. Natürlich ist das für mich jetzt ein Glücksfall. Allerdings wird mit klar, dass eine weitere Märklin-Zentrale wohl als Nachfolge meiner CS2 nicht mehr in Betracht kommt. Ich bin am Beobachten, was andere bieten.


 
berndm
ICE-Sprinter
Beiträge: 6.501
Registriert am: 08.09.2010
Spurweite H0


RE: CS2 Probleme mit DCC Dekodern

#8 von TT800 , 14.01.2022 23:54

Zitat von alexbaeu im Beitrag #6
Ich gehe normalerweise wie folgt vor:
- Lok anlegen mit DCC Adresse 3
- Auslesen der Konfiguration
- Anpassen der Funktionstasten und Test
- Ändern der Adresse im Adressfeld und speichern in die Lok.

Bei der besagten Lok haben die ersten 3 Punkte auch funktioniert. Nachdem ich sie auf die geeignete Adresse gesetzt habe war sie nciht mehr ansprechbar.
Wie kann ich die Lok sicher auf dem Programmiergleis zurücksetzen, auch wenn ich keine Adresse mehr habe? das sollte doch über die Taste RST gehen, oder?

Hallo Alexander,

ich möchte Dich an dieser Stelle abholen, denn es ist nur mehr ein kleiner Schritt. Es hat auch sicher der 4. Punkt funktioniert, doch nun fehlt noch etwas:

Du hast die neue DCC-Adresse zwar dem Decoder mitgeteilt, aber nicht der CS2. Für die (Lokliste der) CS2 hat die Lok noch immer die Adresse 3 - nur dort meldet sich keine Lok mehr.

Also verlasse das Adressmenü der neuen DCC-Adresse mit dem grünen Haken, denn dann wird auch die Lokliste aktualisiert.


Viele Grüße,
Stephan
__________________________________________________________________________
[60211{60128connected}+60215{GUI:4.2.13|GFP:3.81}+60216{GUI3:2.3.1(8)|GFP3:12.113}+CS3webApp]
Insider seit 1993 - HeimatBf: MIST Wien - http://www.insider-stammtisch.net/


alexbaeu hat sich bedankt!
TT800  
TT800
Metropolitan (MET)
Beiträge: 3.470
Registriert am: 31.07.2009
Ort: Weinviertel, Niederösterreich
Spurweite H0
Steuerung Märklin
Stromart Digital


RE: CS2 Probleme mit DCC Dekodern

#9 von vikr , 15.01.2022 09:56

Hallo Alexander,

Zitat von alexbaeu im Beitrag #6
Wie kann ich die Lok sicher auf dem Programmiergleis zurücksetzen, auch wenn ich keine Adresse mehr habe? das sollte doch über die Taste RST gehen, oder?
im Prinzip ja (Radio Eriwan), mit RST sollte die Zentrale (CS2) ihre eigenen Einstellungen für die Lok zurücksetzen, nachdem sie vorher einen für diesen Decoder spezifischen Resetbefehl gesandt hat. Aber kennt die Zentrale den auch?
Es gibt unter DCC eine inzwischen auch genormte Methode, an die sich meines Wissens inzwischen die meisten Decoderhersteller für ihre aktuell ausgelieferten Decoder weitgehend halten und die deshalb immer einen Versuch lohnt.
Ein DCC- Decoder wird in den Auslieferungszustand zurückgesetzt, indem man - ohne Kenntnis der Adresse, auf dem Programmiergleis, im Programmiergleismodus in CV8 den Wert "8" hineinschreibt. Danach sollte ein DCC-Decoder - unter DCC - mit der (kurzen) Adresse "3" ansprechbar sein. Andere Einstellungen des Decoders werden aber ebenfalls auf die Defaultwerte zurückgesetzt.
Wenn der Decoder ein Multidecoder ist, z. B. ein mfx fähiger Decoder, kann es sein, das er an einer mfx fähigen Zentrale wie der MS2 oder CS2 nach dem Reset gar nicht auf DCC-Befehle reagiert. Es ist dann also ratsam in der Zentrale selbst vorher alle Protokolle bis auf DCC auszuschalten. Diesen resetteten Decoder in Ruhe erstmal unter DCC zu konfigurieren und im Decoder ggf. auch einzustellen, dass er selber zukünftig nur auf DCC- Befehle reagiert. Wenn alles geklappt hat, kann man mfx an der Zentrale wieder einschalten, um mit den mfx Decodern wieder wie gewohnt zu "sprechen".
Der Zimo MX645P22 kann aber m.W. kein mfx und sollte deshalb an der CS2 immer auf DCC hören. Allerdings gibt es bei Zimo erweiterte Reset-Optionen, bei denen man durch Schreiben anderer Werte als "8" in CV8 nur bestimmte Werte zurücksetzen kann...

MfG

vik


alexbaeu hat sich bedankt!
vikr  
vikr
Metropolitan (MET)
Beiträge: 3.462
Registriert am: 23.10.2011
Spurweite H0, N

zuletzt bearbeitet 15.01.2022 | Top

RE: CS2 Probleme mit DCC Dekodern

#10 von alexbaeu , 15.01.2022 15:23

Hallo Leute,

warum die BR86 von Roco nicht mehr reagiert, kann ich nicht mehr erklären. Heute habe ich es nochmals einen Reset probiert und es hat auch funktioniert. Ich vermute jetzt ich hatte ein Kontaktproblem auf meinem Programmiergleis

Ich habe mit jetzt nochmals das Thema mit den höheren Adresse angesehen. Wenn ich eine Adresse höher 80 eingebe, verändert die CS2 nur nur Adresse in CV1, sonst nirgends. Bei dem E160 mit ZIMO MX648F scheint das wohl auch für Adresse 120 noch zu funktionieren. Bei der BR86 mit ZIMO MX645P22 funktioniert es nicht mehr.

Ich bin dann wie folgt vorgegangen. Beispiel Adresse 122
- Adresse auslesen und Einstellungen einlesen - hätte jetzt vermutet die CV Register der Lok in der CS2 werden dann auch aktualisiert.
- Bei Wechsel in die CV Ansicht werden die tatsächlichen Resgisterinhalte aber nicht aktualisiert (!!!!), daher habe ich diese alle einzeln ausgelesen.
- Dann habe ich die Register geändert CV1=122 (habe so gelassen), CV17 = 192, CV18=122, CV29=46 (lange Adresse)
- nach dem Schreiben der Register läuft die Lok nun auch unter der neuen Adresse

Was ich nicht wusste war
- Bei Adresseänderung im Einstellen Menü verändert die CS2 nur CV1 (was über 256 passiert habe ich nicht probiert)
- Bei Wechsel in die CV Ansicht stimmen die angezeigten Werte nicht mit dem zuletzt ausgelesenen Werten über das Hauptmenü überein
Das ist natürlich eine blöde Fehlerquelle, da man nciht mit so einem Verhalten rechnet.

Ihr werdet jetzt vielleicht sagen ist ja klar oder ist bekannt, ich wusste es jedenfalls nicht.
Ihr habt mich aber trozdem motiviert weiterzusuchen.
Vielen Dank

Alexander


alexbaeu  
alexbaeu
Beiträge: 6
Registriert am: 13.01.2022


RE: CS2 Probleme mit DCC Dekodern

#11 von berndm , 15.01.2022 16:57

Zitat von alexbaeu im Beitrag #10
...

Was ich nicht wusste war
- Bei Adresseänderung im Einstellen Menü verändert die CS2 nur CV1 (was über 256 passiert habe ich nicht probiert)
- Bei Wechsel in die CV Ansicht stimmen die angezeigten Werte nicht mit dem zuletzt ausgelesenen Werten über das Hauptmenü überein
Das ist natürlich eine blöde Fehlerquelle, da man nciht mit so einem Verhalten rechnet.

Ihr werdet jetzt vielleicht sagen ist ja klar oder ist bekannt, ich wusste es jedenfalls nicht.
Ihr habt mich aber trozdem motiviert weiterzusuchen.
Vielen Dank

Alexander

Wenn Du über einen gewissen Wert hinausgehst, dann geht die CS2 davon aus, dass das eine lange Adresse sein soll. D.h. die Werte werden in die CVs 17 und 18 korrekt berechnet eingetragen.
Wenn ich das richtig in Erinnung habe, musst Du dann aber noch bei der CS2 extera Bit 5 bei CV29 schalten, damit die langen Adressen genutzt werden.


alexbaeu hat sich bedankt!
 
berndm
ICE-Sprinter
Beiträge: 6.501
Registriert am: 08.09.2010
Spurweite H0

zuletzt bearbeitet 15.01.2022 | Top

RE: CS2 Probleme mit DCC Dekodern

#12 von alexbaeu , 15.01.2022 20:55

Ich habe jetzt doch noch ein Problem mit den langen Adressen.
Ich wollte ein paar Loks, die vermutlich alle eine Uhlenbrock Dekoder haben, auf eine Adresse > 80 umstellen durch Beschreiben von CV1, C16/17 und CV29 (+32)
Wenn es überhaupt bei den Dekodern funktioniert, ruckeln die Loks während der fahrt.
Kennt das Problem jemand?
Danke vorab!


alexbaeu  
alexbaeu
Beiträge: 6
Registriert am: 13.01.2022


RE: CS2 Probleme mit DCC Dekodern

#13 von Pirat-Kapitan , 15.01.2022 21:35

Moin,
ich schlage vor, als erstes mal die genormten CVs für die Adressen bei DCC herauszufinden:
CV1, CV17, CV18,CV29.
CV19 sollte 0 sein, wenn Du den Einfluss einer Multitraktion vermeiden willst.

"Lange" Adresse (DCC) wird von unterschiedlichen Zentralen unterschiedlich interpretiert, mal ist 100 bereits lang, mal erst ab 128.
Eine Adresse im Bereich 81 bis 99 ist unter DCC IMMER eine kurze Adresse.

Ruckeln während der Fahrt kommt, wenn die Stromaufnahme fehlerfrei arbeitet, von einer fehlerhaften Einstellung (Programmierung) der Motoransteuerung (incl. Lastregelung).

Schöne Grüße
Johannes


Spur G im Garten, H0m im Hause. Lenz LZV100 mit Rocrail auf RasPi, Manhart-Funky und RocoWLM.


Pirat-Kapitan  
Pirat-Kapitan
EuroCity (EC)
Beiträge: 1.019
Registriert am: 13.05.2018
Ort: Bergisches Land
Gleise Edelstahl / TT-Bettungsgleis Tillig
Spurweite H0, H0m, N, G
Steuerung Lenz LZV100
Stromart Digital


RE: CS2 Probleme mit DCC Dekodern

#14 von alexbaeu , 16.01.2022 13:12

Hallo Pirat-Kapitän,

danke für die Tipps. Ich habe CV1, C16, CV17 und CV29 entsprechend Deinen Tipps und der Anleitung geändert.
Das funktioniert auch bei einige Loks so. Ich habe allerdings einige, wo ich Adressen höher 80 nicht einstellen kann.
Wenn ich den Fahrtregler hochdrehe, dann bricht die Geschwinidgkeit im Abstand von ein paar Sekunden immer wieder ein, bzw. sie ruckeln gleich.
Knotaktproblem kann man ausschließen, da ich die Programmeirung auf einen Rollenprüfstand vornehme und es bei Adressen unter 80 kein Problem gibt.
Meine Beobachtung ist, dass es eventuell mit Uhlenbrock Dekodern zu tun haben könnte.
Ich habe es mit mehreren Adressen ausprobiert, einmal mit 75, 125 und höheren Adressen bis 2000. Immer das gleiche Bild bei Adressen über 80 (CV29 Bit 5=1).
Dabei habe ich es in CV1 sowohl mit 0 als auch der Adresse (sofern kleiner 255) probiert. In CV29 habe ich das Bit 5 für die langen Adressen gesetzt.

Grüße

Alexander


alexbaeu  
alexbaeu
Beiträge: 6
Registriert am: 13.01.2022


RE: CS2 Probleme mit DCC Dekodern

#15 von Pirat-Kapitan , 16.01.2022 13:25

Moin,
kannst Du bei langen Adressen bitte mal die CV16 vergessen und Dich stattdessen der CV 18 widmen?
Werte in CV 1 über 99 bzw. 128 haben keinen sittlichen Mehrwert, ob lange oder kurze Adresse bestimmt CV29 mit Wert = 32 oder 0.

Ich vermeide thunlichst eine Programmierung auf dem Rollenprüfstand sondern nehme ein sauberes, kontakfreudiges und -williges Programmiergleis.

Schöne Grüße
Johannes


Spur G im Garten, H0m im Hause. Lenz LZV100 mit Rocrail auf RasPi, Manhart-Funky und RocoWLM.


alexbaeu hat sich bedankt!
Pirat-Kapitan  
Pirat-Kapitan
EuroCity (EC)
Beiträge: 1.019
Registriert am: 13.05.2018
Ort: Bergisches Land
Gleise Edelstahl / TT-Bettungsgleis Tillig
Spurweite H0, H0m, N, G
Steuerung Lenz LZV100
Stromart Digital

zuletzt bearbeitet 16.01.2022 | Top

RE: CS2 Probleme mit DCC Dekodern

#16 von alexbaeu , 16.01.2022 13:40

Zitat
kannst Du bei langen Adressen bitte mal die CV16 vergessen und Dich stattdessen der CV 18 widmen?
Werte in CV 1 über 99 bzw. 128 haben keinen sittlichen Mehrwert, ob lange oder kurze Adresse bestimmt CV29 mit Wert = 32 oder 0.



Ja ich mache es ganauso, es war ein Schreibfehler CV18 stat CV16.


alexbaeu  
alexbaeu
Beiträge: 6
Registriert am: 13.01.2022


   

LG-G-42 decoder und Marklin + permanentmagnete lauft nicht gut
Drehscheibe Digitalisieren LDT-Licht u. Sound

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
disconnected Foren-Chat Mitglieder Online 46
Xobor Einfach ein eigenes Forum erstellen
Datenschutz