ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#1 von FSK4ever , 13.03.2023 20:35

Hallo,

da es mich langweilt meine ESU-Dekoder über CV einzurichten, ich bislang nur ESU im Einsatz habe und zudem noch für die eine oder andere Bahn über einen Loksound nachdenke, hab ich mich entschlossen einen Lokprogrammer zu kaufen. Soweit so gut oder ehr nicht.

Als OS hab ich Win7 und Win10 probiert, auch mit 2 verschiedenen USB-Kabeln mit FTDI Chip. Beide PC's reden grundsätzlich mit dem Lokprogrammer, heißt ich kann CV schreiben und auch einzeln auslesen. Was allerdings mit keiner der Version 5.x.x funktioniert, ist das Auslesen der Decoder (probiert mit LS5, LP5Basic & 2 LP5). Bei allen kommt "kann Dekoderdaten nicht lesen"

Mit der SW Version 4.7.2 kann ich die Dekoder einlesen, allerdings unterstützen diese die 5er Dekoder nicht ==> heißt keine Soundfiles usw. schreiben.

Es sind keine Puffer verbaut, ca. 15 cm Kabel, neue Gleise und die Loks, soweit ich beurteilen kann an den Kontakten sauber.

Ich raff es nicht, muss man für die Version 5.x.x irgendwas einstellen, da es ja mit der 4er einlesbar ist?

Kennt jemand das Problem, wenn ja, was war die Lösung.

Danke im Voraus


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#2 von gruenflaeche , 13.03.2023 21:30

Hallo,

eine kleine Verständnisfrage, hast du den Lokprogrammer an deine Anlage angeschlossen? Oder hast du einen einzelne Lok auf einem einzelnen Gleis und daran den Lokprogrammer?



Grüße


gruenflaeche  
gruenflaeche
InterRegio (IR)
Beiträge: 152
Registriert am: 24.11.2020
Gleise Märklin K-Gleis
Spurweite H0
Steuerung ESU ECOS
Stromart Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#3 von FSK4ever , 13.03.2023 21:56

Einzelnes Gleis, also 2x 239er mit Prellböcken, damit nix abhauen kann.


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#4 von trapper.hardy , 13.03.2023 21:59

Hallo,
ESU liefert ein Adapterkabel mit, dafür brauchst Du keinen FTDI Chip.
Bei mir läuft der LoPro seit WIn7, dann WIn 10 und jetzt auf WIN 11.
Wenn der LoPro erkannt wird, sollte eigentlich die SW Version angezeigt werden (aktuell 5.2.3)
Kann es sein, daß hier bei der Installation vielleicht der falsche Port eingestellt ist?
-> Extras->Programmeinstellungen->Lokprogrammer->Com Port
Schau in der Version 4.7.2 nach, welcher Com Port dort eingetragen ist.
Vielleicht kommst Du so hin.
Gruß
Hardy


Märklin 3-Leiter im Aufbau, Steuerung ECOS/IB2, Schalten TAMS Easy Control, Rückmelden HSI88, Itrain 5, Loks meist auf ESU LoPi & HLA umgerüstet,


 
trapper.hardy
InterRegio (IR)
Beiträge: 203
Registriert am: 23.06.2021
Ort: DU
Gleise K-Gleis
Spurweite H0
Stromart AC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#5 von FSK4ever , 13.03.2023 22:03

Das Kabel von ESU hat nen FTDI Chip drin.

Beim COM-Port meckert er rum, wenn der falsche gewählt ist. Je nach Kabel, war es 3 oder 4. 😭


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#6 von DipsyTeletubby , 14.03.2023 00:53

Ich halte das mitgelieferte Steckernetzteil zum Lokprogrammer für unterdimensioniert.

Was passiert, wenn Du, anstatt des mitgelieferten 12 V-Esu-Steckernetzteil zur Stromversorgung des Lokprogrammers zu verwenden,
stattdessen ein leistungsstärkeres Netzteil, z. B. ein Märklin 18 V/18 VA Gleichspannungsnetzteil, z. B. 66191oder 66181 einsetzt?
Anstatt eines Steckernetzteils könnte man auch einen 16 V Wechselspannungstrafo an die grünen Schraubklemmen zur Spannungsversorgung des Lokprogrammers anschließen.


CS2 60215 mit 4.2.13 (14) - GFP 3.81


Michael Knop und FSK4ever haben sich bedankt!
 
DipsyTeletubby
EuroCity (EC)
Beiträge: 1.146
Registriert am: 09.07.2007
Gleise M-Gleis
Spurweite H0
Steuerung CS2
Stromart Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#7 von WolfiR , 14.03.2023 01:17

Hallo,

das mitgelieferte Netzteil ist zum Programmieren völlig ausreichend. Ich habe noch nie ein anderes Netzteil angeschlossen.
Der einzige Engpass kann auftrten, wenn man das Fahrpult der Programmer-SW bei Loks mit größeren Verbrauchern ( Dampfgererator, Telex) benutzt.
Ich programmiere auch Spur 1-Loks so.

Was ich mir vorstellen kann: Ist da im Anschlussgleis des Programmiergleises vielleicht ein Entstörkondensator vorhanden?

Gruß
Wolfgang


FSK4ever hat sich bedankt!
 
WolfiR
EuroCity (EC)
Beiträge: 1.256
Registriert am: 08.01.2009
Spurweite H0, H0m, 1, Z
Stromart AC, Digital

zuletzt bearbeitet 14.03.2023 | Top

RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#8 von FSK4ever , 14.03.2023 11:14

Ich werde es heute Abend nochmal probieren und dabei den Aufbau möglichst genau zusammenmalen. Wenn es dann nix wird, geht das Teil Retour und wird geistig als Gerümpel bei mir eingebucht.

Zur letzten Punkt: woher sollte am nackten Gleit ein Kondensator kommen?

Es ist wirklich nix dazwischen, also Lok auf separatem Gleis mit 15-20cm Anschlusskabel am Lokprogrammer. NT ist das mit gelieferte und Kabel zum PC auch. Das 2. Kabel war wie gesagt Backup, weil ich mehrfach über Probleme gelesen hatte.

Software hab ich direkt bei ESU gezogen. Mit der 4er erkennt der Programmer was, kann aber die 5er LoPi nicht ansprechen, da halt 5>4 und die LoPi5 nicht unterstützt werden. Mit der 5er SW bekomme ich nicht mal diese Reaktion hin..

Was allerdings geht: einzelne CV Lesen und Schreiben (sowohl mit 4er als auch 5er SW) und auch den LoPi über das Paneel anzusteuern (Fahren, Licht / Sound beim LoSo5).

So recht will es mir nicht einleuchten, warum einzelne CV gehen aber das Komfort-Feature nicht geht.


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#9 von LukasLokführer , 14.03.2023 13:18

Hi,

hilft es das "Paket Pipelining" ein- bzw. auszuschalten? Das findest du in SW 5.x unter Extras - Programmeinstellungen... - LokProgrammer.
Für das CV-Lesen/Schreiben benutzt der LokProgrammer ja das DCC-Protokoll, das Decoder-Auslesen bzw. Schreiben geht über ein ESU-internes Protokoll. Da sind andere Datenraten im Spiel, die empfindlicher auf die Qualität der Verbindung zw. LokProgrammer und Decoder (also LoPro, Gleisanschluss, Schiene-Rad-Kontakt, elektr. Innereien des Modells) reagieren.

Gruß,
Lukas


 
LukasLokführer
InterCity (IC)
Beiträge: 645
Registriert am: 09.02.2010
Ort: Lummerland
Spurweite H0
Stromart DC, Digital, Analog

zuletzt bearbeitet 14.03.2023 | Top

RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#10 von ohawd , 14.03.2023 14:53

Hallo,

wie offenbar die meisten user, die sich bislang dazu geäußert haben, kann auch ich mir nicht vorstellen, dass der LokProgrammer wirklich defekt ist.

Kannst du de Decoder außerhalb des Fahrzeugs an den LokProgrammer anschließen? Z. B. über einen DecoderPrüfstand oder einen Decoderadapter, den du mal schnell mit Gleisanschluss versiehst? Zeigen die Decoder in CV7 auch wirklich "151" an oder ist dir versehentlich etwas anderes untergekommen?

Viele Grüße

Wolfgang


ohawd  
ohawd
InterRegio (IR)
Beiträge: 242
Registriert am: 10.02.2019
Homepage: Link
Ort: Bad Grund (Harz)
Spurweite H0, H0m
Stromart AC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#11 von drum58 , 14.03.2023 15:06

Zitat von ohawd im Beitrag #10
Zeigen die Decoder in CV7 auch wirklich "151" an oder ist dir versehentlich etwas anderes untergekommen?


Hallo Wolfgang, der Herstellercode steht in CV 8.

Gruß
Werner


drum58  
drum58
Metropolitan (MET)
Beiträge: 3.354
Registriert am: 17.01.2014
Homepage: Link
Ort: Moos-Bankholzen
Spurweite H0
Steuerung Lenz LZV 200 und LZV 100
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#12 von ohawd , 14.03.2023 15:15

...sorry - natürlich CV8. Tippfehler...


ohawd  
ohawd
InterRegio (IR)
Beiträge: 242
Registriert am: 10.02.2019
Homepage: Link
Ort: Bad Grund (Harz)
Spurweite H0, H0m
Stromart AC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#13 von sledge , 14.03.2023 15:54

Hallo FSK4ever, werte Forenleser !

Nachdem Du die Decoder in einer Lok eingebaut hast, wäre es interessant zu wissen um welche Loks (Artikelnummer / Hersteller) es sich handelt. Sind in den Loks vielleicht Speicherkondensatoren verbaut ?

Empfehlung:
Am besten wäre es die Decoder mit einem Decoderprüfstand am Lokprogrammer zu testen. Somit können Fehler in der Signalübertragung Lokprogrammer / Decoder ausgeschlossen werden.


Mit modellbahnerischen Grüssen
sledge

P.S. Ich weiß nicht alles, aber meine Bücher und Hefte!


sledge  
sledge
InterCity (IC)
Beiträge: 672
Registriert am: 05.09.2009


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#14 von FSK4ever , 14.03.2023 17:49

Hallo,

ich habs jetzt nochmal aufgebaut mit einem 16V Netzteil, das sollte dann wirklich ausreichend sein.

Als Loks mit denen es nicht funktioniert hab ich:
https://www.brawa.de/fanwelt/online-muse...vt-703-der-nwb/ ==> LoPi5 Basic
https://www.piko-shop.de/de/artikel/e-lo...g-vi-24419.html ==> LoPi5
https://www.piko-shop.de/de/artikel/dies...ag-v-20742.html ==> LoSo5

FTDI-Treiber von ESU
Software 5.2.3
Herstellerinfo laut CV: 151

Geht immer noch nicht.

Nen Decoderprüfstand hab ich leider nicht und wenn das Teil damit so empfindlich ist, ist es fast nen NoGo, da ich den LoPro nutzen will um den Decoder auf den Motor sauber abzustimmen. Den dazu jedes Mal auszubauen ist wohl nicht im Sinne des Erfinders.

Ich werd es trotzdem mal mit einem Decoder probieren und diesen nur frei verkabeln.
Bild entfernt (keine Rechte)Bild entfernt (keine Rechte)


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#15 von moppe , 14.03.2023 18:00

Wen du LokProgrammer nutzen zu lastreglung anpassen, passt der Reglung nicht, wenn du der Zug auf dein Anlage stellen.

Hab du der „packet pipeline“ ausschaltet?



Klaus


"Meine" Modellbahn:http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk
PIKO C4 "Horror Gallery": http://moppe.dk/PIKOC4.html


 
moppe
Trans Europ Express (TEE)
Beiträge: 8.240
Registriert am: 07.08.2011
Homepage: Link
Ort: Norddeusche halbinsel
Gleise Roco, PECO, Märklin/Trix, PIKO,
Spurweite H0, H0e, N, Z
Steuerung Z21, Lenz, MpC Gahler+Ringsmeier, Games on Track/Faller
Stromart AC, DC, Digital, Analog

zuletzt bearbeitet 14.03.2023 | Top

RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#16 von ohawd , 14.03.2023 18:04

HAllo,

wenn das das Bild ist, das du "beklagst", dann haben wir alle falsch gesucht. Ich jedenfalls dachte, es geht um das Einlesen aller CV auf einmal. Also der kompletten Decodereinstellung. Die erreichst du, wenn du oben in der Software das Icon mit dem grünen Pfeil nach links betätigst. Was du da zeigst, sind die zusätzlichen Decoderinformationen zum Typ, Firmwarestand, u.s.w. Die müssen auch gehen, ist aber eine andere Baustelle.

Bitte probier mal das Lesen der (normalen) Decoderdaten aus der Lok!

Gruß

Wolfgang


ohawd  
ohawd
InterRegio (IR)
Beiträge: 242
Registriert am: 10.02.2019
Homepage: Link
Ort: Bad Grund (Harz)
Spurweite H0, H0m
Stromart AC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#17 von FSK4ever , 14.03.2023 18:22

Alle auf einmal geht halt nicht, einzeln geht es.

Ich hab jetzt einen Decoder mal ohne Lok eingelesen und es geht ... man was ist das für eine Fehlkonstruktion.

In den Piko Loks ist nirgends nen Kondensator drin und auch am Motor nix angelötet was auch nur annähernd einer Kapazität gleicht.

Wie könnte man das Problem lösen ohne jedes mal den Decoder auszubauen


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#18 von ohawd , 14.03.2023 18:28

Sorry, aber dein Urteil über eine Fehlkonstruktion ist mir schleierhaft. Offenbar ist doch irgendetwas auf deiner Strecke vom Programmer über die Schiene zum Decoder nicht in Ordnung. Normalerweise läuft der Programmer perfekt. Mag natürlich sein, dass du ein defektes Exemplar bekommen hast. Dann solltest du den Programmer aber noch immer nicht als Fehlkonstruktion verurteilen sondern dem Händler zurückbringen. Es steht aber nach wie vor stark zu vermuten., dass der Fehler vor dem Gerät sitzt....


Beschwa hat sich bedankt!
ohawd  
ohawd
InterRegio (IR)
Beiträge: 242
Registriert am: 10.02.2019
Homepage: Link
Ort: Bad Grund (Harz)
Spurweite H0, H0m
Stromart AC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#19 von FSK4ever , 14.03.2023 18:41

Hab mir jetzt auf die Schnelle paar Widerstände geschnappt, diese an den Motorpol gehangen und halt die Gleise umgangen, so dass halt nix zwischen ist.

So scheint es zu funktionieren, aber eben genau dass sollte nicht der Sinn von einem solchen Tool sein oder?

Denn jedes Mal den Decoder ausbauen hat für mich keinen Zopf... ist doch das Gleiche beim Auto, da wird auch nicht jedes Mal das Steuergerät ausgebaut, wenn es von nem Hersteller nen Update gibt ...

Dass das Teilchen da so anfällig ist, will mir nicht so recht in den Kopf.


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#20 von ohawd , 14.03.2023 18:43

Deine Schilderungen sind mehr als abenteuerlich. Diu kannst doch nicht den Lokprogrammer an die Motoranschlüsse hängen.


ohawd  
ohawd
InterRegio (IR)
Beiträge: 242
Registriert am: 10.02.2019
Homepage: Link
Ort: Bad Grund (Harz)
Spurweite H0, H0m
Stromart AC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#21 von FSK4ever , 14.03.2023 18:50

Bild entfernt (keine Rechte)

Nein, bitte richtig Lesen

Ich habe die Widerstände an die Motorpole vom LoPi gehangen, damit eine Last vorhanden ist ==> programmierbar

Den LoPro hab ich an die Gleisanschlüsse gehangen.

Also einfach die Konstruktion Lok + Gleis umgangen.

Jetzt geht es mir ehr darum, wie ich den LoPro dazu überreden kann mit dem Decoder in der Lok zu reden, da ich ein ständiges Ausbauen (wenigstens zum Einstellen) als nicht wirklich zielführend empfinde.


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital

zuletzt bearbeitet 14.03.2023 | Top

RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#22 von moppe , 14.03.2023 18:59

Hab du der „packet pipeline“ ausschaltet?

Irgendwo bei ihn is ein Fehler.
Ich kann V5 Decoder lesen und schreiben wenn de Lok/Triebwagen steht an meiner rollenprüfstand.

Klaus


"Meine" Modellbahn:http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk
PIKO C4 "Horror Gallery": http://moppe.dk/PIKOC4.html


 
moppe
Trans Europ Express (TEE)
Beiträge: 8.240
Registriert am: 07.08.2011
Homepage: Link
Ort: Norddeusche halbinsel
Gleise Roco, PECO, Märklin/Trix, PIKO,
Spurweite H0, H0e, N, Z
Steuerung Z21, Lenz, MpC Gahler+Ringsmeier, Games on Track/Faller
Stromart AC, DC, Digital, Analog


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#23 von sledge , 14.03.2023 19:01

Hallo FSK4ever, werte Forenleser !

Nachdem Du nun den Decoder erfolgreich testen konntest ist ein defekt des Lokprogrammers auszuschliessen. Alle 3 Lokomotiven haben eine achtpolige Schnittstelle. Daher ist ein falsches Anschliessen des Decoders ( bis auf verdrehen) nicht möglich. Weitere Fehlermöglichkeit sind verschmutzte Gleise / Radkontakte die das Auslesen des Decoders erschweren können.


Mit modellbahnerischen Grüssen
sledge

P.S. Ich weiß nicht alles, aber meine Bücher und Hefte!


sledge  
sledge
InterCity (IC)
Beiträge: 672
Registriert am: 05.09.2009


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#24 von FSK4ever , 14.03.2023 19:33

Zitat von moppe im Beitrag #22
Hab du der „packet pipeline“ ausschaltet?


Habe beides probiert, sowohl in der Lok als am Dekoder direkt ==> keinen Unterschied


FSK4ever  
FSK4ever
Regionalbahn (RB)
Beiträge: 34
Registriert am: 30.10.2020
Ort: 91469
Spurweite H0
Stromart DC, Digital


RE: ESU Lokprogrammer will einfach nicht mit SW 5 laufen

#25 von MSC , 14.03.2023 19:35

Hallo FSK4ever,

hast du dir schon mal dein Anschlussgleis angesehen.
Es gibt und gab Anschlussgleise in denen zur Entstörung Kondensatoren eingebaut sind, diese müssen bei Digitalbetrieb entfernt werde.
Eine Andere Fehlermöglichkeit wären in den Lokomotiven eingebaute Pufferkondensatoren, dann geht das mit dem Programmieren auch nicht.

Gruß
Michael


FSK4ever hat sich bedankt!
MSC  
MSC
InterRegioExpress (IRE)
Beiträge: 486
Registriert am: 10.12.2017


   

Märklin mld3-Decoder Einstellung für Telexkupplung an AUX 1+2
gelöst LokPilot 5 FX micro programieren mit Z21 (Schwarz) App

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
Xobor Einfach ein eigenes Forum erstellen
Datenschutz