RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#1 von floete100 , 09.06.2012 18:57

Hallo Experten,

habe etliche meiner Loks mit LoPi 3 ausgestattet - und alle problemlos programmieren können (incl. Dimmen, Auf- und Abblenden). Nun habe ich - leichtsinnigerweise? - meinen ersten LoPi 4 angeschafft. Und der schafft mich

Hinbekommen habe ich immerhin die einwandfreie (und wunschgemäße) Programmierung der CVs 1 - 6. Versucht habe ich die "Automatik-Prgrammierung" der Lastregelparameter mit CV 54 = 0 und Drücken von f1. Da die Lok aber nicht gut lief, musste ich doch die CVs 52 - 55 "zu Fuß" programmieren (ich habe keinen Programmer, sondern programmiere mit einer Roco-Multimaus). Das hat aber auch geklappt.

Was aber überhaupt nicht funktioniert, sind meine restlichen Wünsche:
- Auf- und Abblenden (versucht mit CV 259 und 267)
- Dimmen (versucht mit CV 262 und 270)
- Licht vorne und hinten "an", wenn der Rangiergang über f3 aktiviert ist (versucht über CV 426 und 442).

Ergebnis: Welche der genannten CVs ich auch geändert habe - ich konnte keinerlei Veränderung an der Lok feststellen. Es blendet nicht auf noch ab, es behält (selbst wenn ich auf 0 dimme!) die volle Helligkeit, und bei f3 ist Licht nur vorn oder hinten - je nach Fahrtrichtung.

Wer kann mir helfen?

Mit ratlosen Grüßen
Rainer


Am Ende wird alles gut.
Wenn es nicht gut ist, war es noch nicht das Ende ..

Mein Anlagenthread: Die unendliche Geschichte ...

Mein schwierigstes "Winzprojekt": Inneneinrichtung Kabinentender BR 50


 
floete100
Metropolitan (MET)
Beiträge: 3.810
Registriert am: 08.12.2007
Ort: Köln
Gleise M-Gleis, K-Gleis
Spurweite H0
Steuerung CU 6021, WinDigiPet
Stromart Digital


RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#2 von Jörg L. , 09.06.2012 19:05

Hallo Rainer,

in der Umgebung von Köln gibt es Stammtische, dort befindet sich sicherlich auch ein Kollege mit einem LokProgrammer der Dir gerne hilft. Damit sind deine Wünsche innerhalb 2 Minuten erledigt.
Auf- und Abblenden müsste sich auch mit einer CS2 oder ECoS realisieren lassen.

Bei der CV-Programmierung musst Du glaube ich auch noch zusätzlich einen Index-CV setzen, könnte daran liegen.


Viele Grüße Jörg

- Märklin Insider - Epoche IV/V/VI, CSinus- bzw. Faulhaberantriebe
Meine Lieblinge______mä39421...Re 4/4 I im 3er-Pack"


Jörg L.  
Jörg L.
InterCityExpress (ICE)
Beiträge: 2.479
Registriert am: 30.11.2006
Ort: Kreis Wesel
Gleise C-Gleis
Spurweite H0
Steuerung CU, MS2, CS3+, iPad2
Stromart Digital


RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#3 von floete100 , 09.06.2012 20:24

Zitat von Jörg L.
dort befindet sich sicherlich auch ein Kollege mit einem LokProgrammer der Dir gerne hilft.


Hallo Jörg,

danke für den Hinweis. Ich habe mir aber nicht die Multimaus gekauft, um jetzt jemanden mit Lokprogrammer zu suchen (ich brauche die Multimaus nur zum Programmieren) - ich möchte schon autark sein. Und bestimmt gibt es im Forum Fachleute, die meine Bildungslücken beheben können

Zitat von Jörg L.
Bei der CV-Programmierung musst Du glaube ich auch noch zusätzlich einen Index-CV setzen, könnte daran liegen.


Wenn Du das etwas näher erläutern könntest, würde das meiner erste Lücke vielleicht schon abhelfen . Ich habe Deinen Hinweis in der BA nachzuvollziehen versucht, aver nichts gefunden.

Gruß,
Rainer


Am Ende wird alles gut.
Wenn es nicht gut ist, war es noch nicht das Ende ..

Mein Anlagenthread: Die unendliche Geschichte ...

Mein schwierigstes "Winzprojekt": Inneneinrichtung Kabinentender BR 50


 
floete100
Metropolitan (MET)
Beiträge: 3.810
Registriert am: 08.12.2007
Ort: Köln
Gleise M-Gleis, K-Gleis
Spurweite H0
Steuerung CU 6021, WinDigiPet
Stromart Digital


RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#4 von Jörg L. , 09.06.2012 21:04

Hallo Rainer,

welche Multimaus besitzt Du denn mit welchem Softwarestand :
Siehe bitte in die BA von dem LokSound v4.x, dort ist recht umfangreich die Programmierung mit den unterschiedlichen Mäusen erklärt und deren Softwareproblemen (Firmware-Fehler); Seite 35ff Ausgabe April 2012.

Sollte helfen.


Viele Grüße Jörg

- Märklin Insider - Epoche IV/V/VI, CSinus- bzw. Faulhaberantriebe
Meine Lieblinge______mä39421...Re 4/4 I im 3er-Pack"


Jörg L.  
Jörg L.
InterCityExpress (ICE)
Beiträge: 2.479
Registriert am: 30.11.2006
Ort: Kreis Wesel
Gleise C-Gleis
Spurweite H0
Steuerung CU, MS2, CS3+, iPad2
Stromart Digital


RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#5 von H0! , 09.06.2012 21:12

Moin!

Zitat von Jörg L.
Bei der CV-Programmierung musst Du glaube ich auch noch zusätzlich einen Index-CV setzen, könnte daran liegen.

Ja, die CVs 31 und 32 müssen vor dem Zugriff auf CVs zwischen 256 und 511 auf die angegebenen Werte gesetzt werden.
"Bitte setzen Sie die Index-Register CV 31 auf 16 und CV 32 auf 0 ehe Sie Werte ändern."

Ich habe vorgestern mit einer Intellibox das Auf- und Abblenden aktivieren können.


Viele Grüße
Thomas


 
H0!
ICE-Sprinter
Beiträge: 5.882
Registriert am: 12.05.2005
Homepage: Link
Ort: Rheinland
Gleise |:| (Zweileiter)
Spurweite H0, Z
Steuerung CS1R [DCC+MM]
Stromart AC, DC, Digital, Analog


RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#6 von floete100 , 09.06.2012 21:48

Zitat von H0
"Bitte setzen Sie die Index-Register CV 31 auf 16 und CV 32 auf 0 ehe Sie Werte ändern."


Hallo Thomas,

hab's gefunden - BA S. 42 Mitte. Aber: In derselben BA auf S. 50 unten bzw. S. 51 oben steht, dass CV 31 ab Werk auf 16 eingestellt ist - und CV 32 auf 0. Demnach wär' doch mit den Index-Registern alles ok!?

fragt
Rainer


Am Ende wird alles gut.
Wenn es nicht gut ist, war es noch nicht das Ende ..

Mein Anlagenthread: Die unendliche Geschichte ...

Mein schwierigstes "Winzprojekt": Inneneinrichtung Kabinentender BR 50


 
floete100
Metropolitan (MET)
Beiträge: 3.810
Registriert am: 08.12.2007
Ort: Köln
Gleise M-Gleis, K-Gleis
Spurweite H0
Steuerung CU 6021, WinDigiPet
Stromart Digital


RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#7 von H0! , 09.06.2012 22:31

Bei der ersten Charge haben die Werte der Indexregister anscheinend nicht gestimmt.
Es schadet nicht, CVs 31 und 32 einmal richtig zu setzen ...
Wie war das: die Lokmaus kann CVs nicht auslesen, zumindest nicht mit dem Startpackungsverstärker?
Du musst die Indexregister auslesen oder schreiben, wenn Du sicher sein möchtest, dass die Werte stimmen.

Autarkie ist schön und gut - aber mit einem LokProgrammer kann man auch die Firmware aktualisieren.


Viele Grüße
Thomas


 
H0!
ICE-Sprinter
Beiträge: 5.882
Registriert am: 12.05.2005
Homepage: Link
Ort: Rheinland
Gleise |:| (Zweileiter)
Spurweite H0, Z
Steuerung CS1R [DCC+MM]
Stromart AC, DC, Digital, Analog


RE: Brauche Hilfe bei LoPi 4-Programmierung ...

#8 von floete100 , 10.06.2012 14:22

Zitat von Jörg L.
Siehe bitte in die BA von dem LokSound v4.x, dort ist recht umfangreich die Programmierung mit den unterschiedlichen Mäusen erklärt und deren Softwareproblemen (Firmware-Fehler); Seite 35ff Ausgabe April 2012.


Genial, Jörg! Das war ein absoluter Volltreffer

Ich nehme die Beschimpfung der Firma ESU zurück (aber nur zu 75% ) und beschimpfe statt dessen die Firma Roco ...

Aber der Reihe nach: Zuerst habe ich versucht, wie von Thomas empfohlen, die CVs 31 und 32 zu setzen. Leider ohne Erfolg. Dann habe ich ein Komplett-Reset gemacht, um mit den Werkseinstellungen neu zu beginnen. Habe nun erstmal alle "kleinen" CVs programmiert (bis 55). Danach wollte ich an die "großen" gehen. Also "CV AENDERN" mit "OK" bestätigt, bei "CV" "259" eingetragen, mit "OK" bestätigt ... hoppla, was war das ?? Hat da die Multimaus den CV-Wert eigenmächtig verändert? Im Bildschirm war jetzt nur die Eingabemaske "W =" zu sehen. Also mit "STOP" abgebrochen, letzten Schritt wiederholt, dabei genauestens hingesehen. Und tatsächlich: In dem winzigen Augenblick, bevor die Anzeige umspringt, schaltet die Sch...maus den CV-Wert auf 255 zurück. Und zwar egal, ob man nun 259, 420, 515 ... eingibt!

Das war der Moment, wo ich dann doch die LokSound-BA im Internet aufgerufen habe ops:. Und exakt auf der von Dir empfohlenen Seite 35 steht - Zitat:
ROCOs Multimaus® kann aufgrund eines (weiteren, bisher nicht behobenen) Firmwarefehlers in der aktuellen (Stand: Dez. 2010) Firmware 1.02 leider keine CVs über Nummer 255 programmieren.
Zitat Ende

Das also war des Rätsels Lösung!

Auf S. 36 steht dann eine Abhilfemöglichkeit mit den Hilfs-CV 96, 97 und 99. Und es ist mir auf Anhieb gelungen, die CV 259 damit auf "2" zu setzen. Und nun blendet's auf und ab

Warum ich nun 25% der Beschimpfung bei ESU lasse? Diesen Hinweis hätten sie gefälligst auch in der BA des LokPilot bringen sollen. Ohne Deinen Tipp, lieber Jörg, wär' ich nie auf die Idee gekommen, in die LokSound-BA zu schauen.

Nochmals vielen Dank an Jörg und Thomas - bin wieder mal geholfen!

Gruß,
Rainer

Edit: Reduziere die ESU-Schelte auf 10% . Habe gerade im Netz die aktuelle BA LokPilot V4.0, 5. Auflage Mai 2012 aufgerufen. Und da steht nun auf S. 26 derselbe Multimaus-Text drin! Ich hatte allerdings keine Chance - meine LoPi-BA ist 3. Auflage Dezember 2010 ...


Am Ende wird alles gut.
Wenn es nicht gut ist, war es noch nicht das Ende ..

Mein Anlagenthread: Die unendliche Geschichte ...

Mein schwierigstes "Winzprojekt": Inneneinrichtung Kabinentender BR 50


 
floete100
Metropolitan (MET)
Beiträge: 3.810
Registriert am: 08.12.2007
Ort: Köln
Gleise M-Gleis, K-Gleis
Spurweite H0
Steuerung CU 6021, WinDigiPet
Stromart Digital


   


  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
Xobor Einfach ein eigenes Forum erstellen
Datenschutz