MobaLedLib: 768 LEDs, Servos, Sound, …………… Tageszeitung (siehe #4936)

Bereich für alle Themen rund um Modellbahn-Software, sowie der nötigen Hardware (PCs, Bildschirme, etc.).
Benutzeravatar

raily74
InterRegioExpress (IRE)
Beiträge: 402
Registriert: Di 5. Dez 2006, 12:04
Nenngröße: H0
Stromart: DC
Steuerung: Z21, iTrain, MobaLedLib
Gleise: Roco Line o. Bettung
Wohnort: Kassel
Alter: 46
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4826

Beitrag von raily74 »

Alles klar Rolf,

ich bau dir dann euer Nachbarhaus 😉
Viele Grüße, Michael
Das 3-Generationen-Projekt | H0-Anlage in Epoche V im Bau
Niederflur-Beiwagen 4NBWE aus dem 3D-Drucker | Von der Skizze zum Modell

aftpriv
EuroCity (EC)
Beiträge: 1014
Registriert: Di 3. Apr 2012, 10:01
Nenngröße: H0
Stromart: digital
Steuerung: Gleisbox+RocRail-RN-Node
Gleise: K-Gleis|:|(3-Leiter)
Wohnort: 636xx Hessen/Main-Kinzig-Kreis
Alter: 70

MobaLedLib - Platinen bestellen

#4827

Beitrag von aftpriv »

.
Hallo Forianer und Alle, die die MobaLedLib zukünftig verwenden wollen:

Alle Erst-Platinenbesteller laden sich bitte den Fragebogen herunter (Link: https://wiki.mobaledlib.de/_media/medie ... -2021.docx ) und füllen in zur Gänze aus.
Danach sendet Ihr dieses Dokument, einschließlich Eurer Platinenwünsche, per E-Mail an (Link: LedLib@yahoo.com ) zu.

Derzeit verfügbare Platinen könnt Ihr hier sehen (Link: https://wiki.mobaledlib.de/anleitungen/platinen_info )

In Folge bekommt Ihr dann die Preisaufstellung und die weitere Vorgangsweise.

Gruß und viel Spaß beim Basteln wünscht Alf vom MLL-Team

PS:
- schmökert im Stummi-Forum, aber vor allem auch ausgiebigst in der eigenen Wiki (Link: https://wiki.mobaledlib.de/ )
- Bau- und Bestückungsanleitungen findet Ihr hier (Link: https://wiki.mobaledlib.de/anleitungen/ ... uebersicht )
- bitte studiert diese Anleitungen sorgfältig bevor Ihr mit dem Basteln beginnt, dadurch können viele Fehler und Frustration vermieden werden.
Pickel-Bahner seit 1958 / K-Gleis + ZIMO-Decoder (MX633P22/MX645P22)
RocRail & RocNetNode
Email bezüglich MobaLedLib-Belange: LedLib@yahoo.com
Benutzeravatar

Thorsten Schröder
S-Bahn (S)
Beiträge: 19
Registriert: So 16. Nov 2008, 14:13
Nenngröße: H0
Stromart: analog DC
Steuerung: Piko / Roco
Gleise: PIKO / jetzt Roco
Wohnort: Norderstedt
Alter: 44
Kontaktdaten:

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4828

Beitrag von Thorsten Schröder »

Ja Moin habe jetzt ein anderes Mainbord 3,2 Ghz und 16 Gb speicher aber immer noch windwos7 aber folgenden fehler bekomme ich
https://abload.de/image.php?img=unbenanntnsk2f.png
Wo ist denn jetzt Der Fehler???
Und es sagt zu wenig speicher Platz, ähm habe noch 400GB Frei??????
DHC500blau hat geschrieben: Sa 9. Jan 2021, 22:55
Thorsten Schröder hat geschrieben: Sa 9. Jan 2021, 21:20 Hallo Hardi ich habe ein Mainboard von ASROCK mit 2,8Ghz CPU und Das Handbuch sagt es geht nur windows7?
Jetzt bescheidende Frage geht denn auch windwos10????

Liebe GRüße
Hallo Thorsten,

ein Umstieg von Windows 7 auf Windows 10 ist in meinen Augen generell sinnvoll. Windows 7 gilt als eine der eher schwächeren Windows-Versionen und seit exakt einem Jahr liefert Microsoft auch keine Updates mehr zu Windows 7. Somit werden Sicherheitslücken des Betriebssystems nicht mehr geschlossen. Noch ist das Upgrade auf Windows 10 für Privatanwender kostenlos. Es kostet Dich lediglich ein bisschen Zeit.

Liebe Grüße
Lorenz
Die schönste anlage ist Mininatur wunderland......
Benutzeravatar

Dortmunder
Regionalbahn (RB)
Beiträge: 42
Registriert: Mi 11. Dez 2019, 18:07
Nenngröße: N
Stromart: digital
Steuerung: iTrain
Wohnort: Dortmund
Alter: 65
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4829

Beitrag von Dortmunder »

Hi,

windows 7 und 16 GB Arbeitsspeicher, dazu noch ein altes Board, dass dürfte im besten Fall suboptimal sein.

Schau mal hier https://www.google.com/search?client=fi ... %BCr+win+7

wieviel Arbeitsspeicher angesprochen werden können.

Bei zu viel Arbeitsspeicher kann es zu Speicheradressproblemen kommen. Dazu müsste man sich mal ein Testprogramm aufrufen.
Wieviele Speicherriegel?
Alle Riegel von einem Hersteller?
Alle Riegel mit gleicher Spezifikation oder gemischt?
Und es sagt zu wenig speicher Platz, ähm habe noch 400GB Frei??????
Auf der gesamten Festplatte, auf der Startpartion? Bitte mal den exakten Wortlaut der Fehlermeldung.

Norbert
Benutzeravatar

Moba_Nicki
InterCity (IC)
Beiträge: 678
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 39
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4830

Beitrag von Moba_Nicki »

Thorsten Schröder hat geschrieben: Sa 23. Jan 2021, 22:37 Ja Moin habe jetzt ein anderes Mainbord 3,2 Ghz und 16 Gb speicher aber immer noch windwos7 aber folgenden fehler bekomme ich
https://abload.de/image.php?img=unbenanntnsk2f.png
Wo ist denn jetzt Der Fehler???
Und es sagt zu wenig speicher Platz, ähm habe noch 400GB Frei??????
DHC500blau hat geschrieben: Sa 9. Jan 2021, 22:55
Thorsten Schröder hat geschrieben: Sa 9. Jan 2021, 21:20 Hallo Hardi ich habe ein Mainboard von ASROCK mit 2,8Ghz CPU und Das Handbuch sagt es geht nur windows7?
Jetzt bescheidende Frage geht denn auch windwos10????

Liebe GRüße
Hallo Thorsten,

ein Umstieg von Windows 7 auf Windows 10 ist in meinen Augen generell sinnvoll. Windows 7 gilt als eine der eher schwächeren Windows-Versionen und seit exakt einem Jahr liefert Microsoft auch keine Updates mehr zu Windows 7. Somit werden Sicherheitslücken des Betriebssystems nicht mehr geschlossen. Noch ist das Upgrade auf Windows 10 für Privatanwender kostenlos. Es kostet Dich lediglich ein bisschen Zeit.

Liebe Grüße
Lorenz
Hallo Thorsten

WIndows7 wird 99% der Fälle in der 32-Bit Version installiert. Dieses kann nur 4GB Speicher verwenden. Dabei ist es egal ob 8GB oder sogar 16GB vorhanden sind.
Erst wenn du auf Windows10 umstellst, werden die 16GB ordentlich verwendet, sofern du bei der Installation die 64-Bit Variante auswählst.

Schöne Grüße
Dominik
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/

aftpriv
EuroCity (EC)
Beiträge: 1014
Registriert: Di 3. Apr 2012, 10:01
Nenngröße: H0
Stromart: digital
Steuerung: Gleisbox+RocRail-RN-Node
Gleise: K-Gleis|:|(3-Leiter)
Wohnort: 636xx Hessen/Main-Kinzig-Kreis
Alter: 70

Re: MobaLedLib - Platinen bestellen

#4831

Beitrag von aftpriv »

aftpriv hat geschrieben: Sa 23. Jan 2021, 18:46 .
Hallo Forianer und Alle, die die MobaLedLib zukünftig verwenden wollen:

Alle Erst-Platinenbesteller laden sich bitte den Fragebogen herunter (Link: https://wiki.mobaledlib.de/_media/medie ... -2021.docx ) und füllen in zur Gänze aus.
Danach sendet Ihr dieses Dokument, einschließlich Eurer Platinenwünsche, per E-Mail an (Link: LedLib@yahoo.com ) zu.
aus gegebenem Anlass:

Hallo Forianer, dieser Hinweis gilt nur für Erstbesteller und Alle, die mir diesen Fragebogen noch nicht zugeschickt haben!

Gruß Alf
Pickel-Bahner seit 1958 / K-Gleis + ZIMO-Decoder (MX633P22/MX645P22)
RocRail & RocNetNode
Email bezüglich MobaLedLib-Belange: LedLib@yahoo.com

WolfHo
InterRegio (IR)
Beiträge: 101
Registriert: Do 10. Okt 2019, 18:41
Nenngröße: N
Stromart: digital
Steuerung: Intellibox, Railware, Arduino
Gleise: Arnold
Wohnort: Dietzenbach
Alter: 75
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4832

Beitrag von WolfHo »

Hallo Alf,
ob man das immer noch so genau weiß??
Aber ist schon o.k.!

Gruß
Wolf
SpurN Arnold Gleis 60 m, Anlage 2,50x0,70 m, Sbhf 16 Gl., Bhf 7 Gl., BW mit Drehscheibe, 50 Loks, Epoche 3, Fahren IBox I Com2, Booster LDT DB-4; Schalten S-DEC-4, WDECN-TN; Melden HSI-88 (Com3), RM-GB-8(-N). Steuerung Railware 7.34, PC: Core i5 750 , 8 GB RAM, Win10 pro 64Bit

aftpriv
EuroCity (EC)
Beiträge: 1014
Registriert: Di 3. Apr 2012, 10:01
Nenngröße: H0
Stromart: digital
Steuerung: Gleisbox+RocRail-RN-Node
Gleise: K-Gleis|:|(3-Leiter)
Wohnort: 636xx Hessen/Main-Kinzig-Kreis
Alter: 70

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4833

Beitrag von aftpriv »

Hallo Wolf
WolfHo hat geschrieben: So 24. Jan 2021, 18:35
ob man das immer noch so genau weiß??
Aber ist schon o.k.!
Also ob man das so schnell vergisst, wenn man schon Platinen bekommen hat :lol: :lol: :lol: ?

Gruß Alf

PS: Du hast Deinen bereits am 23. 10. 2019 ausgefüllt an mich gesendet :!:
Pickel-Bahner seit 1958 / K-Gleis + ZIMO-Decoder (MX633P22/MX645P22)
RocRail & RocNetNode
Email bezüglich MobaLedLib-Belange: LedLib@yahoo.com
Benutzeravatar

fbstr
EuroCity (EC)
Beiträge: 1158
Registriert: So 28. Aug 2016, 21:04
Nenngröße: H0
Stromart: digital
Steuerung: DR5000, Lenz LZV100
Gleise: Peco Code 75, Trix C
Wohnort: Stuttgart
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4834

Beitrag von fbstr »

Neue PushButtons im Miniatur Wunderland!
:D
@Hardi, das sind doch die gleichen Dinger wie wir sie auch haben, oder?

Ab Minute 2:40...
https://youtu.be/KRck3vg2EAI?t=163
Gruss
Frank
---------------------------------------------------------------------------------------------------------------------
MobaLedLib Wiki
Projekt "Bahnpark Augsburg"
Stummitreff BB: normalerweise jeden 3. Freitag im Monat im Haus Sommerhof in Sindelfingen
Benutzeravatar

Threadersteller
Hardi
EuroCity (EC)
Beiträge: 1175
Registriert: Mo 28. Dez 2015, 13:07
Nenngröße: H0
Stromart: digital
Steuerung: MS2 + IR, Eigenbau
Gleise: Märklin C-Gleis
Wohnort: Mainz
Alter: 57
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4835

Beitrag von Hardi »

Hallo Frank,

vielen Dank für den Link. Leider kann man nicht sehen was das für Platinen sind.

Bild
Aber definitiv (noch) keine PushButton Platine der MobaLedLib ;-(

Hardi
Haltet Euch unbedingt von diesen Seiten fern:
͏͏͏ viewtopic.php?f=7&t=165060
͏͏͏ https://wiki.mobaledlib.de/
sonst wird Eure Anlage niemals fertig…

Unsere Anlage findet Ihr unter meinem Profil bei „Webseite“

WolfHo
InterRegio (IR)
Beiträge: 101
Registriert: Do 10. Okt 2019, 18:41
Nenngröße: N
Stromart: digital
Steuerung: Intellibox, Railware, Arduino
Gleise: Arnold
Wohnort: Dietzenbach
Alter: 75
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4836

Beitrag von WolfHo »

Hallo Alf,

danke für Deine Rückmeldung, Du hast das wirklich sehr gut im Griff !!


Bisher habe ich die MLL-Schaltungen der Nanos testweise über Steckboards gemacht, weil der Aufwand noch relativ gering war. Natürlich würde ich auch gerne etwas "professionelles" machen, aber ich möchte jetzt erst mal sehen, wie sich das jetzt mit der Drehscheibensteuerung von Hardi entwickelt, damit ich nichts doppelt kaufe.

Das ist mit euch allen wirklich ein toller Forumsthread. Ich kann das sagen, weil ich zwischenzeitlich auch mal in andere hinein geschaut habe!

Herzliche Grüße
Wolf
SpurN Arnold Gleis 60 m, Anlage 2,50x0,70 m, Sbhf 16 Gl., Bhf 7 Gl., BW mit Drehscheibe, 50 Loks, Epoche 3, Fahren IBox I Com2, Booster LDT DB-4; Schalten S-DEC-4, WDECN-TN; Melden HSI-88 (Com3), RM-GB-8(-N). Steuerung Railware 7.34, PC: Core i5 750 , 8 GB RAM, Win10 pro 64Bit

indy_ch
InterRegio (IR)
Beiträge: 130
Registriert: Mo 26. Sep 2016, 23:18
Steuerung: DR5000
Gleise: 2 Leiter DDC
Wohnort: Aargau CH
Kontaktdaten:
Schweiz

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4837

Beitrag von indy_ch »

Hallo zusammen :)

Grosses Lob an Alf ;) Der Liefert schneller als Reichelt :) Grosses Kino. Die Platinen sehen ebenfalls sehr wärtig aus ...

:gfm: :gfm: :gfm: :gfm:

aftpriv
EuroCity (EC)
Beiträge: 1014
Registriert: Di 3. Apr 2012, 10:01
Nenngröße: H0
Stromart: digital
Steuerung: Gleisbox+RocRail-RN-Node
Gleise: K-Gleis|:|(3-Leiter)
Wohnort: 636xx Hessen/Main-Kinzig-Kreis
Alter: 70

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4838

Beitrag von aftpriv »

Danke für das Lob, Daniel
indy_ch hat geschrieben: Mo 25. Jan 2021, 14:52 ..Lob an Alf ;) Der Liefert schneller als Reichelt :) Grosses Kino. Die Platinen sehen ebenfalls sehr wärtig aus ...
und ebenfalls ein herzliches Dankeschön das Du mir per E-Mail den Erhalt der Sendung mitgeteilt hast!

Leider sind einige Bastler hier sehr säumig, ich muss immer wieder nachfragen ob sie das Päckchen erhalten haben.

In der Paketankündigung schreibe ich immer
Hallo Bastler, ich habe heute Dein Paket weggeschickt, bitte kurz den Erhalt per Email (LedLib@yahoo.com) bestätigen.
Aber leider, von einigen wird dies nicht berücksichtigt!

Heute bekommen die folgenden Stummies wieder eine E-Mail von mir mit der Frage nach dem Erhalt des Päckchens (abgeschickt von mir am 16. 1. 2021):
- schma29
- celkev2020
- W010614
- Thorsten S (Namen eigekürzt)

Gruß Alf
Pickel-Bahner seit 1958 / K-Gleis + ZIMO-Decoder (MX633P22/MX645P22)
RocRail & RocNetNode
Email bezüglich MobaLedLib-Belange: LedLib@yahoo.com

indy_ch
InterRegio (IR)
Beiträge: 130
Registriert: Mo 26. Sep 2016, 23:18
Steuerung: DR5000
Gleise: 2 Leiter DDC
Wohnort: Aargau CH
Kontaktdaten:
Schweiz

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4839

Beitrag von indy_ch »

aftpriv hat geschrieben: Mo 25. Jan 2021, 16:13
und ebenfalls ein herzliches Dankeschön das Du mir per E-Mail den Erhalt der Sendung mitgeteilt hast!

Leider sind einige Bastler hier sehr säumig, ich muss immer wieder nachfragen ob sie das Päckchen erhalten haben.

Gruß Alf
Das liegt wohl dran das ich noch nicht alle Teile von Reichelt habe sonst wäre ich schon längst beim löten ;)
Benutzeravatar

w010614
S-Bahn (S)
Beiträge: 13
Registriert: Di 17. Mär 2015, 23:39
Nenngröße: H0
Stromart: digital
Steuerung: Märklin Gleisbox, Rocrail BPi
Gleise: Märklin C-Gleis

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4840

Beitrag von w010614 »

Hallo zusammen,
Mein Name ist Wilfried, und ich habe von euch Hauptplatine und Verteilerplatine bekommen.
Soweit aufgebaut, Hauptplatine für DCC.
Bin gut mit eurer wirklich tollen Doku sehr gut zurecht gekommen, und es funktioniert auch.

Mir sind allerdings 2 Arduino Nano kaputt gegangen. Lassen sich nicht mehr Programmieren, bzw. werden nicht mehr erkannt.
Zwar sind sie noch an der COM Schnittstelle zu erkennen. Aber das war's.

Ich habe für die 5V Versorgung ein zusätzliches Netzteil an der Verteilerplatine angeschlossen, und auch den USB Stecker aufgesteckt.
Es ist beides mal der LED-Arduino defekt gegangen. Beide liefen erst und sind dann plötzlich beim Einschalten kaputt gegangen.

Ich glaube es war beides mal so, das das zusätzliche Netzteil eingeschaltet war, und als ich dann den USB-Stecker aufsteckte, ging nichts mehr.
Der 3 LED-Arduino läuft jetzt ein paar Tage. Ich hoffe das bleibt jetzt so.

Warum ich das schreibe- vielleicht ist so was bei euch bekannt oder ihr habt einen Hinweis für mich. (Übrigens das zusätzliche Netzteil ist von Meanwell)

Gruß Wilfried
Gruß Wilfried
Benutzeravatar

Saryk
EuroCity (EC)
Beiträge: 1450
Registriert: So 27. Okt 2019, 21:38
Nenngröße: H0
Stromart: digital
Gleise: K-Gleis/C-Gleis
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4841

Beitrag von Saryk »

Moin Wilfried,

dazu gab es mal eine Diskussion ab Beitragsnummer #780 :)

grüße,
Sarah
kiek nich so!
Ungarn, per Bahn || Ideenkiste

Ohne-Glied im Marzibahnerklub
Benutzeravatar

raily74
InterRegioExpress (IRE)
Beiträge: 402
Registriert: Di 5. Dez 2006, 12:04
Nenngröße: H0
Stromart: DC
Steuerung: Z21, iTrain, MobaLedLib
Gleise: Roco Line o. Bettung
Wohnort: Kassel
Alter: 46
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4842

Beitrag von raily74 »

Hallo Wilfried,

willkommen im MobaLedLib-Forum.

Ich kann dir leider im Moment nicht sagen, warum deine LED-Arduinos durchgebrannt sind. Ich kann nur beitragen, dass ich es genauso angeschlossen habe wie du. Die erste Verteilerplatine wird bei mir über ein MeanWell IRM-60-5ST versorgt, der Lötjumper J_Power an der ersten Verteilerplatine ist nicht getrennt, aber auch nicht mit Lötzinn verstärkt. Die Hauptplatine wird also auch mit Strom versorgt, wenn kein USB angeschlossen ist. Beim Programmieren trenne ich die Verbindung zum Netzteil nicht. Die USB-Verbindung steht dauerhaft über ein USB-Hub.
Sarah hat den entsprechenden Beitrag bereits verlinkt, aber auch da steht, dass das eigentlich funktionieren sollte.

Wenn du den Lötjumper J_Power trennst, bekommt die Hauptplatine keinen Strom mehr von deinem Netzteil. Das löst zwar dein Problem, nicht jedoch die Ursache.

Ich nutze aber an dieser Stelle gleich mal das Thema, um meiner Verpflichtung nachzukommen, einzeln abgesicherte Stromkreise am 10 Ampere starken Netzteil zur Verfügung zu stellen. Wenn ich hier entgegen Hardis Empfehlung dieses Netzteil erwähne, so stehe ich wohl auch in der Pflicht, auf die Gefahren hinzuweisen (Kabelbrand). Nach vielen Hinweisen hier im Thread habe ich mich nun für acht Sicherungen à 1,25 A (flink) entschieden. In Bereichen mit sechs statt vier Leitungen könnte ich die Sicherung auf 2 A (flink) erhöhen.

Ich nutze den Sicherungshalter für Feinsicherung 5x20 mm von Pollin. Ich bin halt auch ein Schwabe (nicht nur gebürtig!).
Dazu einen 20-poligen Schraubklemmenblock mit Steckrichtung senkrecht zur Leiterplatte.
Zur Kontrolle der Sicherungen ist eine grüne 3mm LED mit 240 Ohm Widerstand am Ausgang der Sicherung angeschlossen.

Das Ganze wird dann nach inzwischen bekannter Tradition in einem 3D-Gehäuse verkabelt und an die Wand geschraubt. Die Sicherungshalter werden in das Gehäuse mit "Klick" rein gedrückt. Die geschraubte Spange gibt zusätzlichen Halt. Für die Freunde des 3D-Ducks geht es hier zur Druckdatei.
Benötigt werden dann noch Senkkopfschrauben 3 x 10 mm (7 Stück) und 3 x 30 mm (4 Stück).

Bild

Bild
Viele Grüße, Michael
Das 3-Generationen-Projekt | H0-Anlage in Epoche V im Bau
Niederflur-Beiwagen 4NBWE aus dem 3D-Drucker | Von der Skizze zum Modell
Benutzeravatar

w010614
S-Bahn (S)
Beiträge: 13
Registriert: Di 17. Mär 2015, 23:39
Nenngröße: H0
Stromart: digital
Steuerung: Märklin Gleisbox, Rocrail BPi
Gleise: Märklin C-Gleis

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4843

Beitrag von w010614 »

Hallo Sarah, Hallo Michael,

danke für die schnellen Antworten.
Also mein Fazit- eigentlich dürfte nichts passieren. Möglicherweise ist mir auch ein Fehler unterlaufen, ist ja alles noch ein Testaufbau.

Wenn ich jetzt V_pow auf der Verteilerplatine trenne, dann kann ich den Arduino nur noch über USB mit Strom versorge, richtig?

Der Arduino bietet ja noch die Möglichkeit über Vin eine Stromversorgung von 7-12V. Leider ist der Pin auf der Hauptplatine nicht nach aussen geführt.
So könnte ich den Arduino getrennt mit Strom versorgen, ohne den USB anzuschliessen.

Also V_Pow auf der Verteilerplatine trennen, und mit dem dort angeschlossenen 5V Netzteil die Anlage versorgen.
Und mit einem 2ten z.B. Steckernetztei die Arduinos über Vin versorgen.
USB würde ich dann nur aufstecken wenn ich ein neues Programm zum Arduino senden möchte.

Ist das eine Möglichkeit, oder bringt mir das eigentlich nichts.

Grüße Wilfried
Gruß Wilfried

BJS-1952
S-Bahn (S)
Beiträge: 22
Registriert: So 16. Dez 2018, 09:20
Nenngröße: H0
Stromart: digital
Steuerung: CS3
Alter: 69

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4844

Beitrag von BJS-1952 »

Hallo Hardi

ich habe die Idee von deinem Artikel # 1191 gelesen und war total begeistert.

Da ich nicht weiß wie ich in der Größe einen Nullpunkt für einen Steppmotor realisieren kann, habe ich mich für einen Mini Servo entschieden.

Für ein zwei Flügel Signal kann ich einen zweiten Servo in Reihe montieren.

Wenn die anderen bestellten Mini Servo kommen, werde ich mich an ein zwei Flügel Signal machen.

Da ich nicht weiß wie man ein Video einstellt, habe ich die zwei Bilder gemacht.

Gruß Bernd

Bild

Bild
Benutzeravatar

Threadersteller
Hardi
EuroCity (EC)
Beiträge: 1175
Registriert: Mo 28. Dez 2015, 13:07
Nenngröße: H0
Stromart: digital
Steuerung: MS2 + IR, Eigenbau
Gleise: Märklin C-Gleis
Wohnort: Mainz
Alter: 57
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4845

Beitrag von Hardi »

Hallo Wilfried,

erst mal auch ein Herzliches Willkommen bei der MobaLedLib auch von mir.
w010614 hat geschrieben: Mo 25. Jan 2021, 20:57 Mir sind allerdings 2 Arduino Nano kaputt gegangen. Lassen sich nicht mehr Programmieren, bzw. werden nicht mehr erkannt.
Das gleich zwei Nanos bei Dir kaputt gegangen sind ist Super ärgerlich. Aber das liegt definitiv nicht an der Einspeisung über die Verteilerplatine.

Solange Du ein richtig funktionierendes Netzteil hast kann dem Nano nichts passieren. Wenn dieser über die Verteilerplatine gespeist wird dann kommen dort genauso 5V an wie sie aus dem USB-Port kommen oder wie sie über Vin eingespeist werden. Das sieht man in dem Schaltplan des Nanos:
https://cdn.hackaday.io/files/293271254 ... s-rev1.pdf
Die extern Eingespeisten 5V gehen an die gleiche Leitung (Rot hervorgehoben in dem Plan) wie die Spannung aus dem linear Regler (LM1117-5.0) oder die Spannung aus dem USB-Port welcher über die Schottky Diode SD101CSW entkoppelt ist. Die Diode verhindert das der PC schaden nimmt falls eine zu große Spannung eingespeist wird. Ohne sie währe vielleicht auch Dein USB Port kaputt gegangen.

Der Prozessor hält bis zu 5.5V aus. Ich habe Ihn auch schon mit bis zu 5.4V betrieben. Wenn aus irgendeinem Grund eine größere Spannung anliegt, dann ist er beleidigt.

Die Frage ist jetzt wie es dazu kommt. Ich vermute, dass Dein Netzteil schuld ist. Vielleicht entsteht beim Einschalten mit geringer Last ein Überschwinger in der Spannung der den Prozessor grillt.

Wenn das der Fall ist, dann könntest Du den Arduino schützen indem Du ein „besseres“ zweites Netzteil für den Arduino verwendest. Das könnte aber auch ein 5V Netzteil sein welches an die Schraubklemme an der Hauptplatine angeschlossen wird.

Aber was ist mit Deinen LEDs? Laut Datenblatt vertragen die nur 5.3V. Das tauschen von LEDs in einem Modellhäuschen ist kein Spaß. Und wenn Dein Netzteil tatsächlich einen Überschwinger produziert, dann können die LEDs auch erst nach einiger Zeit ausfallen. Ich habe sie schob mit 12V betrieben. Dann leuchten sie sehr schön hell. Allerdings nur wenige Millisekunden lang. Trotzdem sind bei den versehentlichen „Test“ nicht 60 LEDs kaputt gegangen.

Wenn Du auch so dickes 10A Netzteil verwendest wie Michael, dann kann ich mir gut vorstellen das dieses einen Überschwinger produziert, wenn praktisch keine Last angeschlossen ist. Früher gab es Schaltnetzteile welche man gar nicht im Leerlauf betreiben durfte.

Ich bin immer noch der Meinung, dass man die MobaLedLib nicht mit einem so starken Netzteil versorgen sollte. Mehrere kleine 2A Netzteile sind viel besser geeignet. Das freut auch Deine Feuerversicherung.

Wenn Du tatsächlich ein 7-12V Netzteil an Vin des Arduinos Anschließt, dann besteht eine weitere Gefahr. Der Linearregler kann nur 800mA. Das reicht für den Arduino locker. Aber irgendwann wirst Du zu Testzwecken doch mal ein 64er LED-Panel anschließen. Dieses kann knapp 4A verbrauchen. Vermutlich regelt der LM1117-5.0 dann einfach ab. Es könnte aber auch sein, dass er sich richtig Mühe gibt und es Ihm dabei zu warm wird.

=> Verwende ein anderes Netzteil


Evtl. reicht es auch wenn Du eine 5W Birne als Last anschließt.

Wenn Du ein Oszilloskop hast, dann kannst Du ja mal die Spannung messen. Ich bin sehr gespannt ob ich recht habe.

Hardi
Haltet Euch unbedingt von diesen Seiten fern:
͏͏͏ viewtopic.php?f=7&t=165060
͏͏͏ https://wiki.mobaledlib.de/
sonst wird Eure Anlage niemals fertig…

Unsere Anlage findet Ihr unter meinem Profil bei „Webseite“
Benutzeravatar

Threadersteller
Hardi
EuroCity (EC)
Beiträge: 1175
Registriert: Mo 28. Dez 2015, 13:07
Nenngröße: H0
Stromart: digital
Steuerung: MS2 + IR, Eigenbau
Gleise: Märklin C-Gleis
Wohnort: Mainz
Alter: 57
Kontaktdaten:
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4846

Beitrag von Hardi »

Hallo Bernd,

Deine Lösung gefällt mir sehr gut.

Bei dem winzigen von mir verwendeten Stepper benötigt man keinen Nullpunktschalter. Der Stepper ist so schwach, dass man ihn einfach gegen den Anschlag fahren kann.

Ich werde hoffentlich demnächst dazu kommen mit der Stepper Platine zu beginnen. Noch beschäftigt mich aber die Drehscheibe…

Hardi
Haltet Euch unbedingt von diesen Seiten fern:
͏͏͏ viewtopic.php?f=7&t=165060
͏͏͏ https://wiki.mobaledlib.de/
sonst wird Eure Anlage niemals fertig…

Unsere Anlage findet Ihr unter meinem Profil bei „Webseite“

BJS-1952
S-Bahn (S)
Beiträge: 22
Registriert: So 16. Dez 2018, 09:20
Nenngröße: H0
Stromart: digital
Steuerung: CS3
Alter: 69

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4847

Beitrag von BJS-1952 »

Hallo Hardi

ich weiß, dass du mit der Drehscheiben-Steuerung zur Zeit beschäftigt bist und hoffe, dass ich dich mit meiner Signal Steuerung nicht zu sehr nerve.

Mir ist nicht klar, wie der Schrittmotor ohne Nullpunktschalter funktionieren soll. Angenommen der Weg von Hp0 zu Hp1 sind 100 Stepps.
Der Stepper hat 50 Schritte zurückgelegt und plötzlich fällt der Strom aus. Nach Einschalten des Stromes und erneutem betätigen des Taster Hp1 fährt der Stepper seine 100 Stepps Richtung Hp1, die er nach 50 Stepps erreicht hat, und fährt 50 Stepps über seine Hp1 Stellung hinaus.
Wie kann er sich ohne Nullpunktschalter synchronisieren?

Gruß Bernd
Benutzeravatar

Moba_Nicki
InterCity (IC)
Beiträge: 678
Registriert: Di 28. Jan 2020, 18:24
Nenngröße: H0
Stromart: divers
Steuerung: Steuerung im Eigenbau
Gleise: M-Gleis, Spur Z
Wohnort: Nördliches Oberbayern
Alter: 39
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4848

Beitrag von Moba_Nicki »

BJS-1952 hat geschrieben: Di 26. Jan 2021, 07:46 Hallo Hardi

ich weiß, dass du mit der Drehscheiben-Steuerung zur Zeit beschäftigt bist und hoffe, dass ich dich mit meiner Signal Steuerung nicht zu sehr nerve.

Mir ist nicht klar, wie der Schrittmotor ohne Nullpunktschalter funktionieren soll. Angenommen der Weg von Hp0 zu Hp1 sind 100 Stepps.
Der Stepper hat 50 Schritte zurückgelegt und plötzlich fällt der Strom aus. Nach Einschalten des Stromes und erneutem betätigen des Taster Hp1 fährt der Stepper seine 100 Stepps Richtung Hp1, die er nach 50 Stepps erreicht hat, und fährt 50 Stepps über seine Hp1 Stellung hinaus.
Wie kann er sich ohne Nullpunktschalter synchronisieren?

Gruß Bernd
Hallo Bernd

der Steuer-IC (vermutlich Attiny-84 oder 85) der geplanten Stepperplatine hat eine Brown-Out-Detection und merkt sich daher bei einem Verlust oder Einbruch der Spannung den aktuellen Positionswert des Steppers.
Daher kann der IC nach der Wiederherstellung der Spannungsversorgung den Stepper in die gewünschte Position bzw in eine Defaultposition bringen.

Schöne Grüße
Dominik
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/

Matthias_h0
InterRegio (IR)
Beiträge: 109
Registriert: So 29. Nov 2020, 17:34
Nenngröße: H0
Stromart: digital
Steuerung: MS2, MobaLedLib
Gleise: Märklin C- Gleis
Deutschland

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4849

Beitrag von Matthias_h0 »

Hallo,
Wenn die Nanos abrauchen, ist meistens diese Diode auf der Unterseite kaputt(auf dem Bild markiert)
Bild
Diese kann man ganz einfach auslöten und durch eine neue 1N4001 Diode tauschen. Hat man keine Smd Diode da, kann man auch eine ganz normale Diode nehmen.
Das sieht dann so aus:

Bild

So kann man die Nanos ganz einfach wieder reparieren. Ich habe das bei mir jetzt schon mehrfach gemacht und die Arduinos funktionieren wieder tadellos.

Viele Grüße,
Matthias
Viele Grüße
Matthias

MobaLedLib Wiki
Benutzeravatar

Jueff
InterRegio (IR)
Beiträge: 113
Registriert: Mi 25. Mär 2020, 08:26
Nenngröße: H0
Stromart: DC
Steuerung: Roco z21
Gleise: Roco line
Wohnort: Hallein
Alter: 55
Österreich

Re: MobaLedLib: 768 LEDs, Servos, Sound, …………… Zwei Jahre MobaLedLib!

#4850

Beitrag von Jueff »

BJS-1952 hat geschrieben: Di 26. Jan 2021, 07:46 Hallo Hardi

ich weiß, dass du mit der Drehscheiben-Steuerung zur Zeit beschäftigt bist und hoffe, dass ich dich mit meiner Signal Steuerung nicht zu sehr nerve.

Mir ist nicht klar, wie der Schrittmotor ohne Nullpunktschalter funktionieren soll. Angenommen der Weg von Hp0 zu Hp1 sind 100 Stepps.
Der Stepper hat 50 Schritte zurückgelegt und plötzlich fällt der Strom aus. Nach Einschalten des Stromes und erneutem betätigen des Taster Hp1 fährt der Stepper seine 100 Stepps Richtung Hp1, die er nach 50 Stepps erreicht hat, und fährt 50 Stepps über seine Hp1 Stellung hinaus.
Wie kann er sich ohne Nullpunktschalter synchronisieren?

Gruß Bernd
Hallo Bernd,


Ich plane schon seit Wochen, diese kleinen Microstepper als Weichenantrieb zu verwenden, da sie sehr leise sind und aufgrund ihrer Bauform einen sehr flachen Aufbau ermöglichen.
Bild Klick zum Vergößern

Ich habe auch schon ein paar Prototypen Aufbauten gemacht, komme aber aufgrund meiner anderen Mobaledlib Entwicklungstätigkeiten im Bereich ESP32 und DMX512 derzeit nicht besonders schnell weiter.

Meine bisherigen Erkenntnisse zeigen, dass man auf beiden Seiten einen festen Anschlag braucht, der den maximalen Weg begrenzt. Mein Stepper hat einen Anschlag bauseits, den zweiten möchte ich in die Halterung integrieren, z.B. mit einer Stellschraube.

In deinem Beispiel würde der Servo dann nach 50 Schritten gegen den Anschlag fahren, was bei der geringen Leistung dieses Microsteppers kein Problem darstellt. PC Floppy Disk Laufwerke machen das seit Jahrzenten so (für die Jüngerung unter uns: Diskettenlaufwerk).

Nach der Bewegungsphase muss sich das Programm die aktuelle Position merken, um zu vermeiden, dass dieselbe Postion nochmals angefahren wird, obwohl der Stepper schon dort ist. Das verhindert ein erneutes Fahren gehen den Anschlag.

Besser wäre es natürlich, sich die Position auch während der Bewegung im EEProm zu speichern, dazu habe ich aber noch keine Lösung, das EEPROM hat eine begrenzte Anzahl von Schreibzyklen, ein ständiges Speichern der Position würde das EEProm schnell kaputt machen. Ein Hardwareanschlag gefällt mir auch trotz Softwarelösung besser, damit nicht bei eventuellen Softwarefehlern der Stepper zu ungewollten Positionen fährt, was dann zu Zerstörungen an den angeschlossenen Signalen, Weichen etc. führen kann.

Jürgen...
Alle Infos zur MobaLedLib findet ihr hier: https://wiki.mobaledlib.de/
Antworten

Zurück zu „Software und Hardware“