RE: Tams CV-Navi auf Apple Mac

#1 von nakott , 23.11.2018 09:07

Hallo,

es kommt hin und wieder zu Fragen, wie man das Tams CV-Navi auf Apple Mac betreiben kann.

Dieser Thread soll nun alle Fragen und Diskussionen darüber bündeln.

Zunächst ist wichtig zu verstehen, dass das CV-Navi den USB Port exklusiv benutzt. D.h., dass über den gleichen USB Port nicht gleichzeitig auch Rocrail oder iTrain benutzt werden kann. Also entweder CV-Navi oder Rocrail/iTrain starten.

Dann gibt es in hier bereits Diskussionen und Anleitungen zu diesem Thema:

viewtopic.php?p=1593476#p1593476
viewtopic.php?p=1878891#p1878891

Wer also nun Fragen zu CV-Navi auf dem Mac hat, kann diese gerne hier stellen. Vielleicht können wir dann gemeinsam eine Lösung finden.

Viele Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 7.221
Registriert am: 04.07.2007


RE: Tams CV-Navi auf Apple Mac

#2 von Tariannor ( gelöscht ) , 23.11.2018 16:59

Hallo zusammen,

zunächst möchte Dirk danken, dass er diesen Thread eröffnet hat, nachdem ich ihn persönlich angeschrieben habe.

Ich arbeite zu Hause nur mit Macs, und einer davon, ein Mac-Mini, steuert meine Märklin-Moba. Das Betriebssystem ist Mac OS "High Sierra".
Die Digitalzentrale ist eine Tams Master Control, mit der ich eigentlich sehr zufrieden bin.
Über die serielle Schnittstelle bekommen beide auch ohne große Probleme Kontakt.

Da ich das CV-Navi ebenfalls einsetzen möchte, habe ich nun Computer und MC über USB miteinander verbunden. Ich habe die neueste Version Navi 3.0 installiert, ebenso ist Java installiert sowie der USB-Treiber (von der entsprechenden Seite herauntergeladen). CV-Navi startet auch ohne Probleme.

Wenn ich jedoch beim Port /dev/tty.SLAB_USBtoUART eingebe, dann bekomme ich regelmäßig die Meldung, dass keine Verbindung da ist.

Könnt Ihr mir hier bitte weiterhelfen?

Vielen Dank im voraus,

viele Grüße Thomas


Tariannor

RE: Tams CV-Navi auf Apple Mac

#3 von nakott , 24.11.2018 11:04

Hallo Thomas,

ich meine folgendes verstanden zu haben:

Du nutzt eine Tams MC und nicht die Tams RB
USB 1 am Mac Mini verbunden mit USB-Seriell-Adapter verbinden mit Serieller Schnittstelle der Tams MC
USB 2 am Mac Mini verbunden mit USB Schnittstelle der Tams MC
Für Rocrail benutzt Du die Verbindung über USB 1
Für CV-Navi möchtest Du die Verbindung über USB 2 nutzen

Welchen Device Name trägst Du in Rocrail ein?

Bzgl. der Tams USB Schnittstelle an der MC. Das ist zwar physisch eine Silab Chipsatz, aber er hat eine andere Kennung. Und zwar eine Tams Kennung. Aus diesem Grund wird der Silab Treiber die USB der Tams MC nicht erkennen. Unter Windows ist es das Gleiche, weswegen man auch den Tams Treiber für USB Schnittstelle der MC benutzen muss.

Es gibt aber die Möglichkeit, die Kennung der Tams MC USB Schnittstelle von Tams auf Silab zu ändern. Dazu stellt Tams eine kl. Programm zur Verfügung, das allerdings nur unter WIndows XP funktioniert. Alternativ kann man die MC zu Tams einschicken und Tams ändert das für einen.

Bei der Tams RB, die man mit 2 * USB bekommt, hat eine Schnittstelle die Silab Kennung und eine die Tams Kennung.

Wenn also Rocrail funktioniert, kannst Du zu Testzwecken versuchen, CV-Navi mit dem USB Device Name zu verwenden, den Du sonst für Rocrail benutzt. Rocrail muss dann in dieser Zeit gestoppt sein!

Viele Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 7.221
Registriert am: 04.07.2007


RE: Tams CV-Navi auf Apple Mac

#4 von Tariannor ( gelöscht ) , 25.11.2018 19:04

Hallo Dirk,

vielen Dank für Deine rasche Antwort - und die Lösung des Problems!

Ja, das hast Du alles so richtig verstanden. allerdings habe ich nur versucht, die Verbindung von CV-Navi mit der Master Control über USB 2 herzustellen (ausschließlich).

Das scheint nicht zu klappen - aber dann ist mir ein Licht aufgegangen, als Du gesagt hast, dass der Silab Treiber die USB der Tams nicht erkennen kann (so etwas hatte ich vorher schon vermutet...).

Dann habe ich ganz einfach die serielle Schnittstelle der Master Control genommen und sie über USB Adapter an den Mac Mini angeschlossen.
Sodann habe im CV-Navi den port /dev/tty.usbserial-FTFVE9EO eingegeben, der bei mir auch in Rocrail drinsteht.

Und siehe da: Es klappt jetzt alles und ich kann mit dem CV-Navi ebenfalls fahren!

Ja und klar: Ich kann nicht Rocrail und CV-Navi nebeneinander laufen lassen!

Vielen Dank für Deine Hilfe und Deine Mühen,

herzliche Grüße Thomas


Tariannor

RE: Tams CV-Navi auf Apple Mac

#5 von Egon , 02.01.2019 12:10

Zitat

Hallo,

es kommt hin und wieder zu Fragen, wie man das Tams CV-Navi auf Apple Mac betreiben kann.

Dieser Thread soll nun alle Fragen und Diskussionen darüber bündeln.

.....
Viele Grüße Dirk


Hallo Dirk,
nachdem CV-Navi nun bei mir am MAC über die Schnittstelle USB-2 läuft die Frage wie ich USB-1 verwenden kann? Gibt es dafür einen Treiber? Und/oder wie kann/könnte ich beide USB Schnittstellen parallel nutzen - Rocrail und CV-Navi gleichzeitig?
Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 712
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams CV-Navi auf Apple Mac

#6 von LDG , 02.01.2019 13:21

Hallo Egon,

Zitat

nachdem CV-Navi nun bei mir am MAC über die Schnittstelle USB-2 läuft die Frage wie ich USB-1 verwenden kann? Gibt es dafür einen Treiber?

Man kann eventuell die USB-1 von der Tams- auf die SiLabs-Kennung zurücksetzen. Dann ist es der selbe Treiber wie für USB-2. Das erfordert einen Windows-PC mit funktionierendem Tams-Treiber und Zugriff über USB-1. Das geht bei Tams in Hannover oder auch bei mir (Großraum KA/HD/MA/LU/SP, ab und zu auch Stummitreff-WN/BB oder...) oder bei anderen Benutzern, die damit Erfahrung haben.[quote=Egon]Und/oder wie kann/könnte ich beide USB Schnittstellen parallel nutzen - Rocrail und CV-Navi gleichzeitig?[/quote]Das geht. Ich hab es selbst schon ausprobiert. Aber: Der Zentrale ist es egal über welche Schnittstelle irgendwelche, auch sich widersprechende(!), Befehle kommen. Das sollte man möglichst vermeiden oder sehr genau wissen was mit welchen Befehlen tut und dabei ggf. den Automatikbetrieb "torpediert".
Besser ist es wenn immer nur ein Programm über eine Schnittstelle auf die Zentrale zugreift.

Gruß,
Lothar

PS: Seit CV-Navi Beta 3.1 vom 2.1.2019 sollte die Angabe des JAVA_HOME - Pfades beim Aufruf von CV-Navi.sh auf OS-X nicht mehr notwendig sein
Bitte testen und berichten.
EDIT: Leider muß man bei OS-X zunächst weiterhin die JAVA_HOME setzen. Ich muß mir da noch etwas überlegen.


Termine des Mist67 (Speyer)
Stummitreff WN: jeden 1. Freitag im Monat in Winnenden
Stummitreff BB: jeden 3. Freitag im Monat in Sindelfingen

meine Rocrail Hilfsmittel Online

H0 mit/ohne Pickel, Rocrail, Tams RB+MC+HC+mC+xnC dazu B-4, BiDiB-Interface, -Booster, RC-Link, CS2/MS2 und ECoS2.
Dazu diverses historisches Gedöns wie MS1, CU, IB-IR, HSI-88,...


 
LDG
EuroCity (EC)
Beiträge: 1.299
Registriert am: 07.11.2007
Ort: bei Karlsruhe
Gleise Märklin Modell, M, K, α und C ; RocoLine m. Bettung
Spurweite H0
Steuerung Digital und Analog
Stromart Digital, Analog


RE: Tams CV-Navi auf Apple Mac

#7 von Egon , 02.01.2019 13:40

Halo Lothar,
danke und ich teste 3.1 mal. Habe nur etwas wenig Zeit im Moment.

Gruß
Egon


Egon  
Egon
InterCity (IC)
Beiträge: 712
Registriert am: 14.01.2010
Ort: Ruhrgebiet
Spurweite H0
Steuerung TAMS MC
Stromart AC, Digital


RE: Tams CV-Navi auf Apple Mac

#8 von nakott , 02.01.2019 20:18

Hallo,

zur Vollständigkeit ein Link mit Infos zu JAVA_HOME
viewtopic.php?p=1918233#p1918233

Grüße Dirk


Anlage URI


 
nakott
ICE-Sprinter
Beiträge: 7.221
Registriert am: 04.07.2007


RE: Tams CV-Navi auf Apple Mac

#9 von Maehlmaen , 13.06.2020 21:44

Hallo zusammen,
Ich hab versucht meine Tams RedBox auf dem Mac zu installieren. Hab das Problem das sowohl bei CV-Navi und bei RocRail das Problem einer Zeitüberschreitung kommt. Gestern Abend hat es nach der Eingabe von purejavacomm als Name der Zentrale einmal funktioniert, heute ohne eine Änderung kommt die Meldung in RocRail. Kann jemand damit was anfangen? Und hat vielleicht auch eine Lösung?
Vielen Dank schon mal.


Maehlmaen  
Maehlmaen
Beiträge: 2
Registriert am: 13.06.2020


RE: Tams CV-Navi auf Apple Mac

#10 von Burkhard Ascher , 14.06.2020 08:23

Hallo ?

Ich hatte das Problem bei der umstellung auf Win10. Ja ist kein Mac.
Versuche es mal mit der der Bautrate. Bei 19200 für beide Geräte funktionierte es wieder.


MfG
Burkhard
Mein Youtube


 
Burkhard Ascher
InterCity (IC)
Beiträge: 642
Registriert am: 29.04.2005
Ort: Essen
Gleise C+K-Gleis
Spurweite H0
Steuerung TC 10 Gold / Tams MC / MS2
Stromart AC, Digital


RE: Tams CV-Navi auf Apple Mac

#11 von Maehlmaen , 14.06.2020 10:23

Hab alle Baudraten schon getestet. Hatte leider keinen Erfolg.
Danke für den Tipp


Maehlmaen  
Maehlmaen
Beiträge: 2
Registriert am: 13.06.2020


   


  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
Xobor Einfach ein eigenes Forum erstellen
Datenschutz