Märklin 60883 - LinkS88; erster Testbericht

Bereich für alle Themen rund um Digitaltechnik und digitale Umbauten.
Benutzeravatar

Threadersteller
DiegoGarcia
InterCityExpress (ICE)
Beiträge: 2349
Registriert: So 15. Apr 2007, 12:13
Alter: 104

Märklin 60883 - LinkS88; erster Testbericht

#1

Beitrag von DiegoGarcia » Mi 8. Apr 2015, 11:29

Hallo zusammen,

heute in der Post: Märklin LinkS88 aka 60883. Erstes Bild meinerseits:

Bild

Hinweis zum Auspacken: OVP von der obigen Stirnseite her öffnen, und nicht versuchen, den Innenkarton herauszuziehen, könnte sonst die OVP einreißen.

Innenleben: LinkS88 mit daran befestigtem schwarzen Kabel, BDA und Garantiekarte. Der Stecker als Verbindung zur CS2/Terminal ist 7-polig mit zentralem Plastik-Führungsstift, paßt physisch in die Buchsen des Terminals 60125 und in die CS2 Booster-Buchse. Das Kabel ist mit dem LinkS88 fest verbunden. Länge des Kabels ab Gehäuse bis zur Steckerspitze ca. 164cm. Für die Stromversorgung ist laut Label auf der Unterseite des Gehäuses 19V DC vorgesehen, laut BDA sind die Steckernetzteile 66361 oder 66201 dafür geeignet.

Das Gehäuse läßt sich nach oben vorsichtig abziehen und wird von 4 kleinen Kunststoffzapfen in Position gehalten. Meine Platine trägt den Titel "MAERKLIN S88 LINK Rev2 Sontheim GmbH 2014 M219000502".

Bild

Nun die Platinenunteseite:

Bild

Soviel erst mal für den ersten Augenblick.

Die BDA ist auch schon seit 1 Woche online:

Code: Alles auswählen

http://medienpdb.maerklin.de/product_files/1/pdf/60883_betrieb.pdf
Also habe ich dann mein LinkS88-Modul an ein Steckernetzteil 66201 und dann die CS2 angeschlossen, es wurde mit der Gerätekenner-ID 152 erkannt. Datenstrom beim Anstecken (ohne Pings):

Code: Alles auswählen

erster Datenstrom beim Anschliessen des m60883 LinkS88
Datum: 2015-04-08

in:00366F7D 0 43540EA8 03 12 00 00   <---- CAN-Bootloader request mit DLC=0
in:00306F7D 0 43540EA8 03 12 00 00   <---- Ping request mit DLC=0
in:0031FF4D 8 43540EA8 03 12 00 00   <---- Ping Antwort vom GFP, Geräte-Typ 0x00
in:00366F7D 0 43540EA8 03 12 00 00   <---- CAN-Bootloader request mit DLC=0
in:00375F20 8 53383898 01 00 00 40   <---- mein LinkS88 antwortet auf CAN-Bootloader mit Geräte-Typ 0x40
in:00366F7D 5 53383898 E4 00 00 40   <---- CAN-Bootloader request mit DLC=5 an den LinkS88, Param 0xE4
in:00366F7D 5 53383898 11 00 00 40   <---- CAN-Bootloader request mit DLC=5 an den LinkS88, Param 0x11
in:00306F7D 0 53383898 11 00 00 40   <---- Ping request mit DLC=0
in:0031FF4D 8 43540EA8 03 12 00 00   <---- Ping Antwort vom GFP, Geräte-Typ 0x00
in:00315F20 8 53383898 01 00 00 40   <---- Ping Antwort vom LinkS88, Geräte-Typ 0x40
in:00016F7D 7 53383898 0C 00 98 40   <---- meine CS2 sendet dem LinkS88 seine Gerätekennung mittels System-Subcmd 0x0C: 0x0098
in:00006F7D 6 43540EA8 0B 01 98 40
in:00006F7D 6 43540EA8 0B 02 98 40
in:0001FF4D 8 43540EA8 0B 01 00 00
in:0001FF4D 8 43540EA8 0B 02 00 00
in:00006F7D 6 43540EA8 0B 03 00 00
in:00006F7D 6 43540EA8 0B 04 00 00
in:0001FF4D 8 43540EA8 0B 03 01 D9
in:0001FF4D 8 43540EA8 0B 04 00 3F
in:003A6F7D 5 53383898 00 04 00 3F   <---- Statusdaten request mit DLC=5 an den LinkS88, Index=0 (Gerätebeschreibung)
in:003B0301 8 000C0000 00 00 00 98   <---- Statusdaten-Paket1 vom LinkS88, Messwertkanäle=0, Konfig-Kanäle=12, Serien-Nr=0x00000098
in:003B0302 8 36303838 33 00 00 00   <---- Statusdaten-Paket2 vom LinkS88, weitere Infos
in:003B0303 8 4C696E6B 20 53 38 38   <---- Statusdaten-Paket3 vom LinkS88, weitere Infos
in:003B0304 8 00000000 00 00 00 00   <---- Statusdaten-Paket4 vom LinkS88, weitere Infos, terminiert mit 0x00
in:003B5F20 6 53383898 00 04 00 00   <---- Statusdaten-Antwort vom LinkS88 mit DLC=6: Index=0, Paketanzahl=4
in:003A6F7D 5 53383898 01 04 00 00
out:003A0300 5 53383898 00 00 00 00
in:003B0301 8 01010200 00 00 00 00
in:003B0302 8 41757377 65 72 74 75
in:003B0303 8 6E672031 20 2D 20 31
in:003B0304 8 36004569 6E 7A 65 6C
in:003B0305 8 6E005461 73 74 61 74
in:003B0306 8 75726D61 74 72 69 78
in:003B0307 8 00000000 00 00 00 00
in:003B5F20 6 53383898 01 07 00 00
in:003A6F7D 5 53383898 02 07 00 00
in:003B0301 8 02020000 00 1F 00 00
in:003B0302 8 4CC3A46E 67 65 20 42
in:003B0303 8 75732031 20 28 52 4A
in:003B0304 8 34352D31 29 00 30 00
in:003B0305 8 33310000 00 00 00 00
out:003A0300 5 43540EA8 00 00 00 00
in:003B5F20 6 53383898 02 05 00 00
out:003A0300 5 43540EA9 00 00 00 00
in:003B0301 8 000C0000 00 00 00 98
in:003B0302 8 36303838 33 00 00 00
in:003B0303 8 4C696E6B 20 53 38 38
in:003B0304 8 00000000 00 00 00 00
in:003B5F20 6 53383898 00 04 00 00
in:003A6F7D 5 53383898 03 04 00 00
out:003A0300 5 53383898 00 00 00 00
in:003B0301 8 03020000 00 1F 00 00
in:003B0302 8 4CC3A46E 67 65 20 42
in:003B0303 8 75732032 20 28 52 4A
in:003B0304 8 34352D32 29 00 30 00
in:003B0305 8 33310000 00 00 00 00
in:003B5F20 6 53383898 03 05 00 00
in:003A6F7D 5 53383898 04 05 00 00
in:003B0301 8 04020000 00 1F 00 00
in:003B0302 8 4CC3A46E 67 65 20 42
in:003B0303 8 75732033 20 28 36 2D
in:003B0304 8 506F6C69 67 29 00 30
in:003B0305 8 00333100 00 00 00 00
in:003B5F20 6 53383898 04 05 00 00
in:003A6F7D 5 53383898 05 05 00 00
in:003B0301 8 0502000A 03 E8 00 64
in:003B0302 8 5A796B6C 75 73 7A 65
in:003B0303 8 69742042 75 73 20 31
in:003B0304 8 2028524A 34 35 2D 31
in:003B0305 8 29003130 00 31 30 30
in:003B0306 8 30006D73 00 00 00 00
in:003B5F20 6 53383898 05 06 00 00
in:003A6F7D 5 53383898 06 06 00 00
in:003B0301 8 0602000A 03 E8 00 64
in:003B0302 8 5A796B6C 75 73 7A 65
in:003B0303 8 69742042 75 73 20 32
in:003B0304 8 2028524A 34 35 2D 32
in:003B0305 8 29003130 00 31 30 30
in:003B0306 8 30006D73 00 00 00 00
in:003B5F20 6 53383898 06 06 00 00
in:003A6F7D 5 53383898 07 06 00 00
in:003B0301 8 0702000A 03 E8 00 64
in:003B0302 8 5A796B6C 75 73 7A 65
in:003B0303 8 69742042 75 73 20 33
in:003B0304 8 2028362D 50 6F 6C 69
in:003B0305 8 67290031 30 00 31 30
in:003B0306 8 3030006D 73 00 00 00
in:003B5F20 6 53383898 07 06 00 00
in:003B0301 8 04020000 00 00 6E 54
in:003B0302 8 36303231 35 00 00 00
in:003A6F7D 5 53383898 08 00 00 00
in:003B0301 8 08020064 03 E8 00 A7
in:003B0302 8 4269747A 65 69 74 20
in:003B0303 8 43656E74 72 61 6C 20
in:003B0303 8 53383800 31 30 30 00
in:003B0304 8 31303030 00 C2 B5 73
in:003B0305 8 00000000 00 00 00 00
in:003B5F20 6 53383898 08 05 00 00
in:003B0304 8 53746174 69 6F 6E 20
in:003A6F7D 5 53383898 09 6F 6E 20
in:003B0301 8 0902000A 03 E8 00 64
in:003B0302 8 5A796B6C 75 73 7A 65
in:003B0303 8 69742031 20 2D 20 31
in:003B0304 8 36003130 00 31 30 30
in:003B0305 8 30006D73 00 00 00 00
in:003B5F20 6 53383898 09 05 00 00
in:003B0305 8 32000000 00 00 00 00
in:003A6F7D 5 53383898 0A 00 00 00
in:003B0301 8 0A02000A 00 64 00 25
in:003B0302 8 5A796B6C 75 73 7A 65
in:003B0303 8 69742054 61 73 74 61
in:003B0304 8 74757200 31 30 00 31
in:003B0305 8 3030006D 73 00 00 00
in:003B5F20 6 53383898 0A 05 00 00
in:003BFF4D 5 43540EA8 00 05 00 00
in:003A6F7D 5 53383898 0B 05 00 00
in:003B0301 8 0B020000 00 08 00 00
in:003B0302 8 5370616C 74 65 6E 20
in:003B0303 8 54617374 61 74 75 72
in:003B0304 8 00300038 00 00 00 00
in:003B5F20 6 53383898 0B 04 00 00
in:003A6F7D 5 53383898 0C 04 00 00
in:003B0301 8 0C020000 00 0F 00 00
in:003B0302 8 5A65696C 65 6E 20 54
in:003B0303 8 61737461 74 75 72 00
in:003B0304 8 30003135 00 00 00 00
in:003B5F20 6 53383898 0C 04 00 00
in:003B0301 8 000C0000 00 00 00 98
in:003B0302 8 36303838 33 00 00 00
in:003B0303 8 4C696E6B 20 53 38 38
in:003B0304 8 00000000 00 00 00 00
in:003B5F20 6 53383898 00 04 00 00
in:00366F7D 0 53383898 00 04 00 00
in:00306F7D 0 53383898 00 04 00 00   <---- Ping request mit DLC=0
in:0031FF4D 8 43540EA8 03 12 00 00   <---- Ping Antwort vom GFP, Geräte-Typ 0x00
in:00315F20 8 53383898 01 00 00 40   <---- Ping Antwort vom LinkS88, Geräte-Typ 0x40
in:00006F7D 6 43540EA8 0B 01 00 40
in:00006F7D 6 43540EA8 0B 02 00 40
in:0001FF4D 8 43540EA8 0B 01 00 00
in:0001FF4D 8 43540EA8 0B 02 00 00
in:00006F7D 6 43540EA8 0B 03 00 00
out:00000300 6 43540EA8 0B 01 00 00
in:00006F7D 6 43540EA8 0B 04 00 00
in:0001FF4D 8 43540EA8 0B 03 01 D8
in:0001FF4D 8 43540EA8 0B 04 00 3F
in:0001FF4D 8 43540EA8 0B 01 00 00
out:00000300 6 43540EA8 0B 02 00 00
in:0001FF4D 8 43540EA8 0B 02 00 00
out:00000300 6 43540EA8 0B 03 00 00
in:0001FF4D 8 43540EA8 0B 03 01 D8
out:00000300 6 43540EA8 0B 04 00 00
in:0001FF4D 8 43540EA8 0B 04 00 3F
in:00366F7D 0 43540EA8 0B 04 00 3F
in:00306F7D 0 43540EA8 0B 04 00 3F
in:0031FF4D 8 43540EA8 03 12 00 00
in:00315F20 8 53383898 01 00 00 40
in:00366F7D 0 53383898 01 00 00 40
in:00306F7D 0 53383898 01 00 00 40
in:00315F20 8 53383898 01 00 00 40
in:0031FF4D 8 43540EA8 03 12 00 00
in:00366F7D 0 43540EA8 03 12 00 00
in:00306F7D 0 43540EA8 03 12 00 00
in:0031FF4D 8 43540EA8 03 12 00 00
in:00315F20 8 53383898 01 00 00 40
in:00366F7D 0 53383898 01 00 00 40
in:00306F7D 0 53383898 01 00 00 40
in:0031FF4D 8 43540EA8 03 12 00 00
in:00315F20 8 53383898 01 00 00 40
Dann habe ich Masse am LinkS88 (umgedrehtes "T") mit der Masse der CS2 verbunden und mal testweise Kontakt 5 ausgelöst. Es kamen die entsprechenden Meldungen am Mac an "Gerätekenner 152 / Kontakt 5" was ja passt, da die 16 Sensor-Buchsen des LinkS88 ja als "Bus 0" gelten, wenn sie als normale Sensoren konfiguriert sind:

Code: Alles auswählen

Datenstrom beim Auslösen Kontakt "5" an Bus "0" meines m60883 LinkS88
Datum: 2015-04-08

mein LinkS88 hat den Gerätekenner 152 = 0x98

in:00235F20 8 00980005 00 01 02 08
in:00235F20 8 00980005 01 00 00 1E
in:00235F20 8 00980005 00 01 00 FA
in:00235F20 8 00980005 01 00 00 14
So wird das neue LinkS88 im Info-Feld des CS2-Setup bzw. im "CS2-Setup -> Schraubenschlüssel -> Geräte"-Feld in der Liste der Automatikgeräte angezeigt (wie gesagt, mein LinkS88 hat den Gerätekenner "152"):

Bild

Bild

Und über "CS2-Setup -> Schraubenschlüssel -> Info" lassen sich auch die Parameter der LinkS88-Busse ändern, wie in der BDA angegeben:

Bild

Aus meiner Sicht läuft das alles reibungslos, allerdings muss ich meine Software auf den Umgang mit so hohen Gerätekennern noch anpassen. Wahrscheinlich werde ich bis zum Kenner 512 alles vorbereiten, um so für den Extremfall 5 Millionen Sensoren theoretisch reservieren zu können. In SDL und C2XH wird der LinkS88 auch als Gerät erkannt, in iTrain z.Zt. aber evtl. noch nicht:

Bild


Die Sicherung der Daten eines LinkS88 erfolgt in der Backup-Datei "geraete.cs2":

Code: Alles auswählen

[geraete]
version
 .minor=1
device
 .uid=0x43540ea8
 .kennung=0xffff
 .vmajor=3
 .vminor=18
 .kanal
 ..nr=1
 ..name=Trafo:
 ..wert=2
 .kanal
 ..nr=2
 ..name=6095 mix mode:
device
 .uid=0x53383898
 .kennung=0x98
 .typ=64
 .vmajor=1
 .kanal
 ..nr=1
 ..name=Auswertung 1 - 16
 .kanal
 ..nr=2
 ..name=Länge Bus 1 (RJ45-1)
 .kanal
 ..nr=3
 ..name=Länge Bus 2 (RJ45-2)
 .kanal
 ..nr=4
 ..name=Länge Bus 3 (6-Polig)
 .kanal
 ..nr=5
 ..name=Zykluszeit Bus 1 (RJ45-1)
 ..wert=100
 .kanal
 ..nr=6
 ..name=Zykluszeit Bus 2 (RJ45-2)
 ..wert=100
 .kanal
 ..nr=7
 ..name=Zykluszeit Bus 3 (6-Polig)
 ..wert=100
 .kanal
 ..nr=8
 ..name=Bitzeit S88
 ..wert=167
 .kanal
 ..nr=9
 ..name=Zykluszeit 1 - 16
 ..wert=100
 .kanal
 ..nr=10
 ..name=Zykluszeit Tastatur
 ..wert=37
 .kanal
 ..nr=11
 ..name=Spalten Tastatur
 .kanal
 ..nr=12
 ..name=Zeilen Tastatur

Die Abfrage der Statusdatenkonfiguration mittels 0x1D, in CAN-ID: 0x3A liefert bei meinem LinkS88:

Code: Alles auswählen

out:003A0300 5 53383898 00 00 00 00    --> Abfrage Index 0 "Gerätebeschreibung"
in:003B0301 8 000C0000 00 00 00 98     <--- keine Messwerte, 12 Konfigurationskanäle, Seriennummer 0x00000098
in:003B0302 8 36303838 33 00 00 00     <--- Artikelnummer "60883"
in:003B0303 8 4C696E6B 20 53 38 38     <--- Gerätebezeichnung "Link S88"
in:003B0304 8 00000000 00 00 00 00
Auswertung des CAN-Verkehrs aus meiner bescheidenen Sicht:
- die 32bit-Geräte-UID meines LinkS88 0x53383898 ist in ASCII übersetzt "S88" + Gerätekennung-ab-Werk. Dies ändert sich auch nicht, wenn man den Gerätekenner umkonfiguriert. Dies entspricht dem Hinweis in cs2CAN-Protokoll-2_0.pdf auf Seite 24: "...Die Master - Zentrale weist den Endgeräten die Geräte - Kennung beim Systemstart jeweis zu. Eine Resetfeste Speicherung findet in den Geräten nicht statt. ..."
- Befehl Softwarestand/Ping (0x18, CAN-ID 0x30): der LinkS88 antwortet auf Ping mit Ping-Gerätetyp 0x40.
- Befehl Systembefehl (0x00, CAN-ID 0x00): der LinkS88 sendet seine Gerätekennung mittels System-Subcmd 0x0C selbstständig?


Ciao
Diego

PS: http://www.sontheim-industrie-elektronik.de/

EDIT: weitere Beiträge
http://www.stummiforum.de/viewtopic.php?t=142109 - CS3+ und S88 (Okt. 2016)
http://www.stummiforum.de/viewtopic.php?t=139035 - s88 zerschossen? (Juli 2016)
http://www.stummiforum.de/viewtopic.php?t=136487 - L88 mit Diodentrick ? (April 2016)
http://www.stummiforum.de/viewtopic.php?t=135775 - Märklin: CS2 Update beseitigt L88 Problem ! ? (Mrz. 2016)
http://www.stummiforum.de/viewtopic.php?t=135301 - Probleme 60883 Märklin L88 (Mrz. 2016)
http://www.stummiforum.de/viewtopic.php?t=133808 - Keine korrekte Rückmeldung mit L88 60883 nach dem Starten der CS2 (Jan. 2016, GELÖST)
http://www.stummiforum.de/viewtopic.php?t=126310 - Probleme mit dem S88 Link und 2x CS2 (Juli 2015)
http://www.stummiforum.de/viewtopic.php?t=125749 - Einstellungen am L88 (Märklin #60883) (Juni 2015, GELÖST)
http://www.stummiforum.de/viewtopic.php?t=87830 - Anschluss der neuen Märklin Rückmeldemodule S88 u. L88 (März 2016)
Zuletzt geändert von DiegoGarcia am Fr 28. Okt 2016, 05:39, insgesamt 22-mal geändert.
talks are cheap, and they don't mean much ...

Benutzeravatar

Steamer01
InterRegio (IR)
Beiträge: 163
Registriert: Do 31. Dez 2009, 14:12
Nenngröße: H0
Stromart: AC
Steuerung: CS 3 (60216)
Gleise: K-Gleisen
Alter: 63
Kontaktdaten:

Re: Märklin 60883 - LinkS88; neu ab April 2015

#2

Beitrag von Steamer01 » Mi 8. Apr 2015, 12:48

Auch in den Niederlanden sind die Modulen jetzt zu bekommen. Ich habe vorige Woche 1 x Link S-88 (60883) und 6 x die S-Modulen 60881 gekauft und Alles angeschlossen. Man braucht noch als extra Stromversorgung 66361 und auch die habe ich angeschlossen.

Alles funktioniert und ich bekomme auch die farbigen Rückmeldungen in gelb und grün im Master CS2 (60214). Leider passiert das nicht im Slave-CS2 (60213) aber dort schalten die Fahrstrassen doch. Nur die farbigen Punkten (gelb / grün) fehlen und damit selbstverständlich auch die Gleisbesetztmeldungen. Ich habe Märklin schon Bescheid gesagt und warte auf Antwort. Ich denke es betrifft ein Bug.
Alles ist angeschlossen über Terminal: die 8 Booster die ich habe und die Slave CS2 und die Link-S-Module.

Wer möchte, kann jetzt 4 x 31 x 16 Kontakten benutzen und dabei noch die Bus 0 mit auch noch 16 Kontakten. Das sind zusammen 2000 Rückmeldkontakten !!!!!!

Steamer01
2x CS 60216 + Booster 60174 (8x) + Booster 60175 (1x) alles verbunden über Terminals.


X2000
ICE-Sprinter
Beiträge: 7227
Registriert: Do 28. Apr 2005, 13:38
Nenngröße: H0
Stromart: digital
Steuerung: Tams
Gleise: C

Re: Märklin 60883 - LinkS88; erster Testbericht

#3

Beitrag von X2000 » Mi 8. Apr 2015, 13:04

Was ist denn nun der Vorteil dieser Geräte gegenüber den alten S88 (6088)? Auch die konnte man an die CS2 anschliessen. Geht es nur um mehr als 31 Module?
Gruß

Martin

Benutzeravatar

Threadersteller
DiegoGarcia
InterCityExpress (ICE)
Beiträge: 2349
Registriert: So 15. Apr 2007, 12:13
Alter: 104

Re: Märklin 60883 - LinkS88; erster Testbericht

#4

Beitrag von DiegoGarcia » Mi 8. Apr 2015, 13:40

Hallo Martin,

Für Märklin hat es den Vorteil, dass man nun neben den alten S88-Modulen mit dem Spezialstecker auch die neuen Module 60881 und 60882 mit der CS2 über den LinkS88 anbinden kann, und dies mittels Netzwerkkabeln, die abgeschirmt sind und auch größere Distanzen überbrücken können. Die Tante zieht damit gegenüber den Mitbewerbern ein kleines Stück weit nach. Zusätzlich bietet sich die Möglichkeit, die Spannung auf 12V anzuheben, um die Störanfälligkeit zu beseitigen (laut Hersteller).

Für den Endverbraucher ergäbe sich hypothetisch eine andere interessante Möglichkeit: die Einbindung von alten, bestehenden bzw. preisgünstigen S88-Modulen via LinkS88 in den CAN-Bus z.B. einer CC-Schnitte-2 / MS-2, wenn es Adapterkabel gäbe 7-polig-weiblich auf 6-polig-männlich oder 9-polig-weiblich auf 6-polig-männlich.

Also für mich ein nettes neues Spielzeug. Wer schon seine Anlage fertig verkabelt hat, und auf die CS2 wechseln will, erhält mit dem LinkS88 die Möglichkeit, zusätzlich S88-Ketten anzuschließen, u.U. dann mit mehreren LinkS88.

Ciao
Diego
talks are cheap, and they don't mean much ...


kukuk
CityNightLine (CNL)
Beiträge: 1951
Registriert: Mi 17. Jan 2007, 21:13
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: K-Gleis
Alter: 47
Kontaktdaten:

Re: Märklin 60883 - LinkS88; neu ab April 2015

#5

Beitrag von kukuk » Mi 8. Apr 2015, 16:45

Hallo,
Steamer01 hat geschrieben:Alles funktioniert und ich bekomme auch die farbigen Rückmeldungen in gelb und grün im Master CS2 (60214). Leider passiert das nicht im Slave-CS2 (60213) aber dort schalten die Fahrstrassen doch. Nur die farbigen Punkten (gelb / grün) fehlen und damit selbstverständlich auch die Gleisbesetztmeldungen.
Versuch mal auf Deiner Slave-CS2 das Layout zu schließen und dann wieder zu öffnen. Hilft das eventuell? Bei der Slave-PC Version habe ich beim ersten öffnen auch keine farbigen Punkte, nachdem ich das Fenster einmal geschlossen und wieder geöffnet habe, funktioniert es.

Grüße,
Thorsten
Epoche VI (3L K-Gleis) mit Märklin CS2, MS2 und MS1
Rollmaterial von Brawa, Fleischmann, Märklin, Roco, Trix und vielen mehr


X2000
ICE-Sprinter
Beiträge: 7227
Registriert: Do 28. Apr 2005, 13:38
Nenngröße: H0
Stromart: digital
Steuerung: Tams
Gleise: C

Re: Märklin 60883 - LinkS88; erster Testbericht

#6

Beitrag von X2000 » Mi 8. Apr 2015, 17:53

Danke Diego.
Gruß

Martin


kukuk
CityNightLine (CNL)
Beiträge: 1951
Registriert: Mi 17. Jan 2007, 21:13
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: K-Gleis
Alter: 47
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#7

Beitrag von kukuk » Mi 8. Apr 2015, 22:17

Hallo,

das Link S88 bietet ja die Wahl zwischen 5V und 12V Versorgungsspannung für die S88 Module. Laut http://www.s88-n.eu/ muß bei Verwendung der Norm klar angegeben werden, ob die Geräte 5V oder 12V unterstützen. Märklin sagt 12V sind unterstützt, aber bei TAMS z.B. konnte ich leider nichts dazu finden.
Weiß jemand wie das bei den verschiedenen Herstellern aussieht?

Ansonsten funktioniert hier ein Mix aus 60883/60881 sowie TAMS S88-3 bisher einwandfrei. Mein 60883 hört übrigens auf die Adresse 72.
Das einzige, was mir auffiehl: Wenn ich die Rückmelder, die am Link S88 hängen, im Layout eintrage, und die Kontakte sind schon ausgelöst, funktionieren diese erst nach einem Neustart der CS2. Bei denen, die direkt an der CS2 hängen, funktionieren sie sofort. Deswegen hatte ich erst meinen L88 schon für defekt gehalten.

Grüße,
Thorsten
Epoche VI (3L K-Gleis) mit Märklin CS2, MS2 und MS1
Rollmaterial von Brawa, Fleischmann, Märklin, Roco, Trix und vielen mehr

Benutzeravatar

Steamer01
InterRegio (IR)
Beiträge: 163
Registriert: Do 31. Dez 2009, 14:12
Nenngröße: H0
Stromart: AC
Steuerung: CS 3 (60216)
Gleise: K-Gleisen
Alter: 63
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#8

Beitrag von Steamer01 » Fr 10. Apr 2015, 15:13

Noch immer funktioniert es nicht mit dem Lay-out-Fahrstrassensymbol-Farben gelb und grün.

Auch ein Neustart macht nichts. Bei den alten S-Decodern war Alles in Ordnung. Ich bekam die Rückmeldungen auch in der Slave CS2. Bei dem neuen System nur Rückmeldungen in der Master CS2, aber die Fahrstrassen schalten doch, auch im Display der Slave CS2. Auch habe ich dort die farbigen Punkten gelb und grün in soferne dass ich dann schalten muss durch drücken vom Fahrstrassensymbol im Lay-out wobei die Lampen direkt über die Schaltdecoder geschaltet wird und nicht über die neue S-Link-Decoder. Also mit Handbedienung.
Der Fehler hat also zu tun mit dem Märklin Bus. Ich denke es ist ein Bug.
Nochmals: Im Layout von der Master CS2 gelingt Alles. Es betrift nur die Slave 60213.

Steamer01
2x CS 60216 + Booster 60174 (8x) + Booster 60175 (1x) alles verbunden über Terminals.

Benutzeravatar

Threadersteller
DiegoGarcia
InterCityExpress (ICE)
Beiträge: 2349
Registriert: So 15. Apr 2007, 12:13
Alter: 104

Re: Märklin 60883 - LinkS88; erster Testbericht

#9

Beitrag von DiegoGarcia » Sa 11. Apr 2015, 21:37

Hallo Steamer01,

wie sieht es denn aus mit den Rückmelder-Symbolen an der Slave-CS2? Selber habe ich keine zweite CS2. Aber mit einer PC-CS2 lies sich für mich das Problem nicht nachstellen. Ich bin mir aber nicht sicher, ob ich nicht insgesamt einen Fehler gemacht habe beim Einrichten der Rückmelder im Layout. Muss man da den blauen Pfeil nach unten auch drücken?

Viele Grüße
Diego
talks are cheap, and they don't mean much ...


kukuk
CityNightLine (CNL)
Beiträge: 1951
Registriert: Mi 17. Jan 2007, 21:13
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: K-Gleis
Alter: 47
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#10

Beitrag von kukuk » Sa 11. Apr 2015, 22:35

Hallo,

das mit den LinkS88 und dem Layout der CS2 sind wohl noch zwei Dinge, die noch nicht wirklich zusammen funktionieren. Ich habe das Gefühl, das Layout der CS2 "vergisst" das ein Kontakt ausgelöst ist, und zwar in sehr vielen Fällen. Ich habe da gestern schon eine längere detailierte E-Mail an Märklin geschickt.

Grüße,
Thorsten
Epoche VI (3L K-Gleis) mit Märklin CS2, MS2 und MS1
Rollmaterial von Brawa, Fleischmann, Märklin, Roco, Trix und vielen mehr

Benutzeravatar

nakott
ICE-Sprinter
Beiträge: 5396
Registriert: Mi 4. Jul 2007, 12:37
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#11

Beitrag von nakott » So 12. Apr 2015, 15:07

kukuk hat geschrieben:Märklin sagt 12V sind unterstützt, aber bei TAMS z.B. konnte ich leider nichts dazu finden. Weiß jemand wie das bei den verschiedenen Herstellern aussieht?
Hallo Thorsten,

Tams selber bietet den s88-Booster an, der ebenfalls 12 V an den s88-Bus anlegt. Bei der Beschreibung zu diesem Produkt ist folgendes zu lesen.

Quelle: http://tams-online.de/htmls/produkte/S8 ... s88-2.html

Zitat:

"....Die meisten handelsüblichen s88-Rückmeldemodule (z.B. von Littfinsky, Märklin, Viessmann, Tams) sind auch für die erhöhte Versorgungsspannung geeignet......
....Module mit ICs, deren Typenbezeichnung mit der Nummer „74“ beginnt: Diese Module sind für den Betrieb mit dem s88-Booster nicht geeignet. Bei einer Erhöhung der Versorgungsspannung auf 12 V durch den s88-Booster werden diese Module zerstört!.....
....Module mit ICs, die in der Typenbezeichnung die Nummern „4014“ und „4044“ haben: Diese Module sind für den Betrieb mit dem s88-Booster geeignet....
"

Ich würde aber nicht unbedingt gleich auf 12V stellen. Solange es mit 5V funktioniert, würde ich bei 5V bleiben!

Grüße Dirk
Tams MC 2.1.0 ~ µCon-s88-Master ~ Qdecoder ~TC 8.0 Gold
Anlage URI ~ H0 Regelspur und H0m Furka–Oberalp


kukuk
CityNightLine (CNL)
Beiträge: 1951
Registriert: Mi 17. Jan 2007, 21:13
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: K-Gleis
Alter: 47
Kontaktdaten:

#12

Beitrag von kukuk » So 12. Apr 2015, 20:03

Hallo Dirk,

Ich habe inzwischen Antwort von TAMS erhalten, die S88-3 sind 12V tauglich.

Grüße,
Thorsten


TT800
Metropolitan (MET)
Beiträge: 2905
Registriert: Fr 31. Jul 2009, 22:12
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: M, C
Wohnort: Weinviertel, Niederösterreich

Re: Märklin 60883 - LinkS88; erster Testbericht

#13

Beitrag von TT800 » So 12. Apr 2015, 22:57

Steamer01 hat geschrieben:Noch immer funktioniert es nicht mit dem Lay-out-Fahrstrassensymbol-Farben gelb und grün.

Auch ein Neustart macht nichts. Bei den alten S-Decodern war Alles in Ordnung. Ich bekam die Rückmeldungen auch in der Slave CS2. Bei dem neuen System nur Rückmeldungen in der Master CS2, aber die Fahrstrassen schalten doch, auch im Display der Slave CS2. Auch habe ich dort die farbigen Punkten gelb und grün in soferne dass ich dann schalten muss durch drücken vom Fahrstrassensymbol im Lay-out wobei die Lampen direkt über die Schaltdecoder geschaltet wird und nicht über die neue S-Link-Decoder. Also mit Handbedienung.
Der Fehler hat also zu tun mit dem Märklin Bus. Ich denke es ist ein Bug.
Nochmals: Im Layout von der Master CS2 gelingt Alles. Es betrift nur die Slave 60213.

Steamer01
Ich habe keine Slave CS2, daher kann ich nichts testen. Aber ich frage mich, wie soll der Slave mitbekommen, dass sich die S88 Konfiguration geändert hat. Wurde das synchronisiert?

Der Master schickt doch die S88-Info von einem Kontakt mit einer neuen Adresse (Gerätekennung+Kontakt). Bisher war doch die Gerätekennung 0. Also muss das ganze Layout so synchronisiert werden, dass ein allfällig vorhandener Cache gelöscht wird.
Viele Grüße,
Stephan
____________________________________________________________
[60211 {60128connected} + 60215 {4.2.1(0) mit GFP 3.27} + PC-CS]
Insider seit 1993 - HeimatBf: MIST Wien - http://www.insider-stammtisch.net/

Benutzeravatar

Threadersteller
DiegoGarcia
InterCityExpress (ICE)
Beiträge: 2349
Registriert: So 15. Apr 2007, 12:13
Alter: 104

Re: Märklin 60883 - LinkS88; erster Testbericht

#14

Beitrag von DiegoGarcia » Mo 13. Apr 2015, 05:36

TT800 hat geschrieben:... wie soll der Slave mitbekommen, dass sich die S88 Konfiguration geändert hat. Wurde das synchronisiert?
Hallo zusammen,

die Daten zur Konfiguration eines LinkS88 werden in der Backup-Datei "geraete.cs2" hinterlegt. Erst wenn diese Datei durch Sichern des Backups intern in der CS2 hinterlegt ist, kann eine Slave-CS2 diesbezüglich synchronisiert werden. Evtl. ist das die Lösung des obigen Problems?

Ciao
Diego
talks are cheap, and they don't mean much ...

Benutzeravatar

Steamer01
InterRegio (IR)
Beiträge: 163
Registriert: Do 31. Dez 2009, 14:12
Nenngröße: H0
Stromart: AC
Steuerung: CS 3 (60216)
Gleise: K-Gleisen
Alter: 63
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#15

Beitrag von Steamer01 » Sa 18. Apr 2015, 11:28

Leider hat eine neue Back Up nichts gemacht. Das war also auch nicht die Lösung. Ich habe aber was anderes gefunden. Ich mache eine Fahrstrasse die getrickert wird von der Link S-88. Diese Fahrstrasse löst nur eine andere Fahrstrasse aus die getrickert wird von der CS2. Dan hat man die Rückmeldung mit grünen Punkten in der Slave CS2. Ich habe das gemeldet an Märklin und habe eine Antwort bekommen dass man sich kümmert um dieses Problem.

Steamer01
2x CS 60216 + Booster 60174 (8x) + Booster 60175 (1x) alles verbunden über Terminals.

Benutzeravatar

graafjp
Regionalbahn (RB)
Beiträge: 38
Registriert: Fr 6. Mai 2005, 08:21
Nenngröße: H0
Stromart: digital
Steuerung: CS2-6021-loconet
Gleise: K
Wohnort: Oss
Alter: 59

Re: Märklin 60883 - LinkS88; erster Testbericht

#16

Beitrag von graafjp » Di 28. Apr 2015, 07:37

Hallo,

Seit einige Tagen habe ich jetzt auch ein Schattenbahnhof automatisiert mit der 60883.

Mir ist aufgefallen das die Rückmelding im Layout nicht immer korrekt ist. (Master CS2 3.8.1).
Nach ein Neustart von der CS2 kamm die Rückmelding im Layout nicht überein mit mein Schattenbahnhof.
Aber alles funktionierte glücklich ohne Probleme. Weichenstrassen schalten korrekt.

Weiter wenn mann eine Memory Seite aufruft und beendet mit cancel (rotes Kreuz) herstarted die CS2 app meistens.
Mit freundlichen Grüsse
Jos


TT800
Metropolitan (MET)
Beiträge: 2905
Registriert: Fr 31. Jul 2009, 22:12
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: M, C
Wohnort: Weinviertel, Niederösterreich

Re: Märklin 60883 - LinkS88; erster Testbericht

#17

Beitrag von TT800 » Di 28. Apr 2015, 09:56

X2000 hat geschrieben:Was ist denn nun der Vorteil dieser Geräte gegenüber den alten S88 (6088)? Auch die konnte man an die CS2 anschliessen. Geht es nur um mehr als 31 Module?
Hallo Martin,

Nachdem ich jetzt auch mein "Link S88" - kurz L88 genannt - erhalten und getestet habe, versuche ich Deine Frage, die ja jedem auf den Lippen brennt, zu beantworten.

Der Link S88 "verbindet" (im Sinn von "leitet weiter") die Rückmeldungen aller Generationen von Märklin Rückmeldern, also 6088, 60880, 60881 und 60882, sowie vermutlich auch der Fremdprodukte auf den System-Datenbus (CAN-Bus oder auch Märklin-Bus genannt) der Anlage. Jedes über diesen Bus wirkende Steuergerät, bzw. PC-Steuerprogramm kann nun diese Informationen lesen und für sich verarbeiten.

Bisher gab es für diese Funktion nur die CS2 - deklarierter Weise zur kompatiblen Weiterverwendung der aus der 6050/6051 Interface-Zeit stammenden S88. Natürlich nutzten auch bisher über den System-Datenbus wirkende Steuergeräte und PC-Steuerprogramme diese Informationen. Aber die Rechnerleistung dafür belastete immer mehr und mehr die CS2. Die PC-Steuerprogramme nutzten zwar auch direkte Rückmelderanschlüsse unter Umgehung der CS2, doch gaben sie die Informationen nicht an den System-Datenbus des CS2-Masters weiter.

Ein weiterer Vorteil des L88 liegt darin, dass der Datenverkehr über den System-Datenbus durch Verwendung der S88-Event Befehle statt der aus der Interface-Zeit stammenden S88-Polling Befehle extrem entlastet wird. Einfach erklärt, warum: Bisher mussten "dauernd" ALLE Rückmelder zyklisch nach ihrer Information abgefragt werden - egal ob sich etwas geändert hat oder nicht; der L88 sendet aber von sich aus nur die einzelnen Rückmelde-Informationen, wenn sie sich ereignet haben. Man kann sich unschwer vorstellen, wie alle Teilnehmer am System-Datenbus aufatmen - soferne sie "Events" verstehen.

Sofern keine "alten" S88 Module direkt an der CS2 mehr hängen - man sollte sie alle stattdessen an den L88 hängen - atmet auch die CS2 auf, weil sie sich dann selber Rechnerleistung erspart und alle Rückmelde-Informationen aus dem System-Datenbus bezieht.

Also ist die Verwendung vom L88 eine gute Ergänzung und kein Ersatz zu den bisherigen S88.
Viele Grüße,
Stephan
____________________________________________________________
[60211 {60128connected} + 60215 {4.2.1(0) mit GFP 3.27} + PC-CS]
Insider seit 1993 - HeimatBf: MIST Wien - http://www.insider-stammtisch.net/


kukuk
CityNightLine (CNL)
Beiträge: 1951
Registriert: Mi 17. Jan 2007, 21:13
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: K-Gleis
Alter: 47
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#18

Beitrag von kukuk » Di 28. Apr 2015, 21:13

TT800 hat geschrieben:Ein weiterer Vorteil des L88 liegt darin, dass der Datenverkehr über den System-Datenbus durch Verwendung der S88-Event Befehle statt der aus der Interface-Zeit stammenden S88-Polling Befehle extrem entlastet wird. Einfach erklärt, warum: Bisher mussten "dauernd" ALLE Rückmelder zyklisch nach ihrer Information abgefragt werden - egal ob sich etwas geändert hat oder nicht; der L88 sendet aber von sich aus nur die einzelnen Rückmelde-Informationen, wenn sie sich ereignet haben.
Und genau da scheint Märklin ein Problem zu haben: die CS2 scheint den Status einiger Rückmelder in bestimmten Situationen zu vergessen, und da nur geänderte Events gesendet werden, ist die Anzeige im Layout häufig schlichtweg falsch und damit für mich völlig unbrauchbar.
Ich habe da schon eine lange Liste mit den Fehlern, die mir in dem Zusammenhang aufgefallen sind, an Märklin geschickt. Aber ausser, das sie an die Entwickler weitergeben wurde, habe ich nichts mehr davon gehört.

Grüße,
Thorsten
Epoche VI (3L K-Gleis) mit Märklin CS2, MS2 und MS1
Rollmaterial von Brawa, Fleischmann, Märklin, Roco, Trix und vielen mehr

Benutzeravatar

moppe
Metropolitan (MET)
Beiträge: 3329
Registriert: So 7. Aug 2011, 08:16
Nenngröße: H0
Stromart: DC
Steuerung: Gahler&Ringstmeier analog+digi
Gleise: 2L
Wohnort: Norddeutsche Halbinsel.
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#19

Beitrag von moppe » Mi 29. Apr 2015, 11:03

Der ganze Wochenende hab wir einer kleiner Ausstellungsanlage mit CS2, S88 LINK und S88 DC betrieben. Hier gibt es keiner falsche meldungen.
Edit: hier einer Bild von unsere Anlage: http://baneforum.dk/download/file.php?id=6361&mode=view

Unsere größte Problem war wenn wir "STOP" drücken (und der Fahrspannung schließt ab), fallt alle Rückmeldungen weg.


Klaus
"Meine" Modellbahn: http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk


kukuk
CityNightLine (CNL)
Beiträge: 1951
Registriert: Mi 17. Jan 2007, 21:13
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: K-Gleis
Alter: 47
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#20

Beitrag von kukuk » Mi 29. Apr 2015, 17:02

Hallo Klaus,
moppe hat geschrieben:Der ganze Wochenende hab wir einer kleiner Ausstellungsanlage mit CS2, S88 LINK und S88 DC betrieben. Hier gibt es keiner falsche meldungen.
Edit: hier einer Bild von unsere Anlage: http://baneforum.dk/download/file.php?id=6361&mode=view

Unsere größte Problem war wenn wir "STOP" drücken (und der Fahrspannung schließt ab), fallt alle Rückmeldungen weg.
Irgendwie widersprichst Du Dich. Das die Rückmeldungen wegfallen oder in bestimmten Situationen erst gar nicht im Layout angezeigt werden ist doch genau das Problem.

Grüße,
Thorsten
Epoche VI (3L K-Gleis) mit Märklin CS2, MS2 und MS1
Rollmaterial von Brawa, Fleischmann, Märklin, Roco, Trix und vielen mehr

Benutzeravatar

moppe
Metropolitan (MET)
Beiträge: 3329
Registriert: So 7. Aug 2011, 08:16
Nenngröße: H0
Stromart: DC
Steuerung: Gahler&Ringstmeier analog+digi
Gleise: 2L
Wohnort: Norddeutsche Halbinsel.
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#21

Beitrag von moppe » Mi 29. Apr 2015, 18:13

Wir fahren 2L (und nutzen S88 DC mit stromfühlern), dafür hab wir kein Rückmeldung wenn wir kein gleisspannung haben.

Klaus
"Meine" Modellbahn: http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk

Benutzeravatar

rmayergfx
Metropolitan (MET)
Beiträge: 4225
Registriert: Mo 7. Jul 2008, 13:42
Nenngröße: H0
Stromart: AC
Steuerung: MS2, 6021, 60213
Gleise: C-K-Flex-M-Gleis
Wohnort: Ufr.

Re: Märklin 60883 - LinkS88; erster Testbericht

#22

Beitrag von rmayergfx » Mi 29. Apr 2015, 19:10

Hallo Diego,

ganz wichtige Frage, ist die Belegung der Ethernet Buchsen s88-N konform, d.h. kann man die oben erwähnten TAMS S88-3 per Patchkabel verbinden, oder wird das ganze System dann unbrauchbar ?
Denn laut Handbuch und der Homepage von s88-N ist die Belegung identisch.
http://www.s88-n.eu/
http://medienpdb.maerklin.de/product_fi ... etrieb.pdf (Seite 7)

mfg

Ralf
Der Computer soll die Arbeit des Menschen erleichtern und nicht umgekehrt!
Neue Kupplungen für Faller OHU Selbstentladewagen: http://www.stummiforum.de/viewtopic.php?f=27&t=82863
Kein Support per PN !

Benutzeravatar

Threadersteller
DiegoGarcia
InterCityExpress (ICE)
Beiträge: 2349
Registriert: So 15. Apr 2007, 12:13
Alter: 104

Re: Märklin 60883 - LinkS88; erster Testbericht

#23

Beitrag von DiegoGarcia » Mi 29. Apr 2015, 19:33

Hallo Ralf,

Da ich keine S88-N Komponenten habe, kann ich es nicht testen. Da muss jemand anders ins kalte Wasser springen.

Viele Grüße
Diego
talks are cheap, and they don't mean much ...


kukuk
CityNightLine (CNL)
Beiträge: 1951
Registriert: Mi 17. Jan 2007, 21:13
Nenngröße: H0
Stromart: digital
Steuerung: CS2
Gleise: K-Gleis
Alter: 47
Kontaktdaten:

Re: Märklin 60883 - LinkS88; erster Testbericht

#24

Beitrag von kukuk » Mi 29. Apr 2015, 21:23

Hallo Ralf,
rmayergfx hat geschrieben:ganz wichtige Frage, ist die Belegung der Ethernet Buchsen s88-N konform, d.h. kann man die oben erwähnten TAMS S88-3 per Patchkabel verbinden, oder wird das ganze System dann unbrauchbar ?
Lies Dir einfach mal diesen Thread durch, da habe ich es schon beantwortet :(

Die TAMS S88-3 funktionieren mit 12V am L88 per Patchkabel einwandfrei.

Grüße,
Thorsten
Epoche VI (3L K-Gleis) mit Märklin CS2, MS2 und MS1
Rollmaterial von Brawa, Fleischmann, Märklin, Roco, Trix und vielen mehr

Benutzeravatar

rmayergfx
Metropolitan (MET)
Beiträge: 4225
Registriert: Mo 7. Jul 2008, 13:42
Nenngröße: H0
Stromart: AC
Steuerung: MS2, 6021, 60213
Gleise: C-K-Flex-M-Gleis
Wohnort: Ufr.

Re: Märklin 60883 - LinkS88; erster Testbericht

#25

Beitrag von rmayergfx » Do 30. Apr 2015, 08:20

Hallo Thorsten,

ich kann lesen, leider hast du oben nicht geschrieben wie Du die TAMS S88-3 mit dem LinkS88 verbunden hast.
Da auf dem S88-3 sowohl die alten Pfostenstecker als auch RJ-45 vorhanden sind :D
Du hast sie getestet und sie haben funktionert, aber nichts zur Verkabelung, sonst hätte ich grantiert nicht nachgefragt :D

Danke

Ralf
Der Computer soll die Arbeit des Menschen erleichtern und nicht umgekehrt!
Neue Kupplungen für Faller OHU Selbstentladewagen: http://www.stummiforum.de/viewtopic.php?f=27&t=82863
Kein Support per PN !

Antworten

Zurück zu „Digital“