Willkommen 

An Aus


RailCom Sender funktioniert nicht richtig.

#1 von SCD , 17.12.2019 18:50

Hallo,

ich habe den RailCom transmitter von http://usuaris.tinet.cat/fmco/railcom_en.html#dccrail leicht abgewandelt (Brückengleichrichter)
und auf SMD Basis nachgebaut.

Bild entfernt (keine Rechte)

Leider funktioniert er nicht richtig:

Schalte ich die RailCom Lücke in der Zentrale aus funktioniert der Funktionsdekoder-Teil einwandfrei.

Mit RailCom Lücke blinken die Funktionsausgänge unregelmäßig (als wenn der Decoder sich ständig neustartet).
Eine RailCom Übertragung der Nummer findet nur ganz selten statt.

Wenn ich mit einen Meßgerät die Spannung am Ausgang messe, wird er jedoch oft stabil und funktioniert.
Die RailCom Übertragung funktioniert dann ebenfalls.

Den Schaltplan mit Eagle automatisch geroutet und die Platine durch OshPark fertigen lassen.
Ich gehe davon aus, das diese richtig ist. Ein Lötfehler kann ich auch ausschließen, da alle drei Prototypen das gleiche Problem zeigen.

Den Elko in der Stromversorgung habe ich auch eingebaut (ohne Verbesserung).

Wo könnte der Fehler sein ?

System: Intellibox 2, digikeijs DR5088RC, LDT-DB4


SCD  
SCD
Beiträge: 8
Registriert am: 11.02.2011
Spurweite H0
Stromart Digital

zuletzt bearbeitet 17.07.2021 | Top

RE: RailCom Sender funktioniert nicht richtig.

#2 von volkerS , 23.12.2019 09:47

Hallo,
Wert C2 ist viel zu klein, mindestens Elko 100uF, ist ja als optionaler Elko in den Plänen eingezeichnet. C1 100nF. Tr3 schaltet den negativen Zweig des Gleichrichters kurz, TRKB und GND. Dann bricht die Spannung ein und Brownout des uC resetet.
Volker


volkerS  
volkerS
Metropolitan (MET)
Beiträge: 3.785
Registriert am: 14.10.2014


RE: RailCom Sender funktioniert nicht richtig.

#3 von SCD , 23.12.2019 09:59

Hallo Volker,

danke für die Antwort. Leider habe ich den Elko schon ohne Erfolg versucht:

Zitat

Den Elko in der Stromversorgung habe ich auch eingebaut (ohne Verbesserung).



Was meinst Du mit dem Rest, ist da ein Fehler?
Im Original-Schaltplan sieht es doch auch so aus ?


SCD  
SCD
Beiträge: 8
Registriert am: 11.02.2011
Spurweite H0
Stromart Digital


RE: RailCom Sender funktioniert nicht richtig.

#4 von Domapi , 27.02.2020 18:02

Bist du mit deiner Hardware zum Erzeugen der RailCom-Impulse weitergekommen?

Ich versuche aktuell einem selbstentwickelten Servodekoder auf Arduinobasis das POM-Lesen beizubringen und suche entsprechende Code-Schnipsel, die das Detektieren der RailCom-Lücke und Senden der RC-Befehle ermöglichen.

Mit welcher Software im PIC arbeitest Du?


Viele Grüße
Martin

Mein noch namenloser Trennungsbahnhof: viewtopic.php?f=64&t=152275


 
Domapi
EuroCity (EC)
Beiträge: 1.193
Registriert am: 22.09.2015
Ort: Nämberch
Gleise Ohne Pickel
Spurweite H0
Steuerung Mit Hirn und Verstand
Stromart DC, Digital


RE: RailCom Sender funktioniert nicht richtig.

#5 von SCD , 28.02.2020 07:11

Leider nicht.

Ich nutze die Hex-Datei von der angegeben Homepage. Was genau dahinter steckt kann ich nicht sagen ....

Den Urheber von der Schaltung habe ich vor längerer Zeit auch angeschrieben. Leider habe ich keine Antwort bekommen


SCD  
SCD
Beiträge: 8
Registriert am: 11.02.2011
Spurweite H0
Stromart Digital


   


  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
disconnected Foren-Chat Mitglieder Online 239
Xobor Einfach ein eigenes Forum erstellen
Datenschutz