Willkommen 

An Aus


RE: Loksound 5 seltsames Verhalten?

#1 von Georg Tanzer , 27.11.2020 22:01

Hallo Zusammen,

ich habe die BR 232 von Piko (52775) mit einem Loksound 5 nachgerüstet.
Nachdem ich alles so konfiguriert hatte kam es auf der Anlage zu einem seltsamen verhalten. Jedesmal wenn die Lok vom CS2 Stromkreis in den Boosterkreis fuhr, hat die CS2 den Decoder ausgelesen, aber nicht auf die übliche Art, sondern es kam zu einer Fehlermeldung.
1. "Dieser Decoder hat eine inoffizelle mfx-Uid...." 2. "Mfx Lok Lok-1: Das Auslesen der Einstellungen war nicht möglich"
Bei jeder Runde wurde eine Lok in der Datenbank angelegt "Lok-1(2), Lok-1(3) usw. Irgendwann ist dann die CS2 abgestürzt.

Beim Original Projekt, trat diese Phänomen nicht auf.
Auf zur Fehlersuche:Mittels des ESU Lokprogrammers und ausgehend vom Original-Projekt, habe ich Schritt für Schritt die Parameter geändert.
Fündig wurde ich bei den Motoreinstellungen.
Eigenlich hatte ich bis auf die Kennlinie und Vmin bzw. Vmax nichts geändert.
Die Ursache lag bei der "Motor PWM Frequenz" die "Motor Pulsfrequenz" muß ich unabsichtlich von Default 40 auf 25 geändert haben.
Nachdem ich den Default Wert eingestellt habe, tritt der Fehler (bis jetzt) nicht mehr auf.

Interessant, oder?


Die besten Grüsse
Georg

Märklin C-Gleis / CS2 60215; HW=5.1; SW=4.2.9/LoDi S88 Com./ Märklin Booster/ TrainController 9 Gold / DCC, MM und mfx im Mischbetrieb


 
Georg Tanzer
InterRegio (IR)
Beiträge: 121
Registriert am: 06.02.2006
Ort: Freiburg
Gleise C-Gleis
Spurweite H0
Steuerung CS2 60215 Traincontroller 9G
Stromart AC


RE: Loksound 5 seltsames Verhalten?

#2 von moppe , 27.11.2020 22:32

Ich hab kein Zweifel..........du hab nicht der störkondensator entfernt.

http://moppe.dk/PIKOC4.html



Klaus


"Meine" Modellbahn:http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk
PIKO C4 "Horror Gallery": http://moppe.dk/PIKOC4.html


 
moppe
ICE-Sprinter
Beiträge: 6.207
Registriert am: 07.08.2011
Homepage: Link
Ort: Norddeusche halbinsel
Gleise Roco, PECO, Märklin/Trix, PIKO,
Spurweite H0, H0e, N, Z
Steuerung Z21, Lenz, MpC Gahler+Ringsmeier, Games on Track/Faller
Stromart AC, DC, Digital, Analog


RE: Loksound 5 seltsames Verhalten?

#3 von Georg Tanzer , 28.11.2020 10:20

Hallo Klaus,

vielen Dank für deine Information, auch für die detailierten Bilder.
Noch eine Frage: Kann der Kondensator ersatzlos aus gelötet werden, oder müssen die Pads gebrückt werden?


Die besten Grüsse
Georg

Märklin C-Gleis / CS2 60215; HW=5.1; SW=4.2.9/LoDi S88 Com./ Märklin Booster/ TrainController 9 Gold / DCC, MM und mfx im Mischbetrieb


 
Georg Tanzer
InterRegio (IR)
Beiträge: 121
Registriert am: 06.02.2006
Ort: Freiburg
Gleise C-Gleis
Spurweite H0
Steuerung CS2 60215 Traincontroller 9G
Stromart AC


RE: Loksound 5 seltsames Verhalten?

#4 von Stefan Krauss , 28.11.2020 10:49

Hallo, Georg,

das ist wirklich interessant, danke für den Bericht.

Die Ursache dürfte darin zu suchen sein, dass die 25 kHz PWM-Ansteuerung des Motors mit der mfx-Rückmeldung interferiert, die mit einem modulierten Stromsignal von rund 50 kHz arbeitet. Die Zentrale erkennt dann einen neuen mfx-Dekoder mit UID 0xFFFFFFFF (auf die Abfrage von jedem Bit der UID wird scheinbar mit "Ja" geantwortet). Diese UID ist eigentlich nicht zulässig (daher die Bemerkung "inoffizielle UID"). Danach versucht die Zentrale, den neu erkannten Dekoder auszulesen. Was natürlich nicht geht, weil es keinen Dekoder mit der UID 0xFFFFFFFF gibt. Das führt zur zweiten Meldung. Mit diesen halb erkannten Leichen kann die CS wohl nicht gut umgehen und läuft voll.

Da wird dir nur die Wahl einer anderen PWM-Frequenz helfen.

Grüße
Stefan


Stefan Krauss  
Stefan Krauss
InterCity (IC)
Beiträge: 535
Registriert am: 11.09.2012
Homepage: Link
Spurweite H0
Stromart AC, Digital


RE: Loksound 5 seltsames Verhalten?

#5 von moppe , 28.11.2020 12:20

[quote="Georg Tanzer" post_id=2197156 time=1606555218 user_id=1048]
Noch eine Frage: Kann der Kondensator ersatzlos aus gelötet werden, oder müssen die Pads gebrückt werden?
[/quote]

Nur der C4 auslöten. Nichts anderes.



Klaus


"Meine" Modellbahn:http://www.modelbaneeuropa.dk
Dänisches Bahnforum: http://www.baneforum.dk
PIKO C4 "Horror Gallery": http://moppe.dk/PIKOC4.html


 
moppe
ICE-Sprinter
Beiträge: 6.207
Registriert am: 07.08.2011
Homepage: Link
Ort: Norddeusche halbinsel
Gleise Roco, PECO, Märklin/Trix, PIKO,
Spurweite H0, H0e, N, Z
Steuerung Z21, Lenz, MpC Gahler+Ringsmeier, Games on Track/Faller
Stromart AC, DC, Digital, Analog


RE: Loksound 5 seltsames Verhalten?

#6 von Georg Tanzer , 28.11.2020 19:13

Hallo Klaus,

Danke für die Info


Die besten Grüsse
Georg

Märklin C-Gleis / CS2 60215; HW=5.1; SW=4.2.9/LoDi S88 Com./ Märklin Booster/ TrainController 9 Gold / DCC, MM und mfx im Mischbetrieb


 
Georg Tanzer
InterRegio (IR)
Beiträge: 121
Registriert am: 06.02.2006
Ort: Freiburg
Gleise C-Gleis
Spurweite H0
Steuerung CS2 60215 Traincontroller 9G
Stromart AC


RE: Loksound 5 seltsames Verhalten?

#7 von Beschwa , 28.11.2020 22:29

[quote="Stefan Krauss" post_id=2197167 time=1606556948 user_id=15567]
Hallo, Georg,
Die Ursache dürfte darin zu suchen sein, dass die 25 kHz PWM-Ansteuerung des Motors mit der mfx-Rückmeldung interferiert, die mit einem modulierten Stromsignal von rund 50 kHz arbeitet. Die Zentrale erkennt dann einen neuen mfx-Dekoder mit UID 0xFFFFFFFF (auf die Abfrage von jedem Bit der UID wird scheinbar mit "Ja" geantwortet). Diese UID ist eigentlich nicht zulässig (daher die Bemerkung "inoffizielle UID"). Danach versucht die Zentrale, den neu erkannten Dekoder auszulesen. Was natürlich nicht geht, weil es keinen Dekoder mit der UID 0xFFFFFFFF gibt. Das führt zur zweiten Meldung. Mit diesen halb erkannten Leichen kann die CS wohl nicht gut umgehen und läuft voll.

Da wird dir nur die Wahl einer anderen PWM-Frequenz helfen.

Grüße
Stefan
[/quote]

Hallo Stefan,
und sorry für off Topic
aber Loriot hätte daran seine Freude gehabt .


Grüßle
Bernd


 
Beschwa
EuroCity (EC)
Beiträge: 1.478
Registriert am: 06.01.2009
Ort: BW
Spurweite H0
Steuerung CS2 WinDigipet
Stromart AC, Digital


RE: Loksound 5 seltsames Verhalten?

#8 von Georg Tanzer , 29.11.2020 15:05

Hallo Stefan,

Ich habe deinen Post übersehen.
Deine Beschreibung trifft den Nagel voll auf den Kopf.

Dafür Danke.

Ohne Lokprogrammer hätte ich richtig alt ausgesehen, nur mit der CV Programmierung hätte ich die Ursache nicht gefunden.


Die besten Grüsse
Georg

Märklin C-Gleis / CS2 60215; HW=5.1; SW=4.2.9/LoDi S88 Com./ Märklin Booster/ TrainController 9 Gold / DCC, MM und mfx im Mischbetrieb


 
Georg Tanzer
InterRegio (IR)
Beiträge: 121
Registriert am: 06.02.2006
Ort: Freiburg
Gleise C-Gleis
Spurweite H0
Steuerung CS2 60215 Traincontroller 9G
Stromart AC


   


  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
disconnected Foren-Chat Mitglieder Online 208
Xobor Einfach ein eigenes Forum erstellen
Datenschutz