Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist --> GELÖST

#1 von HelbigR , 16.06.2023 15:28


Workarround siehe Beitrag #15


Lösung: Neue Firemware - Version: 3.3.0.5 (03. Juli 2023)

Bugfix: Fehler behoben, der dazu geführt hat, dass die Firmware für mLD3 mit Kabel (Art. Nr. 60982 und 60983) nicht funktioniert hat



Ich habe seit kurzem ein merkwürdiges Phänomen: Nach dem programmieren von mLD3 Nachrüstdecodern fahren die Loks nicht mehr. Wobei das nicht ganz korrekt ist...der Motor wird nur noch angesteuert, wenn AUX2 eingeschaltet ist. Aktuell habe ich die neueste Firmware im Verdacht (3.3.0.4), da hauptsächlich nach dem flashen dies aufgefallen ist. Die Frage beim Märklinsupport dazu ist noch offen - aber da ich bisher nur auf eine von sechs Supportanfragen binnen drei Jahren überhaupt eine Antwort bekommen habe fahre ich lieber zweigleisig.

Vorgeschichte:
Zwei mDL3 waren ganz regulär im Einsatz, überhaupt keine Auffälligkeiten. Dann habe ich diese für andere Modelle umprogrammiert wie ich es schon zig mal auf die selbe Weise tat. Nachdem der erste Decoder programmiert war und tadellos lief wollte ich den zweiten identsich programmieren. Hier fehlten aber die logischen Funtionen (UND). Ich spielte das Firmwareupate auf, die Funktionen waren nun da und ich stellte diese ein - jetzt fuhr die Lok nur noch vorwärts, dann gar nicht mehr. Den ersten Decoder zum Test umgesteckt - Lok funkioniert. Also von diesem Deocder die Daten gezogen, verglichen - alles gleich. Dennoch diese auf Decoder 2 aufgespielt - Fehler immer noch da (bis jetzt dachte ich, ich hätte den Motorausgang irgendwie zerschossen).
Dann um alles zu reproduzieren Decoder 1 auch nochmals zurückgesetzt und alles nochmals von Hand eingestellt - beim schreiben wies das mDecoderTool auf die neue Firmware hin - installiert - jetzt ging auch bei diesem Decoder der Motor nicht mehr ... ich mittlerweile völlig ratlos. Habe ich mit den logsichen Funktionen einen Feher gemacht - Selbstzweifel!!

Dritten Decoder nagelneu geöffent - Programmiert mit Firmwareupdate ...selber Fehler, kein Zucken am Motor. Beim parallelen Testen der Lichtfunktionen fing der Motor aber aufeinmal an sich zu drehen ?!?!? Nach ein paar Sekunden habe ich bemerkt, dass der Motor sich nur noch dreht (beide Richtungen), wenn AUX2 an ist. Dreht sich der Motor und man schaltet AUX2 aus bleibt auch der Motor stehen. Schaltet man AUX2 wieder an und ändert die Fahrstufe dreht sich der Motor wieder, als ob nichts wäre.

Programmierung (wie auch auf siebzehn anderen Decodern):
UND1 - Ausgang 1, positiver Pegel, beide, beide
UND2 - Ausgang 2, positiver Pegel, beide, beide

F0 - LV, vorwärts, LR, rückwärts, UND1 rückwärts, UND2 vorwärts
F1 - UND1 + UND2: negativer Pegel, beide, beide
F3 - Rangiergang, LV beide, LR beide, UND1 + UND 2 negativer Pegel, beide, beide
F4 - ABV

Mit dieser Einstellung habe ich auf F0 Weiß/Rot jeweils in Fahrtrichtung, kann Rot mit F1 abschalten und über F3 Doppel-A ein und Rot ausschalten - alles jeweils Richtungsabhängig.
Das hatt bisher noch nie Probleme bereitet - jetzt das o.b. Problem.

Entweder habe ich mit den logischen Funktionen etwas -warum auch immer auf einmal- zerschosse oder das Firmwareupdate ist schuld - soweit meine Vermutungen...
Ich bin gespannt auf eure Erfahrungen und Beiträge dazu, danke!!

Das Projekt hängt als ZIP an diesem Beitrag, falls da jemand einen Blick reinwerfen möchte - vielleicht sehe ich ja auch nur die Butter im Kühlschrank nicht...


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital

zuletzt bearbeitet 04.07.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#2 von Michael Knop , 16.06.2023 21:23

Hi,

Die Firmware ist es (höchstwahrscheinlich) nicht - ich und andere haben schon einige Loks damit upgedatet.


Schreib doch mal das werksprojekt vom 60972 in den Dekoder - und schau ob er wieder normal arbeitet - wenn ja, ist irgendwas an deinem Projekt nicht ok.


Viele Grüße, Michael


Andreas85 hat sich bedankt!
Michael Knop  
Michael Knop
ICE-Sprinter
Beiträge: 7.387
Registriert am: 28.04.2005
Ort: Ruhrpott
Gleise C-Gleis
Spurweite H0
Steuerung IB / IB2
Stromart AC, Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#3 von HelbigR , 16.06.2023 21:50

Das hatte ich auch schon versucht, aber es bleibt dabei: Motor wird nur angesteuert, wenn AUX2 eingeschaltet ist.

Ich hatte zuerst die Decoder zurückgesetzt - kein Erfolg
Dann neu mit meinem Projekt beschreiben - kein Erfolg
Nochmals zurückgesetzt und Märklinprojekte herungergeladen und drauf geschrieben - kein Erfolg.
Mein Projekt wieder drauf und die Parameter für AUX2, sowie die UNDs in zig Kombinationen geändert - kein Erfolg.


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#4 von Peterschaf , 16.06.2023 21:56

Moin,

wie alt war den die FW vor dem Update?

Ich habe selber 10 mld3 im Einsatz und alle arbeiten mit 3.3.0.4 normal.


Mfg Sebastian


Märklin H0 mit C-Gleis
Anlage auf 3 Ebenen ca. 3,5qm
6021 Zentrale mit 6035 Fahrregler


Andreas85 hat sich bedankt!
 
Peterschaf
InterRegio (IR)
Beiträge: 132
Registriert am: 22.01.2022
Ort: Unna
Gleise C-Gleis
Spurweite H0
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#5 von HelbigR , 16.06.2023 22:22

Die Decoder hatte ich 09/22 und 11/22 gekauft, der zuletzt verwendete ist von letzer Woche ... welche Firmware zuvor drauf war weiß ich nicht, sollte aber relativ frisch gewesen sein.

Habe gerade festgestellt, dass AUX3 udn AUX4 gar nicht mehr gehen.
Motor bekomme ich zum laufen, wenn ich AUX2 mit "Pegel Negativ" auf eine funktionslose F-Taste lege.
Wird immer absonderlicher...


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#6 von HelbigR , 16.06.2023 22:38

AUX3 und 4 gehen jetzt wieder und der Motor dreht sich wieder ohne das AUX2 eingeschaltet sein muss...dafür muss jetzt F0 eingeschaltet sein (LV,LR,UND3 mit AUX3, UND3 mit AUX4) damit sich der Motordreht, der Zusammenhang mit AUX2 hat sich dadurch aufgelöst. Dafür schaltet jetzt F2 "= AUX2 Positiver Pegel, beide, beide" AUX3 aus...

UND3 sowie UND4 wieder gelöscht...jetzt muss wieder AUX2 eingeschaltet sein, damit der Motor läuft...jetzt programmiere ich schon ein paar Jahre diese Decoder, aber soetwas habe ich noch nicht erlebt...


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#7 von HelbigR , 16.06.2023 22:53

Neuer Versuch: Völliger Verzicht auf UND-Funtionen

F0 - LV und LR
F1 - AUX1 und AUX3 positver Pegel, jeweils Richtungsabhängig
F2 - AUX2 negativer Pegel ohne Tastenbelegung
F3 - Rangiergang, AUX1 und AUX3 negativer Pegel
F4 - ABV

Jetzt geht AUX3 nicht mehr und mit F1 schaltet man jetz AUX2 aus (Standardmäßig jetzt an, obwohl Pegel Negativ) und der Motor läuft nur, wenn AUX2 an ist.


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#8 von WolfiR , 17.06.2023 00:29

Hallo,

ist jetzt zu spät, aber wenn ich noch einen werksneuen Decoder habe, dann probiere ich den zuallererst ohne irgendwas aus, dann lasse ich das Update drüber, teste ob sich was geändert hat und erst dann fange ich an, meine Spezialitäten aufzuspielen.

Gruß
Wolfgang


Andreas85 hat sich bedankt!
 
WolfiR
EuroCity (EC)
Beiträge: 1.422
Registriert am: 08.01.2009
Spurweite H0, H0m, 1, Z
Stromart AC, Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#9 von Peterschaf , 17.06.2023 01:29

Zitat von HelbigR im Beitrag #5
Die Decoder hatte ich 09/22 und 11/22 gekauft, der zuletzt verwendete ist von letzer Woche ... welche Firmware zuvor drauf war weiß ich nicht, sollte aber relativ frisch gewesen sein.

Habe gerade festgestellt, dass AUX3 udn AUX4 gar nicht mehr gehen.
Motor bekomme ich zum laufen, wenn ich AUX2 mit "Pegel Negativ" auf eine funktionslose F-Taste lege.
Wird immer absonderlicher...


Meine sind auch alle aus den letzten 12 Monaten, wenn ich mich recht entsinne war da werksseitig 3.2.2.2 drauf.
Nachdem dann das Update kam habe ich alle Decoder ausgebaut, das Update aufgespielt und wieder eingebaut. Alles lief wie vorher.
Ich programmiere immer mit dem Tool und dem 60971 Decoder-Programmer.

Tritt das Veerhalten denn nur bei einer Lok mit verschiedenen Decodern auf, oder bei mehreren Loks?


Mfg Sebastian


Märklin H0 mit C-Gleis
Anlage auf 3 Ebenen ca. 3,5qm
6021 Zentrale mit 6035 Fahrregler


Andreas85 hat sich bedankt!
 
Peterschaf
InterRegio (IR)
Beiträge: 132
Registriert am: 22.01.2022
Ort: Unna
Gleise C-Gleis
Spurweite H0
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#10 von HelbigR , 17.06.2023 17:20

Zitat von Peterschaf im Beitrag #9
Tritt das Veerhalten denn nur bei einer Lok mit verschiedenen Decodern auf, oder bei mehreren Loks?


Bei drei Decodern (zwei liefen bereits ein paar Monate, einer ist schachtelfrisch) unabhängig in was die eingebaut sind.
Aktuell arbeite ich nur noch mit dem MDT3 (3.6.0) über den USB-Decoderstick (60971) und dem Märklin Decodertester (60970).


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#11 von Thomas Götz , 17.06.2023 18:56

Hallo Zusammen

Was für ein Motor wird angesteuert? Eventuell einer aus der "Sinus" Gruppe?
Diese benötigen je nach Treiber spezielle Einstellungen.

Viel Glück beim Suchen...


Thomas Götz  
Thomas Götz
Beiträge: 7
Registriert am: 09.06.2018
Spurweite H0
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#12 von hu.ms , 18.06.2023 18:21

Zitat von HelbigR im Beitrag #10

Bei drei Decodern (zwei liefen bereits ein paar Monate, einer ist schachtelfrisch) unabhängig in was die eingebaut sind.


"Schachtelfrischer" mld3 ohne irgendeine veränderung mit dem programmer einfach in einer lok ohne sinus-motor eingesteckt und der motor läuft nur mit einem licht- oder aux-ausgang aktiv ?

Hubert


Mein anlagenneubau: https://stummiforum.de/viewtopic.php?f=15&t=140152
Meine fahrzeugverbesserungen: https://stummiforum.de/viewtopic.php?f=27&t=132888

Fahre moba und ID.3 mit selbst produzierten PV-strom.


Andreas85 hat sich bedankt!
 
hu.ms
Trans Europ Express (TEE)
Beiträge: 8.673
Registriert am: 22.09.2007
Ort: in den Alpen
Gleise K-Gleis
Spurweite H0
Steuerung CS3, CS2, LoDi-Con, DCC + mfx + MM
Stromart Digital

zuletzt bearbeitet 18.06.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#13 von jogi , 18.06.2023 19:14

hallo , jogi hier


welche Lok? Nr.? mit welchem Motor?

Ein Bild mit Motor wäre gut.


Bastelnde Grüße Jogi ;
Elektronische Bauteile kennen 3 Zustände:Ein-Aus-Kaputt".
K-Gleise,DCC mit IB .CS2 nur Test Mfx freie Zone.MoBa MÄ seit 1954.
Bilder jogis Bahn
Jogis Bahn
Betrieb auf jogis Bahn

mein letzter Umbau


jogi  
jogi
Metropolitan (MET)
Beiträge: 3.944
Registriert am: 13.06.2005
Ort: NRW
Gleise K - Gleise
Spurweite H0
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#14 von Ludwig47 , 18.06.2023 21:29

Zitat von jogi im Beitrag #13
welche Lok? Nr.? mit welchem Motor?

Hallo Jogi,

lt. seinem Projekt handelt es sich um dieses Modell: RE: Märklin 36604 185 666-5

Was er allerdings daran wie umbaute hat er uns leider noch nicht verraten; zumindest ist sein eingestelltes Projekt "ziemlich verbastelt"; z.B. ist es kein Wunder dass AUX3/4 nicht funktionier(t)en. Offenbar hat er sein Projekt inzwischen auch bereits wieder geändert.

Ich werde mich dazu (erst dann) weiter äußern wenn mehr Infos vorliegen.

Gruß,
Ludwig47


Andreas85 hat sich bedankt!
Ludwig47  
Ludwig47
CityNightLine (CNL)
Beiträge: 1.835
Registriert am: 29.05.2021


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#15 von HelbigR , 18.06.2023 22:56

Ich habe jetzt ein Firmwaredowngrade auf v3.2.2.0 durchgeführt:
- Basistest ohne Einstellungen zu ändern -> Es funktioniert wieder alles
- Meine Programmierung drauf gespielt -> Es geht immer noch alles bestens

--> Firmwareupgrade auf V3.3.0.4:
- Dasselbe Fehlerbild ist zu 100% reproduzierbar. Der Motor dreht sich nur, wenn AUX2 (bzw. 3 oder 4 aber nur einer davon) eingeschaltet sind. Egal was programmiert ist.

--> erneutes Downgrad nach v.3.2.2.0:
Keine Fehler, alles funktioniert hervorragend. Alle UND-Funktionen, alle Abhängigkeiten - tadellos!!

Die -so lese ich die Subtexte- individuellen Spekulationen, ob es an der Firmware oder meiner "vermurksten" Programmiererei liegt (ich bin erst seit etwas über 20 Jahre ITler und Techniker - da weiß ich, das ich nicht alles weiß und jeder macht mal Fehler) überlasse ich jedem selbst.

Für mich hat sich das Thema durch Lösung "Firmwaredowngrade" erledigt, danke für eure Bemühungen!


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


hu.ms und vikr haben sich bedankt!
HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital

zuletzt bearbeitet 18.06.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#16 von Frank_E. , 18.06.2023 23:48

Hallo,

ich habe den Verdacht, dass mit den Templates in deinem mDT3 (Version 3.60) etwas nicht stimmt. Alle fünf Dateien im Programmordner mDecoderTool3\Templates\fds haben sich geändert von Version 3.50 auf 3.60 und sollten jetzt ein Datum vom 14.12.2022 haben!

Gruß
Frank


Volldampf und Andreas85 haben sich bedankt!
 
Frank_E.
InterCity (IC)
Beiträge: 525
Registriert am: 22.11.2009
Spurweite H0
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#17 von HelbigR , 19.06.2023 10:02

Hallo Frank,

die Templates sind auf allen PCs vom 14.12.2022. Ich habe nicht nur mit einem PC getestet und auch die Software reinstalliert und auch eine ältere Version des MDT installiert, aber die ist zu alt (3.4.2), um überhaupt den Decoder mit Firmware 3.2.2.0 auslesen zu können.

Aktuell bleibt es reprodzuierbar, dass mit v3.2.2.0 alles funktioniert und mit v.3.3.0.4 der bemängelte Fehler auftritt, unabhängig von einer Standardprogrammierung oder der Nutzung von logischen Funktionen.
Ich bin gespannt, ob und wenn, was Märklin dazu sagen kann.

VG
René


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#18 von khpmueller , 19.06.2023 17:11

Hallihallo,

ich habe es gerade probiert, meine CS3 bietet nur die Firmware 3.2.2.1 an ... und die funktioniert problemlos!

Wie bist du den an die Firmware 3.3.0.4 gekommen, wo gibt es die

Nette Grüße
KHPM

PS: Auch nach erzwungenem Heimtelefonieren (Systemcheck ob alles aktuell) bietet die CS3 nur Firmware 3.2.2.1 an


Der Motor ist das Herz einer Lokomotive (Märklin Zitat) - Leider sind die meisten "neuen" Märklin Loks ab Werk herzkrank
Der Sound ist Seele einer Lokomotive (Eigene Meinung) - Leider müssen die meisten Märtrix Lokomotiven zum Therapeuten


khpmueller  
khpmueller
InterCity (IC)
Beiträge: 870
Registriert am: 19.05.2005
Spurweite H0
Stromart Digital

zuletzt bearbeitet 19.06.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#19 von HelbigR , 19.06.2023 18:55

Zitat von khpmueller im Beitrag #18
Wie bist du den an die Firmware 3.3.0.4 gekommen, wo gibt es die

Ich gebe mal Hinweise mit Bezug auf die Beiträge zuvor: da findet sich 3x mDT und 2x mDecoderTool.

Zum Glück bietet die CS3 nur die alte Version an, denn damit gelingt das Downgrade auf die (bei mir) funktionierende Version.


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


Michael Knop und vikr haben sich bedankt!
HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital

zuletzt bearbeitet 19.06.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#20 von H0lok , 26.06.2023 09:27

Hallo zusammen,
ich habe es mal mit zwei meiner mLD3 probiert und kann das Problem nicht nachvollziehen. Ich habe die Decoder mit dem Tool aktualisiert, das Mapping eingestellt und dann aufgespielt. Der Motor dreht immer, egal wie die Ausgänge stehen. Zur Reproduktion des Problems fehlt in der Beschreibung also mindestens ein Schritt.
Viele Grüße,
Moritz


Michael Knop und Andreas85 haben sich bedankt!
H0lok  
H0lok
InterRegioExpress (IRE)
Beiträge: 453
Registriert am: 11.07.2014


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#21 von HelbigR , 29.06.2023 16:17

So, da heute ein nagelneuer Austauschdecoder kam wie folgt getestet:

mld3 60983, Firmware 3.2.1.0

- angeschlossen an Märklin Decoder Tester (60970) Schraubterminal
- an PC über USB DecoderProgrammer (60971) angeschlossen (direkt, keine Verlängerung)
- MDT v3.6.0
--> Funktionstest i.O., geht alles | keine Änderungen am Mapping vorgenommen (Werkseinstellungen)

- Firmwareupgrade auf v.3.3.0.4 | keine Änderungen am Mapping vorgenommen (Werkseinstellungen)
--> Motor dreht sich nicht (alle AUX aus)
-> F0 (LV/LR) an: Motor dreht sich nicht (andere AUX aus)
-> F1 (AUX1) an: Motor dreht sich nicht (andere AUX aus)
-> F2 (AUX2) an: Motor dreht sich vorwärts/rückwärts (andere AUX aus)
-> F3 (Rangiergang) an: Motor dreht sich nicht (alle AUX aus)
-> F4 (ABV) an: Motor dreht sich nicht (alle AUX aus)
-> F5 (AUX3) an: Motor dreht sich vorwärts/rückwärts (andere AUX aus)
-> F6 (Aux4) an: Motor dreht sich vorwärts/rückwärts (andere AUX aus)
-> Ist AUX 2 oder 3 oder 4 an UND zusätzlich AUX 2 oder 3 oder 4 an: Motor dreht sich nicht
-> F0, F3 und F4 wirken sich nicht negativ aus, wenn der Motor läuft (Aux2, 3 oder 4 an)
Diese Testfolge wurde über MDT3.60/USB-DecoderProgrammer/MTester, sowie über die CS3 durchgeführt.

- Firmwaredowngrade auf v3.2.2.0 über CS3
--> Funktionstest i.O., geht alles | keine Änderungen am Mapping vorgenommen (Werkseinstellungen)

Es liegt also definitiv nicht am Mapping, da hier keines vorgenommen wurde. Ich habe jetzt auf diese Weise fünf mLD3 mit diesem reproduzierbaren Verhalten.
Märklin lässt den Vorgang durch deren Programmierer gerade prüfen.

Sofern es nur mich betrifft und sonst niemanden ist das ja für die Allgemeinheit nicht wichtig (Wir betreuen über 50.000 Windows Clients und da hat kaum einer mal dasselbe Problem wie der andere bei gleicher Konfiguration - kennt man also). Aber zumindest wäre ein Workarround durch Firmwaredowngrade gegeben, sofern noch jemand über das Problem stolpert.

Mein persönliches Fazit: Aktuell führe ich keine Firmwareupgrades höher als v3.2.2.0 durch und warte auf das Ergebnis der Analyse durch Märklin.
Wobei...ehrlich gesagt interssiert mich das Ergebnis auch nicht mehr wirklich, da ich eh beim Umstieg auf ESU bin und bereits zwei LoPi5 als Ersatz eingebaut habe. Die Märklin-Decoder (vor allem mSD3) kommen nur noch in die Loks vom Nachwuchs oder in die Sachen, welche verkauft werden - funktionstüchtig selbstredend!!


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail


vikr hat sich bedankt!
HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital

zuletzt bearbeitet 29.06.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#22 von Frank_E. , 30.06.2023 19:26

Hallo zusammen,

ich habe jetzt mal bei 2 mLD3 (mit MTC-Schnittstelle) unter Verwendung des Decoder-Programmers 60971 das Firmware-Update von Version 3.2.2.0 auf Version 3.3.0.4 durchgeführt.
Ergebnis: keine Probleme!
Beide Decoder haben die Decoder-Teilenummer 280229 (gemäß Root-Info nach dem Auslesen an meiner CS2).

Auch 5 meiner mSD3 (3 Nachrüst- und 2 Serien-Decoder, alle mit MTC) hatten in letzter Zeit bereits ohne Probleme unter Verwendung des Decoder-Programmers 60971 das Update auf 3.3.0.4 erhalten.

Der Decoder-Tester 60970 ist bei mir übrigens nicht im Spiel. Ich habe den nicht.

Viele Grüße
Frank


sirz-moba, Michael Knop und Ludwig47 haben sich bedankt!
 
Frank_E.
InterCity (IC)
Beiträge: 525
Registriert am: 22.11.2009
Spurweite H0
Stromart Digital

zuletzt bearbeitet 01.07.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#23 von hu.ms , 01.07.2023 08:57

Zitat von HelbigR im Beitrag #21

Wobei...ehrlich gesagt interssiert mich das Ergebnis auch nicht mehr wirklich, da ich eh beim Umstieg auf ESU bin und bereits zwei LoPi5 als Ersatz eingebaut habe. Die Märklin-Decoder (vor allem mSD3) kommen nur noch in die Loks vom Nachwuchs oder in die Sachen, welche verkauft werden - funktionstüchtig selbstredend!!

Was ist der grund für den wechsel auf esu-decoder ?

Hubert


Mein anlagenneubau: https://stummiforum.de/viewtopic.php?f=15&t=140152
Meine fahrzeugverbesserungen: https://stummiforum.de/viewtopic.php?f=27&t=132888

Fahre moba und ID.3 mit selbst produzierten PV-strom.


 
hu.ms
Trans Europ Express (TEE)
Beiträge: 8.673
Registriert am: 22.09.2007
Ort: in den Alpen
Gleise K-Gleis
Spurweite H0
Steuerung CS3, CS2, LoDi-Con, DCC + mfx + MM
Stromart Digital


RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#24 von vikr , 01.07.2023 09:53

Hallo Frank,

Zitat von Frank_E. im Beitrag #22
ich habe jetzt mal bei 2 mLD3 (mit MTC-Schnittstelle) unter Verwendung des Decoder-Programmers 60971 das Firmware-Update von Version 3.2.2.0 auf Version 3.3.0.4 durchgeführt. Ergebnis: keine Probleme!
nun macht man Updates ja eigentlich nicht wegen der Möglichkeit problemlos Updates zu machen.
Was hast Du denn im Alltagsbetrieb mit diesem upgedateten Decoder alles getestet, so dass Du zu dieser uneingeschränkt positiven Bewertung gelangen kannst?
Gibt es etwas was besser funktioniert als vorher, so dass sich das Update lohnt?

MfG

vik


im Übrigen - Märklin am liebsten ohne Pukos, z.B. als Trix


vikr  
vikr
ICE-Sprinter
Beiträge: 6.497
Registriert am: 23.10.2011
Gleise M, C u. K.
Spurweite H0, N
Stromart Digital, Analog

zuletzt bearbeitet 01.07.2023 | Top

RE: Märklin mLD3 - Motor dreht sich nur, wenn AUX2 an ist

#25 von HelbigR , 01.07.2023 10:56

Auf welchem Betriebssystem läuft bei euch den das MDT? Ich nutze W11x64 22H2 - vielleicht ist ja da ein Unterschied.

Zitat von vikr im Beitrag #24
nun macht man Updates ja eigentlich nicht wegen der Möglichkeit problemlos Updates zu machen.

War jetzt nicht an mich die Frage, aber ich habe denoch Senf dazu:
Ich habe das hier bspw. gemacht, da in der vorhandenen FW des Decoders logische Funktionen fehlten und erst die neuere bspw. UND mitbrachte, was ich für mein Mapping benötige.
Andere Decoder hatte so eine alte FW, dass ab MDT3.50 die Projekte eine andere FW-Struktur bemängelten und sich ohne FW-Update nicht aufspielen liesen.



Changelog zu v3.2.2.0:
Version: 3.3.0.4 (14. November 2022)
Feature: Neue CV258 im Indexbereich CV31=17 CV32=0 liefert die Nummer der nächsten freien Funktionszuweisung
Feature: Der PID-Regler kann in Lastsituationen mehr Leistung an den Motor abgeben
Improvement: Bei Nothalt wird jetzt aktiv gebremst.
Bugfix: Fehler, bei dem manche Loks beim konstanten Bremsen abrupt stehen geblieben sind wurde behoben
Bugfix: Ausgangsmodus "Neon" stört nicht mehr die anderen Ausgänge
Bugfix: Der DCC-ACK-Impuls beim Lesen von SUSI-CVs wird jetzt korrekt generiert
Bugfix: Verbesserung beim mfx-Empfang und Struktur
Bugfix: Ein Fehler bei dem die Konfiguration an der CS2 abgebrochen wurde, wurde behoben
Bugfix: Schreiben der CV900 mit Wert 8 wird jetzt korrekt an ein angeschlossenes SUSI-Soundmodul weitergegeben (Werkseinstellungen wiederherstellen)
Bugfix: Fehler im Ausgangsverhalten korrigiert wenn Ein- und Ausschaltdelay gleichzeitig in einem Ausgang konfiguriert war
Bugfix: Fehler behoben der Tests am Tool verhindert hat wenn mfx deaktiviert war
Bugfix: Wenn der Decoder in DCC aufwacht, werden die Funktionen F29, F30 und F31 ausgeschaltet falls sie aktiv waren
Bugfix: Fehler korrigiert, der die korrekte Funktion eines Ausgangs im Modus "Pufferbetrieb" verhindert hat
Bugfix: Fehler im Pufferbetrieb bei ungeregeltem Motor behoben
Bugfix: Wenn Überbrückungsweg von 0 konfiguriert ist wird jetzt überbrückt bis der Puffer leer ist
Bugfix: Fehler beim Anhalten in der Bremsstrecke beseitigt
Bugfix: Fehler korrigiert der das Lesen von CV19 nachdem es gesetzt wurde verhindert hat.
Bugfix: Fehler korrigiert der das Schreiben von CV19 auf 0 verhindert hat wenn es ungleich 0 war.
Bugfix: Filterung für konstanten Bremsweg verbessert.
Bugfix: Fehler beim konstanten Bremsweg behoben.
Bugfix: Fehler beim Anhalteweg im Pufferbetrieb behoben.
Maintenance: Die Anfahrkontrolle wurde überarbeitet

Da Offtopic nur unter dem Themenbenzug beantwortet:

Zitat von hu.ms im Beitrag #23
Zitat von HelbigR im Beitrag #21

Wobei...ehrlich gesagt interssiert mich das Ergebnis auch nicht mehr wirklich, da ich eh beim Umstieg auf ESU bin und bereits zwei LoPi5 als Ersatz eingebaut habe. Die Märklin-Decoder (vor allem mSD3) kommen nur noch in die Loks vom Nachwuchs oder in die Sachen, welche verkauft werden - funktionstüchtig selbstredend!!

Was ist der grund für den wechsel auf esu-decoder ?

Hubert


Ich wollte damals eine 218 mit Sound und hatte mir beim Wiedereinstieg mSD3 geholt - hat mich nicht gerade umgehauen, aber für um die 65€ waren die halt preislich relativ attraktiv. Aber nachdem ich immer wieder mal ESU-Loks angehört hatte habe ich einen LokSound5 (mit ZIMO LS) verbaut - persönliche Meinung: Absolut genial, dagegen ist Märklin Dosenspielzeug-Sound! Also schon einmal die mSD3 nach und nach gegen LokSound5 ersetzt. Da mir bei denen das Fahrverhalten so immens viel besser gefallen hat (kein "Märklin"-Ruck mehr beim anfahren oder Beschleunigen, Alternative Last, Schwere Last, Getriebeausgleich) und diese mehr AUX bieten habe ich auch die LokPilot5 geholt. Bisher bereue ich es keine Sekunde. Das einzige, was ein mSD3 besser kann: Die Equalizerfunktion - Da kann man etwas Bass rausholen. Aber was bringt es, wenn der Sound ansonsten (mich persönlich) enttäuscht (vergleicht man nur BR182/Taurus die Tonleiter - für mich ein Witz bei Märklin, Toll dagegen bei ESU).

Alleine ein Beispiel:
Mit mLD3 in baugleichen, gleichalten Märklin Loks (2021) habe ich ewig an den Motoreinstellungen geschraubt für eine Traktion und es dann sein lassen und mich für die Dummy-Lösung entschieden. War einfach nicht anzugleichen. In zwei PIKO Expert 185er (bei denen ursprünglich die beiden mLD3 drin waren und der ganze Spaß hier begann) jetzt zwei LokPilot rein und die fahren ad-hoc zu 98% identisch.


h03S2L, Märklin CS3, CC-Schnitte, RaspberryPi mit RocRail

Angefügte Bilder:
Sie haben nicht die nötigen Rechte, um die angehängten Bilder zu sehen

HelbigR  
HelbigR
S-Bahn (S)
Beiträge: 22
Registriert am: 15.01.2021
Spurweite H0, Z
Steuerung RocRail
Stromart Digital

zuletzt bearbeitet 02.07.2023 | Top

   

Roco 43945 - VT 98 öffnen
NEUHEIT Piko 52492 Nohab Strabag komisches Verhalten

  • Ähnliche Themen
    Antworten
    Zugriffe
    Letzter Beitrag
Xobor Einfach ein eigenes Forum erstellen
Datenschutz